summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-02-14 12:11:43 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-02-14 12:11:43 +0000
commit7450fde1c7af483d17b1d8fd532c0e178172913d (patch)
treec9d04f320983a6f3276ab3510cae642095ee75fa /dev-tex
parentAdd ~x86-fbsd (diff)
downloadgentoo-2-7450fde1c7af483d17b1d8fd532c0e178172913d.tar.gz
gentoo-2-7450fde1c7af483d17b1d8fd532c0e178172913d.tar.bz2
gentoo-2-7450fde1c7af483d17b1d8fd532c0e178172913d.zip
version bump
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/bibtex2html/ChangeLog9
-rw-r--r--dev-tex/bibtex2html/bibtex2html-1.97.ebuild58
2 files changed, 65 insertions, 2 deletions
diff --git a/dev-tex/bibtex2html/ChangeLog b/dev-tex/bibtex2html/ChangeLog
index d84071b327e5..97fd0b02284b 100644
--- a/dev-tex/bibtex2html/ChangeLog
+++ b/dev-tex/bibtex2html/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/bibtex2html
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtex2html/ChangeLog,v 1.26 2011/10/05 19:07:15 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtex2html/ChangeLog,v 1.27 2012/02/14 12:11:43 aballier Exp $
+
+*bibtex2html-1.97 (14 Feb 2012)
+
+ 14 Feb 2012; Alexis Ballier <aballier@gentoo.org> +bibtex2html-1.97.ebuild:
+ version bump
05 Oct 2011; Alexis Ballier <aballier@gentoo.org> bibtex2html-1.96.ebuild:
remove ptex dep as it is going away
diff --git a/dev-tex/bibtex2html/bibtex2html-1.97.ebuild b/dev-tex/bibtex2html/bibtex2html-1.97.ebuild
new file mode 100644
index 000000000000..688aba922e9b
--- /dev/null
+++ b/dev-tex/bibtex2html/bibtex2html-1.97.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtex2html/bibtex2html-1.97.ebuild,v 1.1 2012/02/14 12:11:43 aballier Exp $
+
+EAPI=2
+
+inherit eutils
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A bibtex to HTML converter"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/bibtex2html/${P}.tar.gz"
+HOMEPAGE="http://www.lri.fr/~filliatr/bibtex2html/"
+
+SLOT="0"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+RESTRICT="test"
+
+# With use doc we need a latex compiler to generate manual.pdf
+# hevea is used for manual.html
+# manual.tex needs fullpage.sty
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
+ doc? ( virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-tex/hevea )"
+# We need tex-base for bibtex but also some bibtex styles, so we use latex-base
+RDEPEND="virtual/latex-base"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.88-destdir.patch"
+ # Avoid pre-stripped files
+ sed -i -e "s/strip/true/" Makefile.in
+ # For make install
+ use ocamlopt || sed -i 's/= opt /= noopt /' Makefile.in
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ if use ocamlopt ; then
+ emake opt || die
+ else
+ emake byte || die
+ fi
+ if use doc; then
+ emake doc || die "failed to create doc"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "failed to install"
+ dodoc README CHANGES || die
+ if use doc; then
+ dodoc manual.pdf || die
+ dohtml manual.html || die
+ fi
+}