summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-07-11 16:37:54 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-07-11 16:37:54 +0000
commita9cfbfc99fb38af2b31cc97d8d23f1a96e96f01c (patch)
treea67e61fb0c08fa5747fe7cd59b85a2a7f260b785 /dev-tex
parentFix e-mail. (diff)
downloadgentoo-2-a9cfbfc99fb38af2b31cc97d8d23f1a96e96f01c.tar.gz
gentoo-2-a9cfbfc99fb38af2b31cc97d8d23f1a96e96f01c.tar.bz2
gentoo-2-a9cfbfc99fb38af2b31cc97d8d23f1a96e96f01c.zip
Add compatibility package revtex-4, can be installed in parallel to revtex-4.1 (slotted)
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 94BFDF4484AD142F)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/revtex/ChangeLog11
-rw-r--r--dev-tex/revtex/revtex-4.ebuild39
2 files changed, 47 insertions, 3 deletions
diff --git a/dev-tex/revtex/ChangeLog b/dev-tex/revtex/ChangeLog
index 521efe8e544e..1a12ca13951e 100644
--- a/dev-tex/revtex/ChangeLog
+++ b/dev-tex/revtex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tex/revtex
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/revtex/ChangeLog,v 1.3 2011/08/12 17:36:04 tomka Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/revtex/ChangeLog,v 1.4 2013/07/11 16:37:54 dilfridge Exp $
+
+*revtex-4 (11 Jul 2013)
+
+ 11 Jul 2013; Andreas K. Huettel <dilfridge@gentoo.org> +revtex-4.ebuild:
+ Add compatibility package revtex-4, can be installed in parallel to revtex-4.1
+ (slotted)
12 Aug 2011; Thomas Kahle <tomka@gentoo.org> revtex-4.1_p2-r1.ebuild:
x86 stable per bug 371711
@@ -13,4 +19,3 @@
02 Oct 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+revtex-4.1_p2-r1.ebuild, +metadata.xml:
New package for up-to-date revtex4
-
diff --git a/dev-tex/revtex/revtex-4.ebuild b/dev-tex/revtex/revtex-4.ebuild
new file mode 100644
index 000000000000..253ff0152eba
--- /dev/null
+++ b/dev-tex/revtex/revtex-4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/revtex/revtex-4.ebuild,v 1.1 2013/07/11 16:37:54 dilfridge Exp $
+
+EAPI=5
+
+inherit latex-package
+
+DESCRIPTION="LaTeX2e macros for journals of the American Physical Society and the American Institute of Physics"
+HOMEPAGE="http://authors.aps.org/revtex4/"
+
+SRC_URI="http://authors.aps.org/revtex4/revtex4.zip"
+
+LICENSE="LPPL-1.3c"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-tex/natbib-8.31a"
+DEPEND="app-arch/unzip"
+
+IUSE=""
+
+S="${WORKDIR}/revtex4/src"
+
+TEXMF=/usr/share/texmf-site
+
+src_install() {
+ latex-package_src_install
+
+ # we need the revtex-specific rtx files in the same dir as the class files
+ insinto ${TEXMF}/tex/latex/${PN}
+ for i in `find . -maxdepth 1 -type f -name "*.rtx"` ; do
+ doins $i || die "doins $i failed"
+ done
+
+ # remove duplicate docu files to allow concurrent install with revtex-4.1
+ rm -fv "${ED}/${TEXMF}/doc/latex/revtex/"{ltxdocext.pdf,ltxgrid.pdf,ltxutil.pdf,ltxutil.dvi}
+ rm -fv "${ED}/usr/share/doc/${P}/"{textcase.dvi,revtex4.dvi,ltxgrid.dvi,ltxdocext.dvi}
+}