summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2013-10-29 14:58:48 +0000
committerDenis Dupeyron <calchan@gentoo.org>2013-10-29 14:58:48 +0000
commitf31869045c8490f3c889c9f4d075aea81817b90a (patch)
tree54659639a3826d017bed1c2caa4b1004413ad783 /dev-tex
parentsparc stable wrt bug #487028 (diff)
downloadgentoo-2-f31869045c8490f3c889c9f4d075aea81817b90a.tar.gz
gentoo-2-f31869045c8490f3c889c9f4d075aea81817b90a.tar.bz2
gentoo-2-f31869045c8490f3c889c9f4d075aea81817b90a.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/circuit_macros/ChangeLog7
-rw-r--r--dev-tex/circuit_macros/circuit_macros-7.7.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-tex/circuit_macros/ChangeLog b/dev-tex/circuit_macros/ChangeLog
index c6019b4b5dd3..0fe88aaa30ef 100644
--- a/dev-tex/circuit_macros/ChangeLog
+++ b/dev-tex/circuit_macros/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/circuit_macros
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/circuit_macros/ChangeLog,v 1.2 2013/07/04 00:11:03 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/circuit_macros/ChangeLog,v 1.3 2013/10/29 14:58:48 calchan Exp $
+
+*circuit_macros-7.7 (29 Oct 2013)
+
+ 29 Oct 2013; Denis Dupeyron <calchan@gentoo.org> +circuit_macros-7.7.ebuild:
+ Version bump.
*circuit_macros-7.6 (04 Jul 2013)
diff --git a/dev-tex/circuit_macros/circuit_macros-7.7.ebuild b/dev-tex/circuit_macros/circuit_macros-7.7.ebuild
new file mode 100644
index 000000000000..3cc9bda433d4
--- /dev/null
+++ b/dev-tex/circuit_macros/circuit_macros-7.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/circuit_macros/circuit_macros-7.7.ebuild,v 1.1 2013/10/29 14:58:48 calchan Exp $
+
+EAPI=5
+
+inherit unpacker texlive-common
+
+DESCRIPTION="M4 Macros for Electric circuit diagrams in TeX or LaTeX"
+HOMEPAGE="https://ece.uwaterloo.ca/~aplevich/Circuit_macros/"
+SRC_URI="http://mirrors.ctan.org/graphics/circuit_macros.zip -> circuit_macros-${PV}.zip"
+
+LICENSE="LPPL-1.3c"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +script"
+
+DEPEND=""
+RDEPEND="|| ( app-text/texlive[graphics] app-text/texlive[pstricks] )
+ media-gfx/dpic
+ sys-devel/m4
+ script? ( app-text/texlive[graphics]
+ dev-texlive/texlive-latexextra )"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins *.m4
+ insinto /usr/share/texmf-site/tex/latex/${PN}
+ doins boxdims.sty
+ dodoc README CHANGES Makefile doc/CMman.pdf
+ rm -f doc/CMman.pdf
+ use doc && dodoc -r doc
+ use examples && dodoc -r examples
+ use script && dobin "${FILESDIR}/CM2pdf"
+ docompress -x \
+ /usr/share/doc/${PF}/Makefile \
+ /usr/share/doc/${PF}/doc \
+ /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ etexmf-update
+ use script && einfo "CM2pdf was installed to automatically create PDFs"
+}
+
+pkg_postrm() {
+ etexmf-update
+}