summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandro Bonazzola <sanchan@gentoo.org>2006-12-26 12:01:32 +0000
committerSandro Bonazzola <sanchan@gentoo.org>2006-12-26 12:01:32 +0000
commitfb5206eb980cea5771a760732e5e396ca3eb1b05 (patch)
treeec754af62fcfd6602ac00476ec1092df91198ed9 /dev-tinyos/nesc
parentAdd ~x86-fbsd keyword. (diff)
downloadgentoo-2-fb5206eb980cea5771a760732e5e396ca3eb1b05.tar.gz
gentoo-2-fb5206eb980cea5771a760732e5e396ca3eb1b05.tar.bz2
gentoo-2-fb5206eb980cea5771a760732e5e396ca3eb1b05.zip
version bump
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'dev-tinyos/nesc')
-rw-r--r--dev-tinyos/nesc/ChangeLog7
-rw-r--r--dev-tinyos/nesc/files/digest-nesc-1.2.8a3
-rw-r--r--dev-tinyos/nesc/nesc-1.2.8a.ebuild84
3 files changed, 93 insertions, 1 deletions
diff --git a/dev-tinyos/nesc/ChangeLog b/dev-tinyos/nesc/ChangeLog
index cb3dd5756540..1f334c19b7c7 100644
--- a/dev-tinyos/nesc/ChangeLog
+++ b/dev-tinyos/nesc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tinyos/nesc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/ChangeLog,v 1.13 2006/12/04 21:41:00 sanchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/ChangeLog,v 1.14 2006/12/26 12:01:32 sanchan Exp $
+
+*nesc-1.2.8a (26 Dec 2006)
+
+ 26 Dec 2006; Sandro Bonazzola <sanchan@gentoo.org> +nesc-1.2.8a.ebuild:
+ Version bump.
*nesc-1.2.8 (04 Dec 2006)
diff --git a/dev-tinyos/nesc/files/digest-nesc-1.2.8a b/dev-tinyos/nesc/files/digest-nesc-1.2.8a
new file mode 100644
index 000000000000..8e97cc164d60
--- /dev/null
+++ b/dev-tinyos/nesc/files/digest-nesc-1.2.8a
@@ -0,0 +1,3 @@
+MD5 cc813b3dfc5a6017fee4c666bacf6a70 nesc-1.2.8a.tar.gz 1164285
+RMD160 2f7f615c64bd15701f14fe85e3c559ea2e6d2f55 nesc-1.2.8a.tar.gz 1164285
+SHA256 6ce67c0ee64dad5429f083c281ba933e39b4f2e80f800247d7ba07af65d41dec nesc-1.2.8a.tar.gz 1164285
diff --git a/dev-tinyos/nesc/nesc-1.2.8a.ebuild b/dev-tinyos/nesc/nesc-1.2.8a.ebuild
new file mode 100644
index 000000000000..64b79eab5161
--- /dev/null
+++ b/dev-tinyos/nesc/nesc-1.2.8a.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/nesc-1.2.8a.ebuild,v 1.1 2006/12/26 12:01:32 sanchan Exp $
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="An extension to gcc that knows how to compile nesC applications"
+HOMEPAGE="http://nescc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nescc/${P}.tar.gz"
+LICENSE="GPL-2 Intel"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+DEPEND=">=dev-lang/perl-5.8.5-r2
+ >=dev-tinyos/tos-1.1.0
+ >=virtual/jdk-1.4.2"
+
+RDEPEND=">=dev-lang/perl-5.8.5-r2
+ >=dev-tinyos/tos-1.1.0
+ >=virtual/jre-1.4.2
+ dev-perl/XML-Simple
+ media-gfx/graphviz"
+
+pkg_setup() {
+ if [ -z "${TOSDIR}" ]
+ then
+ # best to make an assumption
+ export TOSDIR=/usr/src/tinyos-1.x/tos
+ fi
+
+ if [ ! -d "${TOSDIR}" ]
+ then
+ eerror "In order to compile nesc you have to set the"
+ eerror "\$TOSDIR environment properly."
+ eerror ""
+ eerror "You can achieve this by emerging >=dev-tinyos/tos-1.1.15"
+ eerror "or by exporting TOSDIR=\"path to your tinyos dir\""
+ die "Couldn't find a valid TinyOS home"
+ else
+ einfo "Building nesC for ${TOSDIR}"
+ fi
+
+ java-pkg-2_pkg_setup
+}
+
+src_compile() {
+ econf --disable-dependency-tracking || die "econf failed"
+ # language setting needed, otherwise gcc version
+ # will sometimes not be detected right
+ LANGUAGE=C emake || die "emake failed"
+}
+
+src_install() {
+ LANGUAGE=C einstall || die "einstall failed"
+
+ if use doc
+ then
+ dohtml -r -a html,jpg,pdf,txt doc/*
+ fi
+
+ newdoc README NEWS
+ newdoc tools/java/net/tinyos/nesc/dump/README README.dump
+ newdoc tools/java/net/tinyos/nesc/wiring/README README.wiring
+}
+
+pkg_postinst() {
+ elog "To install a nesC editor mode (currently, emacs, vim, kde):"
+ elog "Read /usr/share/ncc/editor-modes/<your-editor-name>/readme.txt"
+ elog ""
+ elog "To use nesC with the Atmel AVR processors or the TI MSP processors you"
+ elog "need the avr-gcc and msp430-gcc packages, and the corresponding GNU"
+ elog "binutils (avr-binutils and msp430-binutils respectively)."
+ elog "# emerge crossdev"
+ elog "# crossdev -t avr"
+ elog "# crossdev -t msp430"
+ elog ""
+ elog "You can use gcc <= 3.4.6 and binutils <= 2.16.1-r3 if you need $ in"
+ elog "symbol names on avr or you can pass the -fnesc-separator=__ option to"
+ elog "nescc (ncc if using TinyOS) to use __ rather than $ in generated code."
+ elog "Example: PFLAGS=\"-fnesc-separator=__\" make mica2"
+ elog "See the nescc man page for details."
+ ebeep 5
+ epause 5
+}