summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-11-04 21:57:45 +0000
committerPacho Ramos <pacho@gentoo.org>2010-11-04 21:57:45 +0000
commit63003241e89b83a7f20b64046c74aec3e9da8c2e (patch)
treedaa5101144bc3a8cbf49654c7a2c498bc0dfbe24 /dev-util/anjuta
parentVersion Bump (diff)
downloadgentoo-2-63003241e89b83a7f20b64046c74aec3e9da8c2e.tar.gz
gentoo-2-63003241e89b83a7f20b64046c74aec3e9da8c2e.tar.bz2
gentoo-2-63003241e89b83a7f20b64046c74aec3e9da8c2e.zip
Version bump for Gnome 2.32.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/anjuta')
-rw-r--r--dev-util/anjuta/ChangeLog15
-rw-r--r--dev-util/anjuta/anjuta-2.32.0.0.ebuild114
-rw-r--r--dev-util/anjuta/files/anjuta-2.32.0.0-automagic-vala.patch40
-rw-r--r--dev-util/anjuta/metadata.xml4
4 files changed, 172 insertions, 1 deletions
diff --git a/dev-util/anjuta/ChangeLog b/dev-util/anjuta/ChangeLog
index 8ab5d3ec99a4..e2319d8570cc 100644
--- a/dev-util/anjuta/ChangeLog
+++ b/dev-util/anjuta/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for dev-util/anjuta
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.121 2010/10/17 16:27:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.122 2010/11/04 21:57:44 pacho Exp $
+
+*anjuta-2.32.0.0 (04 Nov 2010)
+
+ 04 Nov 2010; Pacho Ramos <pacho@gentoo.org> +anjuta-2.32.0.0.ebuild,
+ +files/anjuta-2.32.0.0-automagic-vala.patch, metadata.xml:
+ Version bump for Gnome 2.32 with lots of fixed bugs and updated
+ translations. Uses python2 since upstream still doesn't support python3
+ yet (upstream bug #633786#c2), introspection.m4 needs to be present when
+ running eautoreconf (upstream bug #633730), vala support is no longer
+ automagic (upstream bug #633661), adds introspection and graphviz support
+ via their respective USE flags, stop making symbol-db optional since it's
+ a headache to maintain on major version bumps and upstream really
+ discourages it (upstream bug #621920).
17 Oct 2010; Raúl Porcel <armin76@gentoo.org> anjuta-2.30.2.1.ebuild:
sparc stable wrt #324077
diff --git a/dev-util/anjuta/anjuta-2.32.0.0.ebuild b/dev-util/anjuta/anjuta-2.32.0.0.ebuild
new file mode 100644
index 000000000000..79b457d080a3
--- /dev/null
+++ b/dev-util/anjuta/anjuta-2.32.0.0.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/anjuta-2.32.0.0.ebuild,v 1.1 2010/11/04 21:57:44 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+PYTHON_DEPEND="2"
+
+inherit autotools eutils gnome2 flag-o-matic multilib python
+
+DESCRIPTION="A versatile IDE for GNOME"
+HOMEPAGE="http://www.anjuta.org"
+SRC_URI="${SRC_URI} mirror://gentoo/introspection.m4.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="debug devhelp doc glade graphviz +introspection +sourceview subversion test vala"
+
+RDEPEND=">=dev-libs/glib-2.25.15
+ >=x11-libs/gtk+-2.20.0
+ >=dev-libs/dbus-glib-0.70
+ >=gnome-base/gconf-2.12
+ >=x11-libs/vte-0.13.1
+ >=dev-libs/libxml2-2.4.23
+ >=dev-libs/gdl-2.27.1
+ >=dev-libs/libunique-1
+
+ dev-libs/libxslt
+ >=dev-lang/perl-5
+ dev-perl/Locale-gettext
+ sys-devel/autogen
+
+ >=gnome-extra/libgda-4.1.6:4
+ dev-util/ctags
+
+ devhelp? (
+ >=dev-util/devhelp-0.22
+ >=net-libs/webkit-gtk-1 )
+ glade? ( >=dev-util/glade-3.6.7 )
+ graphviz? ( media-gfx/graphviz )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.6 )
+ subversion? (
+ >=dev-vcs/subversion-1.5.0
+ >=net-libs/neon-0.28.2
+ >=dev-libs/apr-1
+ >=dev-libs/apr-util-1 )
+ sourceview? ( >=x11-libs/gtksourceview-2.9.7 )
+ vala? ( >=dev-lang/vala-0.9.5:0.10 )"
+DEPEND="${RDEPEND}
+ !!dev-libs/gnome-build
+ >=sys-devel/gettext-0.14
+ >=dev-util/intltool-0.40.1
+ >=dev-util/pkgconfig-0.20
+ >=app-text/scrollkeeper-0.3.14-r2
+ >=app-text/gnome-doc-utils-0.3.2
+ dev-util/gtk-doc-am
+ gnome-base/gnome-common
+ doc? ( >=dev-util/gtk-doc-1.4 )
+ test? (
+ ~app-text/docbook-xml-dtd-4.1.2
+ ~app-text/docbook-xml-dtd-4.5 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog FUTURE MAINTAINERS NEWS README ROADMAP THANKS TODO"
+
+ if ! use sourceview; then
+ ewarn "You have disabled sourceview, which means you now have no editor"
+ fi
+
+ G2CONF="${G2CONF}
+ --docdir=/usr/share/doc/${PF}
+ $(use_enable debug)
+ $(use_enable devhelp plugin-devhelp)
+ $(use_enable glade plugin-glade)
+ $(use_enable graphviz)
+ $(use_enable introspection)
+ $(use_enable sourceview plugin-sourceview)
+ $(use_enable subversion plugin-subversion)
+ $(use_enable vala)"
+
+ # Conflics wiht -pg in a plugin, bug #266777
+ filter-flags -fomit-frame-pointer
+
+ python_set_active_version 2
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix automagic dep on vala
+ epatch "${FILESDIR}/${PN}-2.32.0.0-automagic-vala.patch"
+
+ # eautoreconf needs introspection.m4
+ mv "${WORKDIR}"/introspection.m4 . || die
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ AT_M4DIR="." eautoreconf
+}
+
+src_install() {
+ # Anjuta uses a custom rule to install DOCS, get rid of it
+ gnome2_src_install
+ rm -rf "${ED}"/usr/share/doc/${PN} || die "rm failed"
+ find "${ED}" -name "*.la" -delete || die "remove of la files failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog ""
+ elog "Some project templates may require additional development"
+ elog "libraries to function correctly. It goes beyond the scope"
+ elog "of this ebuild to provide them."
+}
diff --git a/dev-util/anjuta/files/anjuta-2.32.0.0-automagic-vala.patch b/dev-util/anjuta/files/anjuta-2.32.0.0-automagic-vala.patch
new file mode 100644
index 000000000000..fad756198b4e
--- /dev/null
+++ b/dev-util/anjuta/files/anjuta-2.32.0.0-automagic-vala.patch
@@ -0,0 +1,40 @@
+From bf96448d1a3d04b19c0e742a5541f8399fc374e0 Mon Sep 17 00:00:00 2001
+From: Pacho Ramos <pacho@condmat1.ciencias.uniovi.es>
+Date: Thu, 04 Nov 2010 09:37:19 +0000
+Subject: build: bgo#633661 - vala support is automagic
+
+---
+diff --git a/configure.in b/configure.in
+index 1fd6f03..1f40614 100644
+--- a/configure.in
++++ b/configure.in
+@@ -266,10 +266,23 @@ AM_CONDITIONAL(HAVE_PLUGIN_SOURCEVIEW, [test x$sourceview = xyes])
+ dnl Check for vala
+ dnl -------------------------------------------------------------
+
+-PKG_CHECK_MODULES(VALA,
+- [vala-0.10 >= $VALA_REQUIRED],
+- [enable_vala="yes"],
+- [enable_vala="no"])
++AC_ARG_ENABLE(vala,
++ AC_HELP_STRING([--disable-vala],[Disable vala support]),
++ [ if test "$enableval" = "no"; then
++ user_disabled_vala=1
++ fi ],
++ [ user_disabled_vala=0 ])
++
++AC_MSG_CHECKING(if vala support is disabled)
++if test "$user_disabled_vala" = 1; then
++ AC_MSG_RESULT(yes)
++ enable_vala="no"
++else
++ AC_MSG_RESULT(no)
++ enable_vala="yes"
++ PKG_CHECK_MODULES(VALA,
++ [vala-0.10 >= $VALA_REQUIRED])
++fi
+
+ if test x$enable_vala = xyes; then
+ AC_PATH_PROG(VALAC, valac, valac)
+--
+cgit v0.8.3.1
diff --git a/dev-util/anjuta/metadata.xml b/dev-util/anjuta/metadata.xml
index e1e3f8540fca..e041cff2a639 100644
--- a/dev-util/anjuta/metadata.xml
+++ b/dev-util/anjuta/metadata.xml
@@ -5,7 +5,11 @@
<use>
<flag name="devhelp">Enable devhelp integration</flag>
<flag name="glade">Build glade plugin for anjuta</flag>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
<flag name="sourceview">Build sourceview editing plugin for anjuta</flag>
<flag name="symbol-db">Enable symbol database plugin for anjuta</flag>
+ <flag name='vala'>Enable support for the Vala programming
+ language</flag>
</use>
</pkgmetadata>