summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-10-07 01:31:42 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-10-07 01:31:42 +0000
commit6c0455abfbcf588b6348cee8660243a2a1570a22 (patch)
treede2e43da0c8c77ca6e332a9a6c849b1d53416261 /dev-util/astyle
parentflag for astyle ti include libs with cli (diff)
downloadgentoo-2-6c0455abfbcf588b6348cee8660243a2a1570a22.tar.gz
gentoo-2-6c0455abfbcf588b6348cee8660243a2a1570a22.tar.bz2
gentoo-2-6c0455abfbcf588b6348cee8660243a2a1570a22.zip
overdue version bump and maintainer update
(Portage version: 2.1.3.11)
Diffstat (limited to 'dev-util/astyle')
-rw-r--r--dev-util/astyle/ChangeLog8
-rw-r--r--dev-util/astyle/astyle-1.21.ebuild59
-rw-r--r--dev-util/astyle/files/astyle-1.21-strip.patch21
-rw-r--r--dev-util/astyle/files/digest-astyle-1.213
-rw-r--r--dev-util/astyle/metadata.xml6
5 files changed, 93 insertions, 4 deletions
diff --git a/dev-util/astyle/ChangeLog b/dev-util/astyle/ChangeLog
index ff2071bc921b..a97728fa2b93 100644
--- a/dev-util/astyle/ChangeLog
+++ b/dev-util/astyle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/astyle
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.16 2007/02/09 03:00:38 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.17 2007/10/07 01:31:42 nerdboy Exp $
+
+*astyle-1.21 (07 Oct 2007)
+
+ 07 Oct 2007; Steve Arnold <nerdboy@gentoo.org>
+ +files/astyle-1.21-strip.patch, metadata.xml, +astyle-1.21.ebuild:
+ overdue version bump and maintainer update
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/dev-util/astyle/astyle-1.21.ebuild b/dev-util/astyle/astyle-1.21.ebuild
new file mode 100644
index 000000000000..bb7715fe228f
--- /dev/null
+++ b/dev-util/astyle/astyle-1.21.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+inherit eutils
+
+DESCRIPTION="Artistic Style is a reindenter and reformatter of C++, C and Java source code"
+HOMEPAGE="http://astyle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~ppc-macos ~sparc ~x86"
+IUSE="debug libs"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-${PV}-strip.patch
+}
+
+src_compile() {
+ cd build
+ local build_targets="release"
+ if use debug; then
+ build_targets="debug"
+ if use libs; then
+ build_targets="debug staticdebug shareddebug"
+ fi
+ else
+ if use libs; then
+ build_targets="release static shared"
+ fi
+ fi
+ make ${build_targets} || die "build failed"
+}
+
+src_install() {
+ if use debug; then
+ newbin bin/astyled astyle
+ if use libs; then
+ newlib.a bin/libastyled.a libastyle.a
+ # shared lib needs at least a soname patch
+ newlib.so bin/libastyled.so libastyle.so
+ fi
+ else
+ if use libs; then
+ dolib.a bin/libastyle.a
+ dolib.so bin/libastyle.so
+ fi
+ dobin bin/astyle
+ fi
+ dohtml doc/*.html
+}
diff --git a/dev-util/astyle/files/astyle-1.21-strip.patch b/dev-util/astyle/files/astyle-1.21-strip.patch
new file mode 100644
index 000000000000..06f9a46159b4
--- /dev/null
+++ b/dev-util/astyle/files/astyle-1.21-strip.patch
@@ -0,0 +1,21 @@
+diff -Naur astyle.orig/build/Makefile astyle/build/Makefile
+--- astyle.orig/build/Makefile 2007-06-14 17:28:24.000000000 +0200
++++ astyle/build/Makefile 2007-10-06 17:43:53.000000000 +0200
+@@ -83,7 +83,7 @@
+ release: astyle
+ astyle: $(OBJ)
+ @ mkdir -p $(bindir)
+- $(CXX) -s -o $(bindir)/$@ $^
++ $(CXX) -o $(bindir)/$@ $^
+ @ echo
+
+ debug: astyled
+@@ -95,7 +95,7 @@
+ shared: libastyle.so
+ libastyle.so: $(OBJs)
+ @ mkdir -p $(bindir)
+- $(CXX) -shared -s -o $(bindir)/$@ $^
++ $(CXX) -shared -o $(bindir)/$@ $^
+ @ echo
+
+ shareddebug: libastyled.so
diff --git a/dev-util/astyle/files/digest-astyle-1.21 b/dev-util/astyle/files/digest-astyle-1.21
new file mode 100644
index 000000000000..4ba89d3583e1
--- /dev/null
+++ b/dev-util/astyle/files/digest-astyle-1.21
@@ -0,0 +1,3 @@
+MD5 c3e2068e9bf64bcad3e1d69628c4d241 astyle_1.21_linux.tar.gz 81678
+RMD160 929134074557865b95d25b84093851a9240f65ac astyle_1.21_linux.tar.gz 81678
+SHA256 894ed6838e61977ee846c219c0e0caa2eaf3f6d9f1df4ed354a8cd45c32d0ec2 astyle_1.21_linux.tar.gz 81678
diff --git a/dev-util/astyle/metadata.xml b/dev-util/astyle/metadata.xml
index a7ec0b429790..fb77ba8abe2e 100644
--- a/dev-util/astyle/metadata.xml
+++ b/dev-util/astyle/metadata.xml
@@ -1,10 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
+<herd>dev-tools</herd>
<maintainer>
- <email>karltk@gentoo.org</email>
- <description>Temporary maintainer, looking for replacements</description>
+ <email>nerdboy@gentoo.org</email>
+ <description>Primary maintainer</description>
</maintainer>
<longdescription>