summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-03-27 15:06:09 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-03-27 15:06:09 +0000
commitbb977a27ccca3df1b12580ec687bc58b00586f85 (patch)
tree5e4c1b1fdfcc290e4d02027fc4323f66f587a02d /dev-util/bam/bam-0.4.0.ebuild
parentx86 stable wrt bug #409213 (diff)
downloadgentoo-2-bb977a27ccca3df1b12580ec687bc58b00586f85.tar.gz
gentoo-2-bb977a27ccca3df1b12580ec687bc58b00586f85.tar.bz2
gentoo-2-bb977a27ccca3df1b12580ec687bc58b00586f85.zip
Version bump to 0.4.0 Bug #357865
Improve pyhton related code. Bug #324371 (Portage version: 2.1.10.51/cvs/Linux i686)
Diffstat (limited to 'dev-util/bam/bam-0.4.0.ebuild')
-rw-r--r--dev-util/bam/bam-0.4.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/bam/bam-0.4.0.ebuild b/dev-util/bam/bam-0.4.0.ebuild
new file mode 100644
index 000000000000..7e450080e644
--- /dev/null
+++ b/dev-util/bam/bam-0.4.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bam/bam-0.4.0.ebuild,v 1.1 2012/03/27 15:06:09 tupone Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="Fast and flexible Lua-based build system"
+HOMEPAGE="http://matricks.github.com/bam/"
+SRC_URI="http://github.com/downloads/matricks/${PN}/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-lang/lua"
+DEPEND="${RDEPEND}
+ doc? ( dev-lang/python )
+ test? ( dev-lang/python )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ cp "${FILESDIR}"/${PV}/Makefile "${S}"/Makefile || die "cp failed"
+ epatch "${FILESDIR}"/${PV}/${P}-test.py.patch
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() {
+ emake ${PN} || die
+
+ if use doc; then
+ $(PYTHON) scripts/gendocs.py || die "doc generation failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN} || die
+
+ if use doc; then
+ dohtml docs/${PN}{.html,_logo.png} || die "dohtml failed"
+ fi
+}