summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-02-13 14:03:16 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-02-13 14:03:16 +0000
commit892585c2d95ce4f64327d7dd7e2efcb46a39a15b (patch)
treed4e43a95ac88abfc2dbe588c807a714e533edcf5 /dev-util/boost-build/boost-build-1.34.1.ebuild
parentInitial import. Closing bug #54161. Thanks Tim Cera <timcera@earthlink.net> f... (diff)
downloadgentoo-2-892585c2d95ce4f64327d7dd7e2efcb46a39a15b.tar.gz
gentoo-2-892585c2d95ce4f64327d7dd7e2efcb46a39a15b.tar.bz2
gentoo-2-892585c2d95ce4f64327d7dd7e2efcb46a39a15b.zip
Added python USE-flag. Adding LDFLAGS to LIBS to fix bug #209794 (see ebuild for more info).
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util/boost-build/boost-build-1.34.1.ebuild')
-rw-r--r--dev-util/boost-build/boost-build-1.34.1.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-util/boost-build/boost-build-1.34.1.ebuild b/dev-util/boost-build/boost-build-1.34.1.ebuild
index 4ee98863f1ab..c13d7f71e3f9 100644
--- a/dev-util/boost-build/boost-build-1.34.1.ebuild
+++ b/dev-util/boost-build/boost-build-1.34.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.34.1.ebuild,v 1.10 2008/02/05 15:40:06 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.34.1.ebuild,v 1.11 2008/02/13 14:03:16 dev-zero Exp $
inherit flag-o-matic toolchain-funcs versionator
@@ -13,9 +13,10 @@ SRC_URI="mirror://sourceforge/boost/boost_${MY_PV}.tar.bz2"
LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
-IUSE=""
+IUSE="python"
-DEPEND="!<dev-libs/boost-1.34.0"
+DEPEND="!<dev-libs/boost-1.34.0
+ python? ( dev-lang/python )"
RDEPEND=""
S=${WORKDIR}/boost_${MY_PV}/tools
@@ -53,7 +54,13 @@ src_compile() {
append-flags -fno-strict-aliasing
- CC=$(tc-getCC) ./build.sh ${toolset} || die "building bjam failed"
+ # The build.jam file for building bjam using a bootstrapped jam0 ignores
+ # the LDFLAGS env var (bug #209794). We have now two options:
+ # a) change the cc-target definition in build.jam to include separate compile
+ # and link targets to make it use the LDFLAGS var, or
+ # b) a simple dirty workaround by injecting the LDFLAGS in the LIBS env var
+ # (which should not be set by us).
+ LIBS="${LDFLAGS}" CC=$(tc-getCC) ./build.sh ${toolset} $(use_with python) || die "building bjam failed"
}
src_install() {