summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-11 13:10:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-11 13:10:51 +0000
commit729051a465537620c431aee29c09523efd09a5d8 (patch)
treeb65e2b7ce26341836ee2a66d5c86e7fdae33f849 /dev-util/bouml
parentStable on sparc (diff)
downloadgentoo-2-729051a465537620c431aee29c09523efd09a5d8.tar.gz
gentoo-2-729051a465537620c431aee29c09523efd09a5d8.tar.bz2
gentoo-2-729051a465537620c431aee29c09523efd09a5d8.zip
Version bump.
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'dev-util/bouml')
-rw-r--r--dev-util/bouml/ChangeLog9
-rw-r--r--dev-util/bouml/bouml-2.21.2.ebuild33
-rw-r--r--dev-util/bouml/files/digest-bouml-2.21.23
3 files changed, 43 insertions, 2 deletions
diff --git a/dev-util/bouml/ChangeLog b/dev-util/bouml/ChangeLog
index 2785721c7d82..35417a3619ff 100644
--- a/dev-util/bouml/ChangeLog
+++ b/dev-util/bouml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/bouml
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.17 2006/12/28 01:25:07 flameeyes Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.18 2007/01/11 13:10:51 flameeyes Exp $
+
+*bouml-2.21.2 (11 Jan 2007)
+
+ 11 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> +bouml-2.21.2.ebuild:
+ Version bump.
*bouml-2.21.1 (28 Dec 2006)
diff --git a/dev-util/bouml/bouml-2.21.2.ebuild b/dev-util/bouml/bouml-2.21.2.ebuild
new file mode 100644
index 000000000000..35a06b274dee
--- /dev/null
+++ b/dev-util/bouml/bouml-2.21.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-2.21.2.ebuild,v 1.1 2007/01/11 13:10:51 flameeyes Exp $
+
+inherit qt3 toolchain-funcs multilib eutils
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool box with C++, Java and Idl code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(qt_min_version 3)"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake QMAKE="${QTDIR}/bin/qmake" \
+ CC="$(tc-getCC) ${CFLAGS}" \
+ CXX="$(tc-getCXX) ${CXXFLAGS}" \
+ LINK="$(tc-getCXX) ${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/dev-util/bouml/files/digest-bouml-2.21.2 b/dev-util/bouml/files/digest-bouml-2.21.2
new file mode 100644
index 000000000000..3109aebae316
--- /dev/null
+++ b/dev-util/bouml/files/digest-bouml-2.21.2
@@ -0,0 +1,3 @@
+MD5 a6d66714afa44aff3428d7acdaac4165 bouml_2.21.2.tar.gz 3191665
+RMD160 851d203707299fe51cb233ef238ca3d7f1c37d93 bouml_2.21.2.tar.gz 3191665
+SHA256 4f7e02f7830b515da198e90e60cae12fb984c954e2992c0f07a3ff356124c182 bouml_2.21.2.tar.gz 3191665