summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-06-01 07:02:44 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-06-01 07:02:44 +0000
commit899382b0baf30cc898e25b02bdf98659786f8ea8 (patch)
tree41b77853964a4cec9e7c128fc999b434b851f1d7 /dev-util/build/build-0.3.9.ebuild
parentmarked x86 per bug 418451 (diff)
downloadgentoo-2-899382b0baf30cc898e25b02bdf98659786f8ea8.tar.gz
gentoo-2-899382b0baf30cc898e25b02bdf98659786f8ea8.tar.bz2
gentoo-2-899382b0baf30cc898e25b02bdf98659786f8ea8.zip
Version bump.
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/build/build-0.3.9.ebuild')
-rw-r--r--dev-util/build/build-0.3.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/build/build-0.3.9.ebuild b/dev-util/build/build-0.3.9.ebuild
new file mode 100644
index 000000000000..3a230f609ef5
--- /dev/null
+++ b/dev-util/build/build-0.3.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/build/build-0.3.9.ebuild,v 1.1 2012/06/01 07:02:44 dev-zero Exp $
+
+EAPI="4"
+
+inherit versionator
+
+DESCRIPTION="A massively-parallel software build system implemented on top of GNU make."
+HOMEPAGE="http://kolpackov.net/projects/build/"
+SLOT="$(get_version_component_range 1-2)"
+SRC_URI="http://www.codesynthesis.com/download/${PN}/${SLOT}/${P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ emake install_prefix="${D}/usr" install
+
+ dodoc documentation/[[:upper:]]*
+ dohtml -A xhtml documentation/*.{css,xhtml}
+
+ if use examples ; then
+ # preserving symlinks in the examples
+ cp -dpR examples "${D}/usr/share/doc/${PF}"
+ fi
+}