summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-04-23 05:47:50 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-04-23 05:47:50 +0000
commitd6d17ce990dc288e65441cc1e0193c8b83e69eb3 (patch)
tree3dbc9fc089590e0bb4f70752508c8edae4f87886 /dev-util/buildbot-slave
parentBump (diff)
downloadgentoo-2-d6d17ce990dc288e65441cc1e0193c8b83e69eb3.tar.gz
gentoo-2-d6d17ce990dc288e65441cc1e0193c8b83e69eb3.tar.bz2
gentoo-2-d6d17ce990dc288e65441cc1e0193c8b83e69eb3.zip
Bump
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/buildbot-slave')
-rw-r--r--dev-util/buildbot-slave/ChangeLog8
-rw-r--r--dev-util/buildbot-slave/buildbot-slave-0.8.6_p1.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-util/buildbot-slave/ChangeLog b/dev-util/buildbot-slave/ChangeLog
index 3cc332491d2e..8e87130ca7e2 100644
--- a/dev-util/buildbot-slave/ChangeLog
+++ b/dev-util/buildbot-slave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/buildbot-slave
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.22 2012/03/29 09:35:31 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.23 2012/04/23 05:47:50 patrick Exp $
+
+*buildbot-slave-0.8.6_p1 (23 Apr 2012)
+
+ 23 Apr 2012; Patrick Lauer <patrick@gentoo.org>
+ +buildbot-slave-0.8.6_p1.ebuild:
+ Bump
29 Mar 2012; Dirkjan Ochtman <djc@gentoo.org> -buildbot-slave-0.8.4.ebuild:
Remove old version.
diff --git a/dev-util/buildbot-slave/buildbot-slave-0.8.6_p1.ebuild b/dev-util/buildbot-slave/buildbot-slave-0.8.6_p1.ebuild
new file mode 100644
index 000000000000..05e00923703e
--- /dev/null
+++ b/dev-util/buildbot-slave/buildbot-slave-0.8.6_p1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/buildbot-slave-0.8.6_p1.ebuild,v 1.1 2012/04/23 05:47:50 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="trial buildslave"
+DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
+
+inherit distutils eutils
+
+DESCRIPTION="BuildBot Slave Daemon"
+HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools
+ >=dev-python/twisted-2
+ !!<dev-util/buildbot-0.8.1
+ !<dev-util/buildbot-0.8.3"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock )"
+
+PYTHON_MODNAME="buildslave"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_pkg_setup
+ enewuser buildbot
+}
+
+src_install() {
+ distutils_src_install
+
+ doman docs/buildslave.1 || die "doman failed"
+
+ newconfd "${FILESDIR}/buildslave.confd" buildslave || die "newconfd failed"
+ newinitd "${FILESDIR}/buildslave.initd" buildslave || die "newinitd failed"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "The \"buildbot\" user and the \"buildslave\" init script has been added"
+ elog "to support starting buildslave through Gentoo's init system. To use this,"
+ elog "set up your build slave following the documentation, make sure the"
+ elog "resulting directories are owned by the \"buildbot\" user and point"
+ elog "\"${ROOT}etc/conf.d/buildslave\" at the right location. The scripts can"
+ elog "run as a different user if desired. If you need to run more than one"
+ elog "build slave, just copy the scripts."
+}