summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-04-05 03:53:43 +0000
committerAron Griffis <agriffis@gentoo.org>2004-04-05 03:53:43 +0000
commitba849c74946119f4b0c0f48beefac6f1cab9994c (patch)
treebda05392654e2c7cd7d29ee5395ae7cb290ad93f /dev-util/byacc
parentremoved incorrect S (bug #46788); use sed -i; IUSE; error messages; tidy (Man... (diff)
downloadgentoo-2-ba849c74946119f4b0c0f48beefac6f1cab9994c.tar.gz
gentoo-2-ba849c74946119f4b0c0f48beefac6f1cab9994c.tar.bz2
gentoo-2-ba849c74946119f4b0c0f48beefac6f1cab9994c.zip
Add patch from Jaime Alvaro Moreno in bug 46233 to make byacc work correctly on ia64 and other 64-bit arches. Also modify the mkstemp patch to coexist with the new patch.
Diffstat (limited to 'dev-util/byacc')
-rw-r--r--dev-util/byacc/ChangeLog10
-rw-r--r--dev-util/byacc/byacc-1.9.ebuild7
-rw-r--r--dev-util/byacc/files/byacc-1.9-ia64.patch24
-rw-r--r--dev-util/byacc/files/mkstemp.patch9
4 files changed, 38 insertions, 12 deletions
diff --git a/dev-util/byacc/ChangeLog b/dev-util/byacc/ChangeLog
index 5cd5be11da28..66b35219ef8c 100644
--- a/dev-util/byacc/ChangeLog
+++ b/dev-util/byacc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/byacc
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/ChangeLog,v 1.2 2003/02/12 06:39:02 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/ChangeLog,v 1.3 2004/04/05 03:53:43 agriffis Exp $
+
+ 04 Apr 2004; Aron Griffis <agriffis@gentoo.org> byacc-1.9.ebuild,
+ files/byacc-1.9-ia64.patch, files/mkstemp.patch:
+ Add patch from Jaime Alvaro Moreno in bug 46233 to make byacc work correctly
+ on ia64 and other 64-bit arches. Also modify the mkstemp patch to coexist with
+ the new patch.
*byacc-1.9 (17 Dec 2002)
diff --git a/dev-util/byacc/byacc-1.9.ebuild b/dev-util/byacc/byacc-1.9.ebuild
index c7137a7eba70..f1d97de128b4 100644
--- a/dev-util/byacc/byacc-1.9.ebuild
+++ b/dev-util/byacc/byacc-1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/byacc-1.9.ebuild,v 1.6 2004/03/13 01:49:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/byacc-1.9.ebuild,v 1.7 2004/04/05 03:53:43 agriffis Exp $
inherit eutils
@@ -14,6 +14,11 @@ KEYWORDS="x86 ppc ia64 ~sparc ~alpha ~mips ~hppa"
src_compile() {
epatch ${FILESDIR}/mkstemp.patch
+
+ # The following patch fixes yacc to run correctly on ia64 (and
+ # other 64-bit arches). See bug 46233
+ epatch ${FILESDIR}/byacc-1.9-ia64.patch
+
make PROGRAM=byacc CFLAGS="${CFLAGS}" || die
}
diff --git a/dev-util/byacc/files/byacc-1.9-ia64.patch b/dev-util/byacc/files/byacc-1.9-ia64.patch
new file mode 100644
index 000000000000..c10e88541287
--- /dev/null
+++ b/dev-util/byacc/files/byacc-1.9-ia64.patch
@@ -0,0 +1,24 @@
+--- byacc-1.9/defs.h.busted Sat May 6 21:10:56 2000
++++ byacc-1.9/defs.h Sat May 6 21:11:22 2000
+@@ -1,7 +1,8 @@
+ #include <assert.h>
+ #include <ctype.h>
+ #include <stdio.h>
+-
++#include <string.h>
++#include <stdlib.h>
+
+ /* machine-dependent definitions */
+ /* the following definitions are for the Tahoe */
+@@ -280,10 +281,3 @@
+ extern int errno;
+
+
+-/* system functions */
+-
+-extern void free();
+-extern char *calloc();
+-extern char *malloc();
+-extern char *realloc();
+-extern char *strcpy();
+
diff --git a/dev-util/byacc/files/mkstemp.patch b/dev-util/byacc/files/mkstemp.patch
index a4a30a342078..f037e331fb5b 100644
--- a/dev-util/byacc/files/mkstemp.patch
+++ b/dev-util/byacc/files/mkstemp.patch
@@ -1,14 +1,5 @@
--- main.c.orig 2002-12-17 14:28:54.000000000 -0500
+++ main.c 2002-12-17 14:29:31.000000000 -0500
-@@ -57,7 +57,7 @@
- short **derives;
- char *nullable;
-
--extern char *mktemp();
-+extern char *mkstemp();
- extern char *getenv();
-
-
@@ -264,9 +264,9 @@
text_file_name[len + 5] = 't';
union_file_name[len + 5] = 'u';