summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2013-06-16 14:58:39 +0000
committerBrian Dolbec <dolsen@gentoo.org>2013-06-16 14:58:39 +0000
commit9cdf2c7abca96ac12467ef7399161c661916d088 (patch)
tree0d2ddf40aa586fba1dfd8eaa676a27f95512c384 /dev-util/catalyst
parentcorrect setuotools in deps wrt Bug #473278 (diff)
downloadgentoo-2-9cdf2c7abca96ac12467ef7399161c661916d088.tar.gz
gentoo-2-9cdf2c7abca96ac12467ef7399161c661916d088.tar.bz2
gentoo-2-9cdf2c7abca96ac12467ef7399161c661916d088.zip
Add new 3.0 development branch ebuild, remove catalyst_3 branch ebuild
(Portage version: 2.2.0_alpha179_p5/cvs/Linux x86_64, signed Manifest commit with key 0x65E309F2189DB0B8)
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/ChangeLog6
-rw-r--r--dev-util/catalyst/catalyst-2.9999.ebuild50
-rw-r--r--dev-util/catalyst/catalyst-3.9999.ebuild108
3 files changed, 55 insertions, 109 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index 23ec01872bca..36ee1202c7db 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.262 2013/04/13 07:04:57 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.263 2013/06/16 14:58:39 dolsen Exp $
+
+ 16 Jun 2013; Brian Dolbec <dolsen@gentoo.org> +catalyst-2.9999.ebuild,
+ -catalyst-3.9999.ebuild:
+ Add new 3.0 development branch live ebuild. Remove catalyst_3 live ebuild.
13 Apr 2013; Matt Turner <mattst88@gentoo.org> catalyst-9999.ebuild:
syslinux is only available on x86/amd64. Only require it there.
diff --git a/dev-util/catalyst/catalyst-2.9999.ebuild b/dev-util/catalyst/catalyst-2.9999.ebuild
new file mode 100644
index 000000000000..b451ee767753
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.9999.ebuild,v 1.11 2013/06/16 14:58:39 dolsen Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 git-2
+
+DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux."
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
+EGIT_MASTER="master"
+EGIT_BRANCH="3.0"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ccache doc kernel_linux"
+
+KEYWORDS=""
+
+DEPEND="app-text/asciidoc
+ >=dev-python/snakeoil-0.5.2"
+
+RDEPEND="app-arch/lbzip2
+ app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+python_prepare_all() {
+ python_export_best
+ echo VERSION="${PV}" "${PYTHON}" setup.py set_version
+ VERSION="${PV}" "${PYTHON}" setup.py set_version
+}
+
+python_compile_all() {
+ # build the man pages and docs
+ emake
+}
+
+python_install_all(){
+ distutils-r1_python_install_all
+ if use doc; then
+ dodoc files/HOWTO.html files/docbook-xsl.css
+ fi
+}
diff --git a/dev-util/catalyst/catalyst-3.9999.ebuild b/dev-util/catalyst/catalyst-3.9999.ebuild
deleted file mode 100644
index e05b74ddf0a0..000000000000
--- a/dev-util/catalyst/catalyst-3.9999.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-3.9999.ebuild,v 1.3 2012/11/02 16:06:10 zerochaos Exp $
-
-# catalyst-9999 -> latest Git
-# catalyst-2.9999 -> catalyst_2 branch from Git
-# catalyst-3.9999 -> catalyst_3 branch from Git
-# catalyst-VER -> normal catalyst release
-
-EAPI=3
-PYTHON_DEPEND="2"
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
- inherit git-2
- SRC_URI=""
- S="${WORKDIR}/${PN}"
- KEYWORDS=""
-
- case ${PV} in
- 2.9999) EGIT_BRANCH="catalyst_2" ;;
- 3.9999) EGIT_BRANCH="catalyst_3" ;;
- esac
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-fi
-inherit eutils multilib python
-
-DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
-HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
-
-LICENSE="GPL-2"
-SLOT="0"
-RESTRICT=""
-IUSE="ccache kernel_linux"
-
-DEPEND="app-text/asciidoc"
-RDEPEND="app-arch/lbzip2
- app-crypt/shash
- virtual/cdrtools
- ccache? ( dev-util/ccache )
- ia64? ( sys-fs/dosfstools )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
-
-pkg_setup() {
- if use ccache ; then
- einfo "Enabling ccache support for catalyst."
- else
- ewarn "By default, ccache support for catalyst is disabled."
- ewarn "If this is not what you intended,"
- ewarn "then you should add ccache to your USE."
- fi
- echo
- einfo "The template spec files are now installed by default. You can find"
- einfo "them under /usr/share/doc/${PF}/examples"
- einfo "and they are considered to be the authorative source of information"
- einfo "on catalyst."
- echo
- if [[ ${PV} == *9999* ]]; then
- ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
- ewarn "work-in-progress code. Be aware that it's likely that it will not"
- ewarn "be in a working state at any given point. Please do not file bugs"
- ewarn "until you have posted on the gentoo-catalyst mailing list and we"
- ewarn "have asked you to do so."
- fi
- python_set_active_version 2
-}
-
-src_prepare() {
- python_convert_shebangs 2 catalyst modules/catalyst_lock.py
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/${PN}
- exeinto /usr/$(get_libdir)/${PN}
- doexe catalyst || die "copying catalyst"
- if [[ ${PV} == 3.9999* ]]; then
- doins -r modules files || die "copying files"
- else
- doins -r arch modules livecd || die "copying files"
- fi
- for x in targets/*; do
- exeinto /usr/$(get_libdir)/${PN}/$x
- doexe $x/* || die "copying ${x}"
- done
- make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
- insinto /etc/catalyst
- doins files/catalyst.conf files/catalystrc || die "copying configuration"
- insinto /usr/share/doc/${PF}/examples
- doins examples/* || die
- dodoc README ChangeLog AUTHORS
- doman files/catalyst.1
- # Here is where we actually enable ccache
- use ccache && \
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst/catalyst.conf
- dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
- /etc/catalyst/catalyst.conf
-}
-
-pkg_postinst() {
- einfo "You can find more information about catalyst by checking out the"
- einfo "catalyst project page at:"
- einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
- echo
-}