summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-11-10 15:03:54 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-11-10 15:03:54 +0000
commitaf9d3525a0079be708f9e4c67c5796d19fdcc035 (patch)
tree6636d333bb4eed758c0ed7e8e076ea05f6d00dad /dev-util/cdiff/cdiff-0.9.3.ebuild
parentCleanup. (diff)
downloadgentoo-2-af9d3525a0079be708f9e4c67c5796d19fdcc035.tar.gz
gentoo-2-af9d3525a0079be708f9e4c67c5796d19fdcc035.tar.bz2
gentoo-2-af9d3525a0079be708f9e4c67c5796d19fdcc035.zip
Sync up 0.9.2, 0.9.3 and 9999 versions, as they were not edited together; changed src_test to python_test as requested by mgorny, fixes bug #489538.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-util/cdiff/cdiff-0.9.3.ebuild')
-rw-r--r--dev-util/cdiff/cdiff-0.9.3.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/dev-util/cdiff/cdiff-0.9.3.ebuild b/dev-util/cdiff/cdiff-0.9.3.ebuild
index 85b7fb9f574a..2b7256a916f0 100644
--- a/dev-util/cdiff/cdiff-0.9.3.ebuild
+++ b/dev-util/cdiff/cdiff-0.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cdiff/cdiff-0.9.3.ebuild,v 1.2 2013/10/13 08:33:11 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cdiff/cdiff-0.9.3.ebuild,v 1.3 2013/11/10 15:03:54 tomwij Exp $
EAPI="5"
@@ -9,13 +9,20 @@ DOCS=( CHANGES README.rst )
inherit distutils-r1
+if [[ "${PV}" != *"9999"* ]] ; then
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+else
+ KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/ymattw/cdiff.git"
+ inherit git-r3
+fi
+
DESCRIPTION="Colored, side-by-side diff terminal viewer."
HOMEPAGE="https://github.com/ymattw/${PN}"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
DEPEND="!app-misc/colordiff
dev-python/setuptools[${PYTHON_USEDEP}]
@@ -25,10 +32,10 @@ RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}"/${PN}-0.9.2-disable-unimportant-failing-test.patch )
-src_test() {
+python_test() {
python_export_best
${PYTHON} tests/test_cdiff.py || die "Unit tests failed."
./tests/regression.sh || die "Regression tests failed."
-} \ No newline at end of file
+}