summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2005-11-08 18:34:00 +0000
committerLisa M. Seelye <lisa@gentoo.org>2005-11-08 18:34:00 +0000
commit477b102d4b7b728492beb8ee9e312d82ecb6914d (patch)
tree64383e20315ec20f2391141cf9a3259dc82616a8 /dev-util/cmake
parentVersion bump (diff)
downloadgentoo-2-477b102d4b7b728492beb8ee9e312d82ecb6914d.tar.gz
gentoo-2-477b102d4b7b728492beb8ee9e312d82ecb6914d.tar.bz2
gentoo-2-477b102d4b7b728492beb8ee9e312d82ecb6914d.zip
version bump to solve bug #111881
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog8
-rw-r--r--dev-util/cmake/Manifest15
-rw-r--r--dev-util/cmake/cmake-2.2.2.ebuild48
-rw-r--r--dev-util/cmake/files/cmake-2.2.2-rpath-fix.patch11
-rw-r--r--dev-util/cmake/files/digest-cmake-2.2.21
5 files changed, 71 insertions, 12 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index f859b36f7872..905cf7890a8b 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cmake
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.26 2005/10/29 05:00:01 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.27 2005/11/08 18:34:00 lisa Exp $
+
+*cmake-2.2.2 (08 Nov 2005)
+
+ 08 Nov 2005; Lisa Seelye <lisa@gentoo.org>
+ +files/cmake-2.2.2-rpath-fix.patch, +cmake-2.2.2.ebuild:
+ version bump to solve bug #111881
29 Oct 2005; Daniel Goller <morfic@gentoo.org> cmake-2.2.1.ebuild:
Stable on amd64
diff --git a/dev-util/cmake/Manifest b/dev-util/cmake/Manifest
index 98b340203d55..ecbdf8ecd33b 100644
--- a/dev-util/cmake/Manifest
+++ b/dev-util/cmake/Manifest
@@ -1,21 +1,14 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 38c718a249b1bb0121915687975fbaad ChangeLog 4000
MD5 a1898a629719df413be3d7e90ed84322 cmake-2.0.6-r1.ebuild 1004
MD5 a959a6103f04ad2383ccec8c6d0936e8 cmake-2.2.0-r1.ebuild 1223
MD5 0c26b9e9e59ce6a1d2b04334add4e156 cmake-2.2.1.ebuild 1218
-MD5 c7008534123f6886fbc11f82417c0b39 metadata.xml 347
+MD5 0c26b9e9e59ce6a1d2b04334add4e156 cmake-2.2.2.ebuild 1218
MD5 cc142b07505b203f41d024728adb130f files/cmake-2.0.6-rpath-fix.patch 526
MD5 dd14e025d4b768e7ea416902ddc0b756 files/cmake-2.2.0-rpath-fix.patch 448
MD5 c47657a48f7a256e7cd145d89274b9f1 files/cmake-2.2.1-rpath-fix.patch 444
+MD5 4c641d177972ed1be807ccb36d2be4b1 files/cmake-2.2.2-rpath-fix.patch 468
MD5 beb07080ff2955d2e023b17bc15e6b67 files/digest-cmake-2.0.6-r1 64
MD5 6b3e76d4d01f10ed7f93bb39cc603f8c files/digest-cmake-2.2.0-r1 64
MD5 a1a51ec90e30f352bb6f0aa3822083e7 files/digest-cmake-2.2.1 64
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDYwHq/aM9DdBw91cRAtvDAKC+uuCYjBJUuEBn6340oSghYRX3wQCfSZKf
-NtsmbMbP6rue5Q71UyM/Hno=
-=aqmW
------END PGP SIGNATURE-----
+MD5 9368ae4e7af6a751bd768e05ac5ffbca files/digest-cmake-2.2.2 64
+MD5 c7008534123f6886fbc11f82417c0b39 metadata.xml 347
diff --git a/dev-util/cmake/cmake-2.2.2.ebuild b/dev-util/cmake/cmake-2.2.2.ebuild
new file mode 100644
index 000000000000..45df06b9c1fb
--- /dev/null
+++ b/dev-util/cmake/cmake-2.2.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.2.2.ebuild,v 1.1 2005/11/08 18:34:00 lisa Exp $
+
+inherit debug flag-o-matic qt3 toolchain-funcs eutils
+
+SHORT_PV=2.2
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v${SHORT_PV}/${P}.tar.gz"
+
+LICENSE="CMake"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-rpath-fix.patch
+ sed -i -e "s:g++:$(tc-getCXX):" \
+ ${S}/Modules/CMakeCXXInformation.cmake
+ sed -i -e "s:gcc:$(tc-getCC):" \
+ ${S}/Modules/CMakeCInformation.cmake
+}
+
+src_compile() {
+ strip-flags
+ ./bootstrap \
+ --prefix=/usr \
+ --docdir=/share/doc/${PN} \
+ --datadir=/share/${PN} \
+ --mandir=/share/man || die "./bootstrap failed"
+ emake -j1 || die
+}
+
+src_test() {
+ einfo "Self tests broken"
+ make test || \
+ einfo "note test failure on qtwrapping was expected - nature of portage rather than a true failure"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "install failed"
+ mv ${D}usr/share/doc/cmake ${D}usr/share/doc/${PF}
+}
diff --git a/dev-util/cmake/files/cmake-2.2.2-rpath-fix.patch b/dev-util/cmake/files/cmake-2.2.2-rpath-fix.patch
new file mode 100644
index 000000000000..263214117ce8
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.2.2-rpath-fix.patch
@@ -0,0 +1,11 @@
+--- cmake-2.2.2/Modules/CMakeGenericSystem.cmake.orig 2005-11-08 17:59:07.000000000 +0000
++++ cmake-2.2.2/Modules/CMakeGenericSystem.cmake 2005-11-08 17:59:22.000000000 +0000
+@@ -21,7 +21,7 @@
+ SET(CMAKE_SHARED_LIBRARY_CXX_FLAGS "-fPIC") # -pic
+ ENDIF(CMAKE_COMPILER_IS_GNUCXX)
+
+-SET (CMAKE_SKIP_RPATH "NO" CACHE BOOL
++SET (CMAKE_SKIP_RPATH "YES" CACHE BOOL
+ "If set, runtime paths are not added when using shared libraries.")
+
+ SET(CMAKE_INIT_VALUE FALSE)
diff --git a/dev-util/cmake/files/digest-cmake-2.2.2 b/dev-util/cmake/files/digest-cmake-2.2.2
new file mode 100644
index 000000000000..a94d42586e01
--- /dev/null
+++ b/dev-util/cmake/files/digest-cmake-2.2.2
@@ -0,0 +1 @@
+MD5 703ca45ea6fdd4600cde27827155bf20 cmake-2.2.2.tar.gz 2417339