summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2013-10-21 14:42:13 +0000
committerFabian Groffen <grobian@gentoo.org>2013-10-21 14:42:13 +0000
commit5acdd0982feab2145ce0811fc6a56d5bd20500af (patch)
tree106a921d206b29c22904573cdbe837e0b7f5dfde /dev-util/cmake
parentMove kde-base/drkonqi to USE="semantic-desktop". It hard depends on kde-base/... (diff)
downloadgentoo-2-5acdd0982feab2145ce0811fc6a56d5bd20500af.tar.gz
gentoo-2-5acdd0982feab2145ce0811fc6a56d5bd20500af.tar.bz2
gentoo-2-5acdd0982feab2145ce0811fc6a56d5bd20500af.zip
Fix compilation on Solaris
(Portage version: 2.2.7-prefix/cvs/SunOS i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog5
-rw-r--r--dev-util/cmake/cmake-2.8.12.ebuild7
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 7a260f7163bc..36aac897d3ed 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.256 2013/10/21 03:27:53 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.257 2013/10/21 14:42:13 grobian Exp $
+
+ 21 Oct 2013; Fabian Groffen <grobian@gentoo.org> cmake-2.8.12.ebuild:
+ Fix compilation on Solaris
*cmake-2.8.12 (21 Oct 2013)
diff --git a/dev-util/cmake/cmake-2.8.12.ebuild b/dev-util/cmake/cmake-2.8.12.ebuild
index 9001762975a3..11ffded9b954 100644
--- a/dev-util/cmake/cmake-2.8.12.ebuild
+++ b/dev-util/cmake/cmake-2.8.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.12.ebuild,v 1.1 2013/10/21 03:27:53 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.12.ebuild,v 1.2 2013/10/21 14:42:13 grobian Exp $
EAPI=5
@@ -82,6 +82,11 @@ cmake_src_bootstrap() {
par_arg="--parallel=1"
fi
+ # execinfo.h on Solaris isn't quite what it is on Darwin
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's/execinfo\.h/blablabla.h/' Source/kwsys/CMakeLists.txt || die
+ fi
+
tc-export CC CXX LD
# bootstrap script isn't exactly /bin/sh compatible