summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-07-10 20:30:55 +0000
committerJohannes Huber <johu@gentoo.org>2013-07-10 20:30:55 +0000
commita79ea928535a411126e3f63e1547f168de543ac6 (patch)
tree8aa397f7c9eb8ea2f5e05f77c6143067849b1d1f /dev-util/cmake
parentchanged the keyring dep to a use flag, good riddance (diff)
downloadgentoo-2-a79ea928535a411126e3f63e1547f168de543ac6.tar.gz
gentoo-2-a79ea928535a411126e3f63e1547f168de543ac6.tar.bz2
gentoo-2-a79ea928535a411126e3f63e1547f168de543ac6.zip
Format patch with dos2unix, bug #476064.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog6
-rw-r--r--dev-util/cmake/files/cmake-2.8.10.2-FindPythonLibs.patch48
2 files changed, 29 insertions, 25 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 3c0245d15970..6638da5e6e54 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.252 2013/06/14 17:17:22 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.253 2013/07/10 20:30:55 johu Exp $
+
+ 10 Jul 2013; Johannes Huber <johu@gentoo.org>
+ files/cmake-2.8.10.2-FindPythonLibs.patch:
+ Format patch with dos2unix, bug #476064.
14 Jun 2013; Michael Palimaka <kensington@gentoo.org> cmake-2.8.11.1.ebuild:
Fix tests by David Leverton <levertond@googlemail.com> wrt bug #467720.
diff --git a/dev-util/cmake/files/cmake-2.8.10.2-FindPythonLibs.patch b/dev-util/cmake/files/cmake-2.8.10.2-FindPythonLibs.patch
index 80cc4d38873f..2a83ff7abb69 100644
--- a/dev-util/cmake/files/cmake-2.8.10.2-FindPythonLibs.patch
+++ b/dev-util/cmake/files/cmake-2.8.10.2-FindPythonLibs.patch
@@ -1,24 +1,24 @@
-diff --git a/Modules/FindPythonLibs.cmake b/Modules/FindPythonLibs.cmake
-index bffa9fb..8fc90ee 100644
---- a/Modules/FindPythonLibs.cmake
-+++ b/Modules/FindPythonLibs.cmake
-@@ -74,6 +74,19 @@ set(_Python_VERSIONS
- ${_PYTHON_FIND_OTHER_VERSIONS}
- )
-
-+# Gentoo portage requires that you use exactly the given python version
-+if (CMAKE_BUILD_TYPE STREQUAL Gentoo)
-+ execute_process(COMMAND python -c "import sys; sys.stdout.write('.'.join([str(x) for x in sys.version_info[:2]]))"
-+ OUTPUT_VARIABLE _Gentoo_Python_VERSION)
-+ list(FIND _Python_VERSIONS "${_Gentoo_Python_VERSION}" _Gentoo_Python_INDEX)
-+ if (_Gentoo_Python_INDEX EQUAL -1)
-+ # the current Gentoo python version is not compatible with what is requested
-+ set(_Python_VERSIONS)
-+ else ()
-+ set(_Python_VERSIONS "${_Gentoo_Python_VERSION}")
-+ endif ()
-+endif()
-+
- unset(_PYTHON_FIND_OTHER_VERSIONS)
- unset(_PYTHON1_VERSIONS)
- unset(_PYTHON2_VERSIONS)
+diff --git a/Modules/FindPythonLibs.cmake b/Modules/FindPythonLibs.cmake
+index bffa9fb..8fc90ee 100644
+--- a/Modules/FindPythonLibs.cmake
++++ b/Modules/FindPythonLibs.cmake
+@@ -74,6 +74,19 @@ set(_Python_VERSIONS
+ ${_PYTHON_FIND_OTHER_VERSIONS}
+ )
+
++# Gentoo portage requires that you use exactly the given python version
++if (CMAKE_BUILD_TYPE STREQUAL Gentoo)
++ execute_process(COMMAND python -c "import sys; sys.stdout.write('.'.join([str(x) for x in sys.version_info[:2]]))"
++ OUTPUT_VARIABLE _Gentoo_Python_VERSION)
++ list(FIND _Python_VERSIONS "${_Gentoo_Python_VERSION}" _Gentoo_Python_INDEX)
++ if (_Gentoo_Python_INDEX EQUAL -1)
++ # the current Gentoo python version is not compatible with what is requested
++ set(_Python_VERSIONS)
++ else ()
++ set(_Python_VERSIONS "${_Gentoo_Python_VERSION}")
++ endif ()
++endif()
++
+ unset(_PYTHON_FIND_OTHER_VERSIONS)
+ unset(_PYTHON1_VERSIONS)
+ unset(_PYTHON2_VERSIONS)