summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-09-27 18:47:16 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-09-27 18:47:16 +0000
commitc10b1659243a193815748a91e9f8bb7a10a9290b (patch)
tree3ea2c73fd2d1d1a9721bebb20990528054943761 /dev-util/cmake
parentTemporaryly p.masked =dev-util/cmake-2.4.7-r2 for further testing and until x... (diff)
downloadgentoo-2-c10b1659243a193815748a91e9f8bb7a10a9290b.tar.gz
gentoo-2-c10b1659243a193815748a91e9f8bb7a10a9290b.tar.bz2
gentoo-2-c10b1659243a193815748a91e9f8bb7a10a9290b.zip
cmake-2.4.7-r2 now uses the system libraries during the bootstrap process instead of the bundled versions. Fixes bug 178999. Furthermore, it features a new FindSWIG.cmake module as provided by Axel Roebel on upstream bug 4145. Fixes our bug 192594.
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog11
-rw-r--r--dev-util/cmake/cmake-2.4.7-r2.ebuild90
-rw-r--r--dev-util/cmake/files/FindSWIG.cmake56
-rw-r--r--dev-util/cmake/files/digest-cmake-2.4.7-r23
4 files changed, 159 insertions, 1 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 58c047559d97..8660425490b3 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/cmake
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.63 2007/09/07 21:30:53 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.64 2007/09/27 18:47:16 philantrop Exp $
+
+*cmake-2.4.7-r2 (27 Sep 2007)
+
+ 27 Sep 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/FindSWIG.cmake, +cmake-2.4.7-r2.ebuild:
+ cmake-2.4.7-r2 now uses the system libraries during the bootstrap process
+ instead of the bundled versions. Fixes bug 178999. Furthermore, it features
+ a new FindSWIG.cmake module as provided by Axel Roebel on upstream bug 4145.
+ Fixes our bug 192594.
*cmake-2.4.7-r1 (07 Sep 2007)
diff --git a/dev-util/cmake/cmake-2.4.7-r2.ebuild b/dev-util/cmake/cmake-2.4.7-r2.ebuild
new file mode 100644
index 000000000000..0658da046739
--- /dev/null
+++ b/dev-util/cmake/cmake-2.4.7-r2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.7-r2.ebuild,v 1.1 2007/09/27 18:47:16 philantrop Exp $
+
+inherit elisp-common toolchain-funcs eutils versionator qt3 flag-o-matic
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="CMake"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs vim-syntax"
+
+DEPEND=">=net-misc/curl-7.16.4
+ >=dev-libs/expat-2.0.1
+ >=dev-libs/libxml2-2.6.28
+ >=dev-libs/xmlrpc-c-1.06.03
+ emacs? ( virtual/emacs )
+ vim-syntax? ( || (
+ app-editors/vim
+ app-editors/gvim ) )"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+VIMFILE="${PN}.vim"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Upstream patch to make sure KDE4 is found. cf. bug 191412.
+ epatch "${FILESDIR}/${P}-findkde4.patch"
+
+ # Upstream's version is broken. Reported in upstream bugs 3498, 3637, 4145.
+ # Fixed version kindly provided on 4145 by Axel Roebel.
+ cp "${FILESDIR}/FindSWIG.cmake" "${S}/Modules/"
+}
+
+src_compile() {
+ cd "${S}"
+ tc-export CC CXX LD
+
+ append-ldflags -Wl,--no-as-needed
+
+ ./bootstrap \
+ --system-libs \
+ --prefix=/usr \
+ --docdir=/share/doc/${PN} \
+ --datadir=/share/${PN} \
+ --mandir=/share/man || die "./bootstrap failed"
+ emake || die
+ if use emacs; then
+ elisp-compile Docs/cmake-mode.el || die "elisp compile failed"
+ fi
+}
+
+src_test() {
+ einfo "Self tests broken"
+ make test || \
+ einfo "note test failure on qtwrapping was expected - nature of portage rather than a true failure"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ mv "${D}usr/share/doc/cmake" "${D}usr/share/doc/${PF}"
+ if use emacs; then
+ elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins "${S}"/Docs/cmake-syntax.vim
+
+ insinto /usr/share/vim/vimfiles/indent
+ doins "${S}"/Docs/cmake-indent.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}/${VIMFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cmake/files/FindSWIG.cmake b/dev-util/cmake/files/FindSWIG.cmake
new file mode 100644
index 000000000000..a3b650eb7d0c
--- /dev/null
+++ b/dev-util/cmake/files/FindSWIG.cmake
@@ -0,0 +1,56 @@
+# - Find SWIG
+# This module finds an installed SWIG. It sets the following variables:
+# SWIG_FOUND - set to true if SWIG is found
+# SWIG_DIR - the directory where swig is installed
+# SWIG_EXECUTABLE - the path to the swig executable
+# SWIG_VERSION - the version number of the swig executable
+#
+# All informations are collected from the SWIG_EXECUTABLE so the
+# version to be found can be changed from the command line by
+# means of setting SWIG_EXECUTABLE
+#
+
+SET(SWIG_FOUND FALSE)
+
+FIND_PROGRAM(SWIG_EXECUTABLE swig)
+
+IF(SWIG_EXECUTABLE)
+ EXECUTE_PROCESS(COMMAND ${SWIG_EXECUTABLE} -swiglib
+ OUTPUT_VARIABLE SWIG_swiglib_output
+ ERROR_VARIABLE SWIG_swiglib_error
+ RESULT_VARIABLE SWIG_swiglib_result)
+
+ IF(SWIG_swiglib_result)
+ MESSAGE(SEND_ERROR "Command \"${SWIG_EXECUTABLE} -swiglib\" failed with output:\n${SWIG_swiglib_error}")
+ ELSE(SWIG_swiglib_result)
+ STRING(REGEX REPLACE "[\n\r]+" ";" SWIG_swiglib_output ${SWIG_swiglib_output})
+ # force the path to be computed each time in case SWIG_EXECUTABLE has changed.
+ SET(SWIG_DIR SWIG_DIR-NOTFOUND)
+ FIND_PATH(SWIG_DIR swig.swg PATHS ${SWIG_swiglib_output})
+ IF(SWIG_DIR)
+ SET(SWIG_FOUND 1)
+ SET(SWIG_USE_FILE ${CMAKE_ROOT}/Modules/UseSWIG.cmake)
+ EXECUTE_PROCESS(COMMAND ${SWIG_EXECUTABLE} -version
+ OUTPUT_VARIABLE SWIG_version_output
+ ERROR_VARIABLE SWIG_version_output
+ RESULT_VARIABLE SWIG_version_result)
+ IF(SWIG_version_result)
+ MESSAGE(SEND_ERROR "Command \"${SWIG_EXECUTABLE} -version\" failed with output:\n${SWIG_version_output}")
+ ELSE(SWIG_version_result)
+ STRING(REGEX REPLACE ".*SWIG Version[^0-9.]*\([0-9.]+\).*" "\\1"
+ SWIG_version_output "${SWIG_version_output}")
+ SET(SWIG_VERSION ${SWIG_version_output} CACHE STRING "Swig version" FORCE)
+ ENDIF(SWIG_version_result)
+ ENDIF(SWIG_DIR)
+ ENDIF(SWIG_swiglib_result)
+ENDIF(SWIG_EXECUTABLE)
+
+IF(NOT SWIG_FOUND)
+ IF(NOT SWIG_FIND_QUIETLY)
+ IF(SWIG_FIND_REQUIRED)
+ MESSAGE(FATAL_ERROR "SWIG was not found. Please specify Swig executable location")
+ ELSE(SWIG_FIND_REQUIRED)
+ MESSAGE(STATUS "SWIG was not found. Please specify Swig executable location")
+ ENDIF(SWIG_FIND_REQUIRED)
+ ENDIF(NOT SWIG_FIND_QUIETLY)
+ENDIF(NOT SWIG_FOUND)
diff --git a/dev-util/cmake/files/digest-cmake-2.4.7-r2 b/dev-util/cmake/files/digest-cmake-2.4.7-r2
new file mode 100644
index 000000000000..159cbb370c75
--- /dev/null
+++ b/dev-util/cmake/files/digest-cmake-2.4.7-r2
@@ -0,0 +1,3 @@
+MD5 4476c423b8f74266136964e42ea88028 cmake-2.4.7.tar.gz 2600960
+RMD160 7fed176c42f39c25e1d4c761436aa4d5a8a64e3a cmake-2.4.7.tar.gz 2600960
+SHA256 2fd5feb294b933ae3a0071b8c7a396797cf79dfe6b0ffeff8788e07ff4107d56 cmake-2.4.7.tar.gz 2600960