summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-10-29 21:49:29 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-10-29 21:49:29 +0000
commitd611e8e7ec27ace966a1ba76fa5c4df3a25ccdf5 (patch)
tree79d60139035d852382e8070c9426fa4b2205c5cb /dev-util/cmake
parentmedia-gfx/blender: Bump scons dependency to 2.x (bug #372151) (diff)
downloadgentoo-2-d611e8e7ec27ace966a1ba76fa5c4df3a25ccdf5.tar.gz
gentoo-2-d611e8e7ec27ace966a1ba76fa5c4df3a25ccdf5.tar.bz2
gentoo-2-d611e8e7ec27ace966a1ba76fa5c4df3a25ccdf5.zip
Fix FindLAPACK, bug 388757
(Portage version: 2.1.10.31/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog9
-rw-r--r--dev-util/cmake/cmake-2.8.6-r2.ebuild (renamed from dev-util/cmake/cmake-2.8.6-r1.ebuild)4
-rw-r--r--dev-util/cmake/files/cmake-2.8.6-FindLAPACK-2.patch34
3 files changed, 44 insertions, 3 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 9e4ad1dac374..fc60de4d3dab 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.172 2011/10/19 21:10:58 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.173 2011/10/29 21:49:29 dilfridge Exp $
+
+*cmake-2.8.6-r2 (29 Oct 2011)
+
+ 29 Oct 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ -cmake-2.8.6-r1.ebuild, +cmake-2.8.6-r2.ebuild,
+ +files/cmake-2.8.6-FindLAPACK-2.patch:
+ Fix FindLAPACK, bug 388757
19 Oct 2011; Andreas K. Huettel <dilfridge@gentoo.org> cmake-2.8.6-r1.ebuild:
Fix java 7 sandbox violation, bug 387227
diff --git a/dev-util/cmake/cmake-2.8.6-r1.ebuild b/dev-util/cmake/cmake-2.8.6-r2.ebuild
index 334cfe6bb8d6..8ac3a8e41659 100644
--- a/dev-util/cmake/cmake-2.8.6-r1.ebuild
+++ b/dev-util/cmake/cmake-2.8.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.6-r1.ebuild,v 1.2 2011/10/19 21:10:58 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.6-r2.ebuild,v 1.1 2011/10/29 21:49:29 dilfridge Exp $
EAPI=4
@@ -57,7 +57,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.8.3-ruby_libname.patch
"${FILESDIR}"/${PN}-2.8.4-FindBoost.patch
"${FILESDIR}"/${PN}-2.8.6-FindBLAS.patch
- "${FILESDIR}"/${PN}-2.8.6-FindLAPACK.patch
+ "${FILESDIR}"/${PN}-2.8.6-FindLAPACK-2.patch
)
cmake_src_bootstrap() {
# Cleanup args to extract only JOBS.
diff --git a/dev-util/cmake/files/cmake-2.8.6-FindLAPACK-2.patch b/dev-util/cmake/files/cmake-2.8.6-FindLAPACK-2.patch
new file mode 100644
index 000000000000..579a07d880a1
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.6-FindLAPACK-2.patch
@@ -0,0 +1,34 @@
+--- cmake-2.8.6.orig/Modules/FindLAPACK.cmake 2011-10-09 23:38:48.956933106 +0800
++++ cmake-2.8.6.orig/Modules/FindLAPACK.cmake 2011-10-09 23:39:52.002144646 +0800
+@@ -1,3 +1,9 @@
++#
++# Version modified for Gentoo Linux
++# If a valid PkgConfig configuration is found, this overrides and cancels
++# all further checks.
++#
++
+ # - Find LAPACK library
+ # This module finds an installed fortran library that implements the LAPACK
+ # linear-algebra interface (see http://www.netlib.org/lapack/).
+@@ -36,6 +42,14 @@
+ # (To distribute this file outside of CMake, substitute the full
+ # License text for the above reference.)
+
++#
++# first, try PkgConfig
++#
++find_package(PkgConfig REQUIRED)
++pkg_check_modules(LAPACK lapack)
++if(NOT LAPACK_FOUND)
++message(STATUS "No PkgConfig configuration for LAPACK found; starting more extensive search.")
++
+ set(_lapack_ORIG_CMAKE_FIND_LIBRARY_SUFFIXES ${CMAKE_FIND_LIBRARY_SUFFIXES})
+
+ get_property(_LANGUAGES_ GLOBAL PROPERTY ENABLED_LANGUAGES)
+@@ -304,4 +318,6 @@
+ endif(NOT LAPACK_FIND_QUIETLY)
+ endif(BLA_F95)
+
+ set(CMAKE_FIND_LIBRARY_SUFFIXES ${_lapack_ORIG_CMAKE_FIND_LIBRARY_SUFFIXES})
++
++endif(NOT LAPACK_FOUND)