summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-05-06 21:12:34 +0000
committerJohannes Huber <johu@gentoo.org>2014-05-06 21:12:34 +0000
commite6c36db07d50843f9927d5865b17e9728baa1201 (patch)
tree6faa27c3fb1213bc13a4c2a5ce7d31f035ba223b /dev-util/cmake
parentamd64 stable wrt bug #504210 (diff)
downloadgentoo-2-e6c36db07d50843f9927d5865b17e9728baa1201.tar.gz
gentoo-2-e6c36db07d50843f9927d5865b17e9728baa1201.tar.bz2
gentoo-2-e6c36db07d50843f9927d5865b17e9728baa1201.zip
Add patch to fix build with sys-libs/ncurses[tinfo] by Mark Wright <gienah@gentoo.org>, bug #468622.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog7
-rw-r--r--dev-util/cmake/cmake-2.8.12.2-r1.ebuild3
-rw-r--r--dev-util/cmake/files/cmake-2.8.12.2-FindCurses.patch42
3 files changed, 50 insertions, 2 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index dc7b7aa43903..806dca9fed95 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.277 2014/05/06 12:21:42 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.278 2014/05/06 21:12:34 johu Exp $
+
+ 06 May 2014; Johannes Huber <johu@gentoo.org>
+ +files/cmake-2.8.12.2-FindCurses.patch, cmake-2.8.12.2-r1.ebuild:
+ Add patch to fix build with sys-libs/ncurses[tinfo] by Mark Wright
+ <gienah@gentoo.org>, bug #468622.
*cmake-2.8.12.2-r1 (06 May 2014)
diff --git a/dev-util/cmake/cmake-2.8.12.2-r1.ebuild b/dev-util/cmake/cmake-2.8.12.2-r1.ebuild
index cd4a0a4baf1b..25a198e550a1 100644
--- a/dev-util/cmake/cmake-2.8.12.2-r1.ebuild
+++ b/dev-util/cmake/cmake-2.8.12.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.12.2-r1.ebuild,v 1.1 2014/05/06 12:21:42 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.12.2-r1.ebuild,v 1.2 2014/05/06 21:12:34 johu Exp $
EAPI=5
@@ -65,6 +65,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.8.12.1-FindFreetype.patch
"${FILESDIR}"/${PN}-2.8.12.2-hppa-bootstrap.patch
"${FILESDIR}"/${PN}-2.8.12.2-FindBoost-python.patch
+ "${FILESDIR}"/${PN}-2.8.12.2-FindCurses.patch
)
cmake_src_bootstrap() {
diff --git a/dev-util/cmake/files/cmake-2.8.12.2-FindCurses.patch b/dev-util/cmake/files/cmake-2.8.12.2-FindCurses.patch
new file mode 100644
index 000000000000..43a2a7f4a2f0
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.12.2-FindCurses.patch
@@ -0,0 +1,42 @@
+--- cmake-2.8.12.1-orig/Modules/FindCurses.cmake 2013-11-06 06:07:22.000000000 +1100
++++ cmake-2.8.12.1/Modules/FindCurses.cmake 2014-01-17 21:55:40.630142386 +1100
+@@ -30,7 +30,7 @@
+ find_library(CURSES_NCURSES_LIBRARY NAMES ncurses )
+ set(CURSES_USE_NCURSES FALSE)
+
+-if(CURSES_NCURSES_LIBRARY AND NOT CURSES_CURSES_LIBRARY)
++if(CURSES_NCURSES_LIBRARY AND ((NOT CURSES_CURSES_LIBRARY) OR CURSES_NEED_NCURSES))
+ set(CURSES_USE_NCURSES TRUE)
+ endif()
+ # http://cygwin.com/ml/cygwin-announce/2010-01/msg00002.html
+@@ -125,10 +125,20 @@
+ CACHE FILEPATH "The curses library" ${FORCE_IT})
+ endif()
+
++ CHECK_LIBRARY_EXISTS("${CURSES_NCURSES_LIBRARY}"
++ cbreak "" CURSES_NCURSES_HAS_CBREAK)
++ if(NOT CURSES_NCURSES_HAS_CBREAK)
++ find_library(CURSES_EXTRA_LIBRARY tinfo HINTS "${_cursesLibDir}")
++ find_library(CURSES_EXTRA_LIBRARY tinfo )
++ CHECK_LIBRARY_EXISTS("${CURSES_EXTRA_LIBRARY}"
++ cbreak "" CURSES_TINFO_HAS_CBREAK)
++ endif()
+ endif()
+
+-find_library(CURSES_EXTRA_LIBRARY cur_colr HINTS "${_cursesLibDir}")
+-find_library(CURSES_EXTRA_LIBRARY cur_colr )
++if (NOT CURSES_TINFO_HAS_CBREAK)
++ find_library(CURSES_EXTRA_LIBRARY cur_colr HINTS "${_cursesLibDir}")
++ find_library(CURSES_EXTRA_LIBRARY cur_colr )
++endif()
+
+ find_library(CURSES_FORM_LIBRARY form HINTS "${_cursesLibDir}")
+ find_library(CURSES_FORM_LIBRARY form )
+@@ -172,5 +182,7 @@
+ CURSES_INCLUDE_DIR
+ CURSES_CURSES_HAS_WSYNCUP
+ CURSES_NCURSES_HAS_WSYNCUP
++ CURSES_NCURSES_HAS_CBREAK
++ CURSES_TINFO_HAS_CBREAK
+ )
+