summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-02-21 20:14:36 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-02-21 20:14:36 +0000
commit4281b827dc5fc27b609159225e0963df26349ee9 (patch)
treeacf626ba69d5046fc20c206192afb36cd5df8fc3 /dev-util/colorgcc
parentfix build with ruby-1.6.6 (diff)
downloadgentoo-2-4281b827dc5fc27b609159225e0963df26349ee9.tar.gz
gentoo-2-4281b827dc5fc27b609159225e0963df26349ee9.tar.bz2
gentoo-2-4281b827dc5fc27b609159225e0963df26349ee9.zip
updated, fixing bug #252
Diffstat (limited to 'dev-util/colorgcc')
-rw-r--r--dev-util/colorgcc/colorgcc-1.3.2-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/colorgcc/colorgcc-1.3.2-r1.ebuild b/dev-util/colorgcc/colorgcc-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..0f73bda00aab
--- /dev/null
+++ b/dev-util/colorgcc/colorgcc-1.3.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <g2boojum@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/colorgcc/colorgcc-1.3.2-r1.ebuild,v 1.1 2002/02/21 20:14:36 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Adds color to gcc output"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/${PN}/${PN}_${PV}.orig.tar.gz
+http://ftp.debian.org/debian/pool/main/c/${PN}/${PN}_${PV}-4.1.diff.gz"
+
+HOMEPAGE="http://packages.debian.org/testing/devel/colorgcc.html"
+
+DEPEND="sys-devel/perl
+ sys-devel/gcc"
+
+src_unpack() {
+ unpack ${PN}_${PV}.orig.tar.gz
+ zcat ${DISTDIR}/${PN}_${PV}-4.1.diff.gz | patch -p0
+}
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe colorgcc
+ dodir /usr/bin/wrappers
+ dosym /usr/bin/colorgcc /usr/bin/wrappers/gcc
+ dosym /usr/bin/colorgcc /usr/bin/wrappers/g++
+ dosym /usr/bin/colorgcc /usr/bin/wrappers/cc
+ dosym /usr/bin/colorgcc /usr/bin/wrappers/c++
+ dodoc COPYING CREDITS ChangeLog INSTALL colorgccrc
+}
+
+pkg_postinst() {
+if grep /usr/bin/wrappers /etc/profile > /dev/null
+then
+ echo "/etc/profile already updated for wrappers"
+else
+ echo "Add this to the end of your ${ROOT}etc/profile:"
+ echo
+ echo "#Put /usr/bin/wrappers in path before /usr/bin"
+ echo 'export PATH=/usr/bin/wrappers:${PATH}'
+fi
+}