summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-10 23:58:52 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-10 23:58:52 +0000
commitd0d2053330278b6c5f72ea8c0d0b31bf9d14e1b7 (patch)
tree596491fb47c4ac87ec398fd7225a33e925f17a2a /dev-util/cppcheck
parentStable for HPPA (bug #390003). (diff)
downloadgentoo-2-d0d2053330278b6c5f72ea8c0d0b31bf9d14e1b7.tar.gz
gentoo-2-d0d2053330278b6c5f72ea8c0d0b31bf9d14e1b7.tar.bz2
gentoo-2-d0d2053330278b6c5f72ea8c0d0b31bf9d14e1b7.zip
Remove old versions
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cppcheck')
-rw-r--r--dev-util/cppcheck/ChangeLog6
-rw-r--r--dev-util/cppcheck/cppcheck-1.48.ebuild77
-rw-r--r--dev-util/cppcheck/cppcheck-1.49.ebuild77
-rw-r--r--dev-util/cppcheck/cppcheck-1.50.ebuild77
4 files changed, 5 insertions, 232 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index 00a65ad6709e..037ae120d417 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/cppcheck
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.27 2011/10/15 08:50:39 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.28 2011/11/10 23:58:52 xmw Exp $
+
+ 10 Nov 2011; Michael Weber <xmw@gentoo.org> -cppcheck-1.48.ebuild,
+ -cppcheck-1.49.ebuild, -cppcheck-1.50.ebuild:
+ Remove old versions
*cppcheck-1.51 (15 Oct 2011)
diff --git a/dev-util/cppcheck/cppcheck-1.48.ebuild b/dev-util/cppcheck/cppcheck-1.48.ebuild
deleted file mode 100644
index c6c46bd821fe..000000000000
--- a/dev-util/cppcheck/cppcheck-1.48.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.48.ebuild,v 1.1 2011/04/27 21:19:02 xmw Exp $
-
-EAPI="3"
-PYTHON_DEPEND="htmlreport? 2"
-
-inherit distutils eutils qt4-r2 toolchain-funcs
-
-DESCRIPTION="static analyzer of C/C++ code"
-HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
-SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="htmlreport qt4"
-
-DEPEND="htmlreport? ( dev-python/pygments )
- qt4? ( x11-libs/qt-gui:4
- x11-libs/qt-assistant:4 )"
-RDEPEND="${DEPEND}"
-
-DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
-
-pkg_setup() {
- if use htmlreport ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- if use htmlreport ; then
- pushd htmlreport
- python_convert_shebangs -r 2 .
- distutils_src_prepare
- popd
- fi
-}
-
-src_configure() {
- tc-export CXX
- if use qt4 ; then
- pushd gui
- qt4-r2_src_configure
- popd
- fi
-}
-
-src_compile() {
- emake || die
- if use qt4 ; then
- pushd gui
- qt4-r2_src_compile
- popd
- fi
- use htmlreport && distutils_src_compile
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc readme.txt || die
- if use qt4 ; then
- dobin gui/${PN}-gui || die
- dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
- fi
- use htmlreport && distutils_src_install
-}
-
-pkg_postinst() {
- use htmlreport && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use htmlreport && distutils_pkg_postrm
-}
diff --git a/dev-util/cppcheck/cppcheck-1.49.ebuild b/dev-util/cppcheck/cppcheck-1.49.ebuild
deleted file mode 100644
index 69dbb1781390..000000000000
--- a/dev-util/cppcheck/cppcheck-1.49.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.49.ebuild,v 1.1 2011/07/27 23:38:38 xmw Exp $
-
-EAPI="3"
-PYTHON_DEPEND="htmlreport? 2"
-
-inherit distutils eutils qt4-r2 toolchain-funcs
-
-DESCRIPTION="static analyzer of C/C++ code"
-HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
-SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="htmlreport qt4"
-
-DEPEND="htmlreport? ( dev-python/pygments )
- qt4? ( x11-libs/qt-gui:4
- x11-libs/qt-assistant:4 )"
-RDEPEND="${DEPEND}"
-
-DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
-
-pkg_setup() {
- if use htmlreport ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- if use htmlreport ; then
- pushd htmlreport
- python_convert_shebangs -r 2 .
- distutils_src_prepare
- popd
- fi
-}
-
-src_configure() {
- tc-export CXX
- if use qt4 ; then
- pushd gui
- qt4-r2_src_configure
- popd
- fi
-}
-
-src_compile() {
- emake || die
- if use qt4 ; then
- pushd gui
- qt4-r2_src_compile
- popd
- fi
- use htmlreport && distutils_src_compile
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc readme.txt || die
- if use qt4 ; then
- dobin gui/${PN}-gui || die
- dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
- fi
- use htmlreport && distutils_src_install
-}
-
-pkg_postinst() {
- use htmlreport && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use htmlreport && distutils_pkg_postrm
-}
diff --git a/dev-util/cppcheck/cppcheck-1.50.ebuild b/dev-util/cppcheck/cppcheck-1.50.ebuild
deleted file mode 100644
index 994f1a5f5650..000000000000
--- a/dev-util/cppcheck/cppcheck-1.50.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.50.ebuild,v 1.1 2011/09/25 00:28:13 xmw Exp $
-
-EAPI="3"
-PYTHON_DEPEND="htmlreport? 2"
-
-inherit distutils eutils qt4-r2 toolchain-funcs
-
-DESCRIPTION="static analyzer of C/C++ code"
-HOMEPAGE="http://apps.sourceforge.net/trac/cppcheck/"
-SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="htmlreport qt4"
-
-DEPEND="htmlreport? ( dev-python/pygments )
- qt4? ( x11-libs/qt-gui:4
- x11-libs/qt-assistant:4 )"
-RDEPEND="${DEPEND}"
-
-DISTUTILS_SETUP_FILES=("htmlreport|setup.py")
-
-pkg_setup() {
- if use htmlreport ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- if use htmlreport ; then
- pushd htmlreport
- python_convert_shebangs -r 2 .
- distutils_src_prepare
- popd
- fi
-}
-
-src_configure() {
- tc-export CXX
- if use qt4 ; then
- pushd gui
- qt4-r2_src_configure
- popd
- fi
-}
-
-src_compile() {
- emake || die
- if use qt4 ; then
- pushd gui
- qt4-r2_src_compile
- popd
- fi
- use htmlreport && distutils_src_compile
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc readme.txt || die
- if use qt4 ; then
- dobin gui/${PN}-gui || die
- dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck} || die
- fi
- use htmlreport && distutils_src_install
-}
-
-pkg_postinst() {
- use htmlreport && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use htmlreport && distutils_pkg_postrm
-}