summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-11-21 19:57:25 +0000
committerUlrich Müller <ulm@gentoo.org>2011-11-21 19:57:25 +0000
commitd014ba7c1b8c5160071f5358092d761af38fd2bd (patch)
tree367d8d6c36a3e90d4994c2dfec94474d87356563 /dev-util/cscope
parentfixed erroneous drop of CFLAGS from last patch update (diff)
downloadgentoo-2-d014ba7c1b8c5160071f5358092d761af38fd2bd.tar.gz
gentoo-2-d014ba7c1b8c5160071f5358092d761af38fd2bd.tar.bz2
gentoo-2-d014ba7c1b8c5160071f5358092d761af38fd2bd.zip
Bump to EAPI=4.
(Portage version: 2.1.10.36/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cscope')
-rw-r--r--dev-util/cscope/ChangeLog10
-rw-r--r--dev-util/cscope/cscope-15.7a-r1.ebuild30
-rw-r--r--dev-util/cscope/files/50cscope-gentoo.el3
3 files changed, 22 insertions, 21 deletions
diff --git a/dev-util/cscope/ChangeLog b/dev-util/cscope/ChangeLog
index 9aebdbd98d66..5e563ceab5f2 100644
--- a/dev-util/cscope/ChangeLog
+++ b/dev-util/cscope/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cscope
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.119 2009/05/11 21:03:59 ulm Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.120 2011/11/21 19:57:24 ulm Exp $
+
+ 21 Nov 2011; Ulrich Mueller <ulm@gentoo.org> cscope-15.7a-r1.ebuild:
+ Bump to EAPI=4.
+
+ 21 Nov 2011; Ulrich Mueller <ulm@gentoo.org> cscope-15.7a-r1.ebuild:
+ Bump to EAPI=4.
*cscope-15.7a-r1 (11 May 2009)
diff --git a/dev-util/cscope/cscope-15.7a-r1.ebuild b/dev-util/cscope/cscope-15.7a-r1.ebuild
index ce28a82675d6..8f226632f80e 100644
--- a/dev-util/cscope/cscope-15.7a-r1.ebuild
+++ b/dev-util/cscope/cscope-15.7a-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.7a-r1.ebuild,v 1.2 2009/05/11 21:03:59 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.7a-r1.ebuild,v 1.3 2011/11/21 19:57:24 ulm Exp $
+
+EAPI=4
inherit elisp-common eutils
@@ -22,40 +24,36 @@ DEPEND="${RDEPEND}
SITEFILE="50${PN}-gentoo.el"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}-ocs-sysdir.patch" #269305
}
src_compile() {
- STRIP="no"
-
- econf || die "econf failed"
make clean || die "make clean failed"
- emake || die "emake failed"
+ emake
- if use emacs ; then
+ if use emacs; then
cd "${S}"/contrib/xcscope || die
elisp-compile *.el || die
fi
}
src_install() {
- einstall || die "einstall failed"
- dodoc AUTHORS ChangeLog NEWS README* TODO || die "dodoc failed"
+ einstall
+ dodoc AUTHORS ChangeLog NEWS README* TODO
- if use emacs ; then
+ if use emacs; then
cd "${S}"/contrib/xcscope || die
elisp-install ${PN} *.el *.elc || die
elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- dobin cscope-indexer || die "dobin failed"
+ dobin cscope-indexer
fi
cd "${S}"/contrib/webcscope || die
docinto webcscope
- dodoc INSTALL TODO cgi-lib.pl cscope hilite.c || die "dodoc failed"
- insinto /usr/share/doc/${PF}/webcscope/icons; doins icons/*.gif
+ dodoc INSTALL TODO cgi-lib.pl cscope hilite.c
+ docinto webcscope/icons
+ dodoc icons/*.gif
}
pkg_postinst() {
diff --git a/dev-util/cscope/files/50cscope-gentoo.el b/dev-util/cscope/files/50cscope-gentoo.el
index bfb13da9f974..08fd4b449352 100644
--- a/dev-util/cscope/files/50cscope-gentoo.el
+++ b/dev-util/cscope/files/50cscope-gentoo.el
@@ -1,6 +1,3 @@
-
-;;; cscope site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
(autoload 'cscope-minor-mode "xcscope")