summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-10 12:45:09 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-10 12:45:09 +0000
commite27c43913c049681679b773f3dbb34ab43f6e209 (patch)
tree6667392b7a863994137178138537c6472535fa94 /dev-util/cscope
parentnew version .. no RC5, sorry (diff)
downloadgentoo-2-e27c43913c049681679b773f3dbb34ab43f6e209.tar.gz
gentoo-2-e27c43913c049681679b773f3dbb34ab43f6e209.tar.bz2
gentoo-2-e27c43913c049681679b773f3dbb34ab43f6e209.zip
A=-fix, try->die, tab-fixes, stylefixes, ...
Diffstat (limited to 'dev-util/cscope')
-rw-r--r--dev-util/cscope/cscope-15.1.ebuild6
-rw-r--r--dev-util/cscope/cscope-15.3.ebuild29
2 files changed, 21 insertions, 14 deletions
diff --git a/dev-util/cscope/cscope-15.1.ebuild b/dev-util/cscope/cscope-15.1.ebuild
index 6c98216f4d54..6f74770026b6 100644
--- a/dev-util/cscope/cscope-15.1.ebuild
+++ b/dev-util/cscope/cscope-15.1.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author AJ Lewis <lewis@sistina.com>
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.1.ebuild,v 1.5 2001/08/31 03:23:38 pm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.1.ebuild,v 1.6 2001/11/10 12:45:09 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="CScope - interactively examine a C program"
-SRC_URI="http://download.sourceforge.net/cscope/${A}"
+SRC_URI="http://download.sourceforge.net/cscope/${P}.tar.gz"
HOMEPAGE="http://cscope.sourceforge.net"
RDEPEND="virtual/glibc
>=sys-libs/ncurses-5.2"
DEPEND="$RDEPEND sys-devel/flex"
+
src_compile() {
try ./configure --prefix=/usr/ --mandir=/usr/share/man --infodir=/usr/share/info
try make clean
diff --git a/dev-util/cscope/cscope-15.3.ebuild b/dev-util/cscope/cscope-15.3.ebuild
index 9824ea91ecf2..9b23accc8531 100644
--- a/dev-util/cscope/cscope-15.3.ebuild
+++ b/dev-util/cscope/cscope-15.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author AJ Lewis <lewis@sistina.com>
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.3.ebuild,v 1.4 2001/10/08 01:47:55 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.3.ebuild,v 1.5 2001/11/10 12:45:09 hallski Exp $
S=${WORKDIR}/${P}
DESCRIPTION="CScope - interactively examine a C program"
@@ -10,19 +10,26 @@ HOMEPAGE="http://cscope.sourceforge.net"
RDEPEND="virtual/glibc
>=sys-libs/ncurses-5.2"
-DEPEND="$RDEPEND sys-devel/flex"
-src_compile() {
- try ./configure --prefix=/usr/ --mandir=/usr/share/man --infodir=/usr/share/info
- try make clean
- try make ${MAKEOPTS}
-}
+DEPEND="$RDEPEND
+ sys-devel/flex"
-src_install() {
- try make prefix=${D}/usr/ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
- dodoc NEWS AUTHORS TODO COPYING Changelog INSTALL README*
-}
+src_compile() {
+ ./configure --prefix=/usr/ \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ assert
+ make clean || die
+ emake || die
+}
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+ dodoc NEWS AUTHORS TODO COPYING Changelog INSTALL README*
+}