summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-09-14 18:19:40 +0000
committerRoy Marples <uberlord@gentoo.org>2007-09-14 18:19:40 +0000
commit36d420ba0f6a08283f67e547ca1b74b1cf873090 (patch)
tree761c71b106698f6e90550983e966cf35b105ef39 /dev-util/cvs
parentwhitespace (diff)
downloadgentoo-2-36d420ba0f6a08283f67e547ca1b74b1cf873090.tar.gz
gentoo-2-36d420ba0f6a08283f67e547ca1b74b1cf873090.tar.bz2
gentoo-2-36d420ba0f6a08283f67e547ca1b74b1cf873090.zip
Fix install on FreeBSD with -j N
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-util/cvs')
-rw-r--r--dev-util/cvs/ChangeLog7
-rw-r--r--dev-util/cvs/cvs-1.12.12-r4.ebuild4
-rw-r--r--dev-util/cvs/cvs-1.12.13-r1.ebuild6
-rw-r--r--dev-util/cvs/files/cvs-1.12.12-install-sh.patch12
4 files changed, 25 insertions, 4 deletions
diff --git a/dev-util/cvs/ChangeLog b/dev-util/cvs/ChangeLog
index c3b6f1660e28..13865858a52c 100644
--- a/dev-util/cvs/ChangeLog
+++ b/dev-util/cvs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cvs
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/ChangeLog,v 1.122 2007/04/22 13:47:48 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/ChangeLog,v 1.123 2007/09/14 18:19:39 uberlord Exp $
+
+ 14 Sep 2007; Roy Marples <uberlord@gentoo.org>
+ +files/cvs-1.12.12-install-sh.patch, cvs-1.12.12-r4.ebuild,
+ cvs-1.12.13-r1.ebuild:
+ Fix install on FreeBSD with -j N
22 Apr 2007; Tobias Scherbaum <dertobi123@gentoo.org>
cvs-1.12.12-r4.ebuild:
diff --git a/dev-util/cvs/cvs-1.12.12-r4.ebuild b/dev-util/cvs/cvs-1.12.12-r4.ebuild
index 80222f39666f..30d30fb70fec 100644
--- a/dev-util/cvs/cvs-1.12.12-r4.ebuild
+++ b/dev-util/cvs/cvs-1.12.12-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.12-r4.ebuild,v 1.14 2007/07/12 01:05:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.12-r4.ebuild,v 1.15 2007/09/14 18:19:39 uberlord Exp $
inherit eutils pam
@@ -28,6 +28,8 @@ src_unpack() {
EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${P}-cvsbug-tmpfix.patch
epatch ${FILESDIR}/${P}-openat.patch
EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${P}-block-requests.patch
+ cd "${S}"
+ epatch ${FILESDIR}/${P}-install-sh.patch
elog "If you want any CVS server functionality, you MUST emerge with USE=server!"
}
diff --git a/dev-util/cvs/cvs-1.12.13-r1.ebuild b/dev-util/cvs/cvs-1.12.13-r1.ebuild
index b8464b5905b5..a2c48fa68a33 100644
--- a/dev-util/cvs/cvs-1.12.13-r1.ebuild
+++ b/dev-util/cvs/cvs-1.12.13-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.13-r1.ebuild,v 1.3 2006/10/17 15:08:46 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.13-r1.ebuild,v 1.4 2007/09/14 18:19:39 uberlord Exp $
inherit eutils pam
@@ -28,6 +28,8 @@ src_unpack() {
EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${P}-cvsbug-tmpfix.patch
epatch ${FILESDIR}/${P}-openat.patch
EPATCH_OPTS="-p0 -d ${S}" epatch ${FILESDIR}/${P}-zlib.patch
+ cd "${S}"
+ epatch ${FILESDIR}/${PN}-1.12.12-install-sh.patch
# this testcase was not updated
#sed -i.orig -e '/unrecognized keyword.*BogusOption/s,98,73,g' \
# ${S}/src/sanity.sh
diff --git a/dev-util/cvs/files/cvs-1.12.12-install-sh.patch b/dev-util/cvs/files/cvs-1.12.12-install-sh.patch
new file mode 100644
index 000000000000..825c0ee6f1c3
--- /dev/null
+++ b/dev-util/cvs/files/cvs-1.12.12-install-sh.patch
@@ -0,0 +1,12 @@
+diff -ur a/build-aux/install-sh b/build-aux/install-sh
+--- a/build-aux/install-sh 2006-03-25 20:04:46 +0000
++++ b/build-aux/install-sh 2007-09-14 10:53:29 +0100
+@@ -246,7 +246,7 @@
+ fi
+
+ if test -n "$dir_arg"; then
+- $doit $mkdircmd "$dst" \
++ { test -d "$dst" || $doit $mkdircmd -p "$dst"; } \
+ && { test -z "$chowncmd" || $doit $chowncmd "$dst"; } \
+ && { test -z "$chgrpcmd" || $doit $chgrpcmd "$dst"; } \
+ && { test -z "$stripcmd" || $doit $stripcmd "$dst"; } \