summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-02-21 03:06:44 +0000
committerJonathan Callen <abcd@gentoo.org>2010-02-21 03:06:44 +0000
commit7dab99e3206539406adc171bdf34caf910487c81 (patch)
treec1ba3a1f4dab0700c38be4d3303beedda6856ea2 /dev-util/cvs
parentUnmasking mysql-5.1 series now, be sure to read the news item! (diff)
downloadgentoo-2-7dab99e3206539406adc171bdf34caf910487c81.tar.gz
gentoo-2-7dab99e3206539406adc171bdf34caf910487c81.tar.bz2
gentoo-2-7dab99e3206539406adc171bdf34caf910487c81.zip
Revbump for EAPI bump, add prefix keywords
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'dev-util/cvs')
-rw-r--r--dev-util/cvs/ChangeLog10
-rw-r--r--dev-util/cvs/cvs-1.12.12-r7.ebuild80
-rw-r--r--dev-util/cvs/cvs-1.12.13-r1.ebuild26
-rw-r--r--dev-util/cvs/cvs-1.12.13.1.ebuild30
4 files changed, 116 insertions, 30 deletions
diff --git a/dev-util/cvs/ChangeLog b/dev-util/cvs/ChangeLog
index 1ae934e04c5e..5b063fa96f7a 100644
--- a/dev-util/cvs/ChangeLog
+++ b/dev-util/cvs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cvs
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/ChangeLog,v 1.135 2009/04/26 19:35:49 ranger Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/ChangeLog,v 1.136 2010/02/21 03:06:44 abcd Exp $
+
+*cvs-1.12.12-r7 (21 Feb 2010)
+
+ 21 Feb 2010; Jonathan Callen <abcd@gentoo.org> +cvs-1.12.12-r7.ebuild,
+ cvs-1.12.13-r1.ebuild, cvs-1.12.13.1.ebuild:
+ Revbump for EAPI bump, add prefix keywords
26 Apr 2009; Brent Baude <ranger@gentoo.org> cvs-1.12.12-r6.ebuild:
stable ppc, bug 265780
diff --git a/dev-util/cvs/cvs-1.12.12-r7.ebuild b/dev-util/cvs/cvs-1.12.12-r7.ebuild
new file mode 100644
index 000000000000..add52a4171b8
--- /dev/null
+++ b/dev-util/cvs/cvs-1.12.12-r7.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.12-r7.ebuild,v 1.1 2010/02/21 03:06:44 abcd Exp $
+
+EAPI=3
+
+inherit eutils pam
+
+DESCRIPTION="Concurrent Versions System - source code revision control tools"
+HOMEPAGE="http://www.nongnu.org/cvs/"
+
+SRC_URI="mirror://gnu/non-gnu/cvs/source/feature/${PV}/${P}.tar.bz2
+ doc? ( mirror://gnu/non-gnu/cvs/source/feature/${PV}/cederqvist-${PV}.html.tar.bz2
+ mirror://gnu/non-gnu/cvs/source/feature/${PV}/cederqvist-${PV}.pdf
+ mirror://gnu/non-gnu/cvs/source/feature/${PV}/cederqvist-${PV}.ps )"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="crypt doc kerberos nls pam server"
+
+DEPEND=">=sys-libs/zlib-1.1.4
+ kerberos? ( virtual/krb5 )
+ pam? ( virtual/pam )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use doc && unpack cederqvist-${PV}.html.tar.bz2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cvsbug-tmpfix.patch
+ epatch "${FILESDIR}"/${P}-openat.patch
+ epatch "${FILESDIR}"/${P}-block-requests.patch
+ epatch "${FILESDIR}"/${P}-cvs-gnulib-vasnprintf.patch
+ epatch "${FILESDIR}"/${P}-install-sh.patch
+ elog "If you want any CVS server functionality, you MUST emerge with USE=server!"
+}
+
+src_configure() {
+ econf \
+ --with-external-zlib \
+ --with-tmpdir=/tmp \
+ $(use_enable crypt encryption) \
+ $(use_with kerberos gssapi) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_enable server)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/cvspserver.xinetd.d cvspserver || die "newins failed"
+
+ dodoc BUGS ChangeLog* DEVEL* FAQ HACKING \
+ MINOR* NEWS PROJECTS README* TESTS TODO
+
+ # Not installed into emacs site-lisp because it clobbers the normal C
+ # indentations.
+ dodoc cvs-format.el || die "dodoc failed"
+
+ use server && newdoc "${FILESDIR}"/cvs-1.12.12-cvs-custom.c cvs-custom.c
+
+ if use doc; then
+ dodoc "${DISTDIR}"/cederqvist-${PV}.pdf
+ dodoc "${DISTDIR}"/cederqvist-${PV}.ps
+ tar xjf "${DISTDIR}"/cederqvist-${PV}.html.tar.bz2
+ dohtml -r cederqvist-${PV}.html/*
+ dosym cvs.html /usr/share/doc/${PF}/html/index.html
+ fi
+
+ newpamd "${FILESDIR}"/cvs.pam-include-1.12.12 cvs
+}
+
+src_test() {
+ einfo "FEATURES=\"maketest\" has been disabled for dev-util/cvs"
+}
diff --git a/dev-util/cvs/cvs-1.12.13-r1.ebuild b/dev-util/cvs/cvs-1.12.13-r1.ebuild
index b4bcd1b07a89..56cd77a1acab 100644
--- a/dev-util/cvs/cvs-1.12.13-r1.ebuild
+++ b/dev-util/cvs/cvs-1.12.13-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.13-r1.ebuild,v 1.6 2008/06/16 18:11:58 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.13-r1.ebuild,v 1.7 2010/02/21 03:06:44 abcd Exp $
+
+EAPI=3
inherit eutils pam
@@ -14,7 +16,7 @@ SRC_URI="mirror://gnu/non-gnu/cvs/source/feature/${PV}/${P}.tar.bz2
LICENSE="GPL-2 LGPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="crypt doc emacs kerberos nls pam server"
@@ -25,10 +27,12 @@ DEPEND=">=sys-libs/zlib-1.1.4
src_unpack() {
unpack ${P}.tar.bz2
use doc && unpack cederqvist-${PV}.html.tar.bz2
- EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-1.12.12-cvsbug-tmpfix.patch
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.12.12-cvsbug-tmpfix.patch
epatch "${FILESDIR}"/${P}-openat.patch
- EPATCH_OPTS="-p0 -d ${S}" epatch "${FILESDIR}"/${P}-zlib.patch
- cd "${S}"
+ epatch "${FILESDIR}"/${P}-zlib.patch
epatch "${FILESDIR}"/${PN}-1.12.12-install-sh.patch
# this testcase was not updated
#sed -i.orig -e '/unrecognized keyword.*BogusOption/s,98,73,g' \
@@ -38,7 +42,7 @@ src_unpack() {
"${S}"/src/sanity.sh
}
-src_compile() {
+src_configure() {
local myconf
# the tests need the server and proxy
if has test $FEATURES; then
@@ -54,10 +58,7 @@ src_compile() {
$(use_enable nls) \
$(use_enable pam) \
$(use_enable server) \
- $(use_enable server proxy) \
- ${myconf} \
- || die
- emake || die "emake failed"
+ $(use_enable server proxy)
}
src_install() {
@@ -81,8 +82,7 @@ src_install() {
dodoc "${DISTDIR}"/cederqvist-${PV}.ps
tar xjf "${DISTDIR}"/cederqvist-${PV}.html.tar.bz2
dohtml -r cederqvist-${PV}.html/*
- cd "${D}"/usr/share/doc/${PF}/html/
- ln -s cvs.html index.html
+ dosym cvs.html /usr/share/doc/${PF}/html/index.html
fi
newpamd "${FILESDIR}"/cvs.pam-include-1.12.12 cvs
diff --git a/dev-util/cvs/cvs-1.12.13.1.ebuild b/dev-util/cvs/cvs-1.12.13.1.ebuild
index 71a48eb9e281..00644ff6f07a 100644
--- a/dev-util/cvs/cvs-1.12.13.1.ebuild
+++ b/dev-util/cvs/cvs-1.12.13.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.13.1.ebuild,v 1.5 2008/06/16 18:14:45 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.13.1.ebuild,v 1.6 2010/02/21 03:06:44 abcd Exp $
+
+EAPI=3
inherit eutils pam versionator
@@ -22,7 +24,7 @@ SRC_URI="
LICENSE="GPL-2 LGPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="crypt doc kerberos nls pam server"
@@ -33,15 +35,16 @@ DEPEND=">=sys-libs/zlib-1.1.4
src_unpack() {
unpack ${P}.tar.bz2
use doc && unpack cederqvist-${DOC_PV}.html.tar.bz2
+}
- EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-1.12.12-cvsbug-tmpfix.patch
- EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-1.12.12-install-sh.patch
- EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-1.12.13.1-block-requests.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.12.12-cvsbug-tmpfix.patch
+ epatch "${FILESDIR}"/${PN}-1.12.12-install-sh.patch
+ epatch "${FILESDIR}"/${PN}-1.12.13.1-block-requests.patch
# Applied by upstream:
- #EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-1.12.13-openat.patch
- #EPATCH_OPTS="-p0 -d ${S}" epatch ${FILESDIR}/${PN}-1.12.13-zlib.patch
+ #epatch "${FILESDIR}"/${PN}-1.12.13-openat.patch
+ #epatch "${FILESDIR}"/${PN}-1.12.13-zlib.patch
- cd "${S}"
# this testcase was not updated
#sed -i.orig -e '/unrecognized keyword.*BogusOption/s,98,73,g' \
# ${S}/src/sanity.sh
@@ -53,7 +56,7 @@ src_unpack() {
elog "If you want any CVS server functionality, you MUST emerge with USE=server!"
}
-src_compile() {
+src_configure() {
local myconf
# the tests need the server and proxy
if has test $FEATURES; then
@@ -70,9 +73,7 @@ src_compile() {
$(use_enable pam) \
$(use_enable server) \
$(use_enable server proxy) \
- ${myconf} \
- || die
- emake || die "emake failed"
+ ${myconf}
}
src_install() {
@@ -96,8 +97,7 @@ src_install() {
dodoc "${DISTDIR}"/cederqvist-${DOC_PV}.pdf
dodoc "${DISTDIR}"/cederqvist-${DOC_PV}.ps
dohtml -r "${WORKDIR}"/cederqvist-${DOC_PV}.html/
- cd "${D}"/usr/share/doc/${PF}/html/
- ln -s cvs.html index.html
+ dosym cvs.html /usr/share/doc/${PF}/html/index.html
fi
newpamd "${FILESDIR}"/cvs.pam-include-1.12.12 cvs