summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-01-17 17:53:02 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-01-17 17:53:02 +0000
commitdb3f1990ab271d049bceba190cf4d554afbd40d7 (patch)
treeb39275113c499f42b252d9813910235d7c820e90 /dev-util/cwdiff
parentRemove old, bump EAPI to 5 (diff)
downloadgentoo-2-db3f1990ab271d049bceba190cf4d554afbd40d7.tar.gz
gentoo-2-db3f1990ab271d049bceba190cf4d554afbd40d7.tar.bz2
gentoo-2-db3f1990ab271d049bceba190cf4d554afbd40d7.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-util/cwdiff')
-rw-r--r--dev-util/cwdiff/ChangeLog9
-rw-r--r--dev-util/cwdiff/cwdiff-0.2.6.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-util/cwdiff/ChangeLog b/dev-util/cwdiff/ChangeLog
index 230b4e9a23f2..3e877d60a393 100644
--- a/dev-util/cwdiff/ChangeLog
+++ b/dev-util/cwdiff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cwdiff
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cwdiff/ChangeLog,v 1.6 2013/09/06 22:45:00 ottxor Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cwdiff/ChangeLog,v 1.7 2014/01/17 17:53:02 ottxor Exp $
+
+*cwdiff-0.2.6 (17 Jan 2014)
+
+ 17 Jan 2014; Christoph Junghans <ottxor@gentoo.org> +cwdiff-0.2.6.ebuild:
+ version bump
*cwdiff-0.2.5 (06 Sep 2013)
diff --git a/dev-util/cwdiff/cwdiff-0.2.6.ebuild b/dev-util/cwdiff/cwdiff-0.2.6.ebuild
new file mode 100644
index 000000000000..f10c6a7fa033
--- /dev/null
+++ b/dev-util/cwdiff/cwdiff-0.2.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cwdiff/cwdiff-0.2.6.ebuild,v 1.1 2014/01/17 17:53:02 ottxor Exp $
+
+EAPI=5
+
+DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
+HOMEPAGE="http://code.google.com/p/cj-overlay/source/browse/cwdiff?repo=evergreens"
+SRC_URI="http://cj-overlay.googlecode.com/files/${P}.tar.gz"
+RESTRICT="primaryuri"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-macos"
+IUSE="a2ps mercurial"
+
+DEPEND=""
+RDEPEND="
+ sys-apps/sed
+ app-shells/bash
+ app-text/wdiff
+ sys-apps/diffutils
+ a2ps? ( app-text/a2ps )
+ mercurial? ( dev-vcs/mercurial )
+ "
+
+src_install () {
+ dobin "${PN}"
+ if use mercurial ; then
+ insinto /etc/mercurial/hgrc.d
+ doins hgrc.d/"${PN}".rc
+ fi
+}