summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-12-28 13:25:47 +0000
committerJeroen Roovers <jer@gentoo.org>2013-12-28 13:25:47 +0000
commitd61b142137d647957ee512cdeeb6a9e484a08fc6 (patch)
tree71ccc1b2ea16448389e7b1a9bcd49804911b58c7 /dev-util/debhelper
parentUpdate config checks also solving bug #493874 by Alexey Vladykin, drop old. (diff)
downloadgentoo-2-d61b142137d647957ee512cdeeb6a9e484a08fc6.tar.gz
gentoo-2-d61b142137d647957ee512cdeeb6a9e484a08fc6.tar.bz2
gentoo-2-d61b142137d647957ee512cdeeb6a9e484a08fc6.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-util/debhelper')
-rw-r--r--dev-util/debhelper/ChangeLog7
-rw-r--r--dev-util/debhelper/debhelper-9.20131227.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-util/debhelper/ChangeLog b/dev-util/debhelper/ChangeLog
index 6e9625d47495..8e546560b2cf 100644
--- a/dev-util/debhelper/ChangeLog
+++ b/dev-util/debhelper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/debhelper
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/debhelper/ChangeLog,v 1.96 2013/12/14 14:44:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debhelper/ChangeLog,v 1.97 2013/12/28 13:25:47 jer Exp $
+
+*debhelper-9.20131227 (28 Dec 2013)
+
+ 28 Dec 2013; Jeroen Roovers <jer@gentoo.org> +debhelper-9.20131227.ebuild:
+ Version bump.
*debhelper-9.20131213 (14 Dec 2013)
diff --git a/dev-util/debhelper/debhelper-9.20131227.ebuild b/dev-util/debhelper/debhelper-9.20131227.ebuild
new file mode 100644
index 000000000000..f81b8be37b13
--- /dev/null
+++ b/dev-util/debhelper/debhelper-9.20131227.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/debhelper/debhelper-9.20131227.ebuild,v 1.1 2013/12/28 13:25:47 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Collection of programs that can be used to automate common tasks in debian/rules"
+HOMEPAGE="http://packages.qa.debian.org/d/debhelper.html http://joeyh.name/code/debhelper/"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux"
+IUSE="test"
+DH_LINGUAS=( de es fr )
+IUSE+=" ${DH_LINGUAS[@]/#/linguas_}"
+
+NLS_DEPEND=$(
+ printf "linguas_%s? ( >=app-text/po4a-0.24 )\n" ${DH_LINGUAS[@]}
+)
+
+RDEPEND="
+ >=dev-lang/perl-5.10
+ >=app-arch/dpkg-1.17
+ dev-perl/TimeDate
+ virtual/perl-Getopt-Long
+"
+DEPEND="${RDEPEND}
+ ${NLS_DEPEND}
+ test? ( dev-perl/Test-Pod )
+"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ tc-export CC
+
+ local LANGS="" USE_NLS=no lingua
+ for lingua in ${DH_LINGUAS[@]}; do
+ if use linguas_${lingua}; then
+ LANGS+=" ${lingua}"
+ USE_NLS=yes
+ fi
+ done
+
+ emake USE_NLS="${USE_NLS}" LANGS="${LANGS}" build
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc doc/* debian/changelog
+ docinto examples
+ dodoc examples/*
+ local lingua
+ for manfile in *.1 *.7 ; do
+ for lingua in ${DH_LINGUAS[@]}; do
+ case ${manfile} in
+ *.${lingua}.?)
+ use linguas_${lingua} \
+ && cp ${manfile} "${T}"/${manfile/.${lingua}/} \
+ && doman -i18n=${lingua} "${T}"/${manfile/.${lingua}/}
+ ;;
+ *)
+ doman ${manfile}
+ ;;
+ esac
+ done
+ done
+}