summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-10-10 00:35:22 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-10-10 00:35:22 +0000
commit45c64c04929d3924829a27672ae45fc577700216 (patch)
treed44d212353acad32305ab4201ce4b21e6980ff37 /dev-util/duma
parentQA fixes - Removed WANT_AUTO{MAKE,CONF} assignments since we were assigning t... (diff)
downloadgentoo-2-45c64c04929d3924829a27672ae45fc577700216.tar.gz
gentoo-2-45c64c04929d3924829a27672ae45fc577700216.tar.bz2
gentoo-2-45c64c04929d3924829a27672ae45fc577700216.zip
version bump and stable bump (special case) for bug 195203
(Portage version: 2.1.3.12)
Diffstat (limited to 'dev-util/duma')
-rw-r--r--dev-util/duma/ChangeLog9
-rw-r--r--dev-util/duma/duma-2.4.27.ebuild12
-rw-r--r--dev-util/duma/duma-2.5.8.ebuild85
-rw-r--r--dev-util/duma/files/digest-duma-2.5.83
-rw-r--r--dev-util/duma/files/duma-2.5.8-soname.patch13
5 files changed, 114 insertions, 8 deletions
diff --git a/dev-util/duma/ChangeLog b/dev-util/duma/ChangeLog
index 878632d9f6de..09123b60f51b 100644
--- a/dev-util/duma/ChangeLog
+++ b/dev-util/duma/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/duma
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/ChangeLog,v 1.2 2007/04/03 06:09:16 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/ChangeLog,v 1.3 2007/10/10 00:35:22 nerdboy Exp $
+
+*duma-2.5.8 (10 Oct 2007)
+
+ 10 Oct 2007; Steve Arnold <nerdboy@gentoo.org>
+ +files/duma-2.5.8-soname.patch, duma-2.4.27.ebuild, +duma-2.5.8.ebuild:
+ Version bump and stable bump (special case, since there was only one
+ unstable version to begin with). Closes bug 195203.
*duma-2.4.27 (03 Apr 2007)
diff --git a/dev-util/duma/duma-2.4.27.ebuild b/dev-util/duma/duma-2.4.27.ebuild
index 2ce12e8c478a..692a1a4f131d 100644
--- a/dev-util/duma/duma-2.4.27.ebuild
+++ b/dev-util/duma/duma-2.4.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/duma-2.4.27.ebuild,v 1.2 2007/07/12 01:05:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/duma-2.4.27.ebuild,v 1.3 2007/10/10 00:35:22 nerdboy Exp $
inherit eutils versionator multilib toolchain-funcs
# flag-o-matic
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/duma/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
DEPEND="virtual/libc"
@@ -38,12 +38,10 @@ pkg_setup() {
}
src_unpack(){
- unpack ${A}
+ unpack "${A}"
cd "${S}"
epatch "${FILESDIR}/${P}-types.patch"
epatch "${FILESDIR}/${P}-make.patch"
- # source has carriage returns scattered throughout...
- #edos2unix *
}
src_compile(){
@@ -51,7 +49,7 @@ src_compile(){
# for next part of compile
use amd64 && export DUMA_ALIGNMENT=16
# append-flags doesn't work here (stupid static makefile)
- emake CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" CC=$(tc-getCC) \
+ make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" CC=$(tc-getCC) \
|| die "emake failed"
}
@@ -59,7 +57,7 @@ src_test() {
einfo "Control-C now if you want to disable tests..."
epause 5
- cd ${S}
+ cd "${S}"
use amd64 && export DUMA_ALIGNMENT=16
make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" \
CC=$(tc-getCC) check || die "make check failed"
diff --git a/dev-util/duma/duma-2.5.8.ebuild b/dev-util/duma/duma-2.5.8.ebuild
new file mode 100644
index 000000000000..b229149e8fff
--- /dev/null
+++ b/dev-util/duma/duma-2.5.8.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/duma/duma-2.5.8.ebuild,v 1.1 2007/10/10 00:35:22 nerdboy Exp $
+
+inherit eutils toolchain-funcs versionator
+
+MY_P="${PN}_$(replace_all_version_separators '_')"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="DUMA (Detect Unintended Memory Access) is a memory debugging library."
+HOMEPAGE="http://duma.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/duma/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ app-shells/bash"
+
+pkg_setup() {
+ #DUMA_OPTIONS="-DDUMA_LIB_NO_LEAKDETECTION"
+ DUMA_OPTIONS="-DDUMA_USE_FRAMENO"
+ if [ -n "${DUMA_OPTIONS}" ]; then
+ ewarn ""
+ elog "Custom build options are ${DUMA_OPTIONS}."
+ ewarn ""
+ else
+ ewarn ""
+ elog "Custom build options are not set!"
+ elog "See the package Makefile for more options."
+ ewarn ""
+ fi
+}
+
+src_unpack(){
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-soname.patch"
+}
+
+src_compile(){
+ use amd64 && export DUMA_ALIGNMENT=16
+ # append-flags doesn't work here (stupid static makefile) and neither
+ # does distcc :(
+ make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" CC=$(tc-getCC) \
+ || die "emake failed"
+}
+
+src_test() {
+ ewarn "Control-C now if you want to disable tests..."
+ epause 5
+
+ cd "${S}"
+ use amd64 && export DUMA_ALIGNMENT=16
+ make CFLAGS="${DUMA_OPTIONS} ${CFLAGS}" \
+ CC=$(tc-getCC) check || die "make check failed"
+
+ ewarn "Check output above to verify all tests have passed..."
+}
+
+src_install(){
+ # make install fails nicely here on the first file...
+ newbin duma.sh duma
+ dolib.so libduma.so.0.0
+ dosym libduma.so.0.0 /usr/$(get_libdir)/libduma.so.0
+ dosym libduma.so.0.0 /usr/$(get_libdir)/libduma.so
+ dolib.a libduma.a
+
+ insinto /usr/include
+ doins duma.h dumapp.h sem_inc.h paging.h print.h duma_hlp.h noduma.h \
+ || die "failed to install headers"
+
+ dodoc CHANGELOG README.txt TODO
+ doman duma.3
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples
+ doins example[1-6].cpp
+ doins example_makes/ex6/Makefile
+ fi
+}
diff --git a/dev-util/duma/files/digest-duma-2.5.8 b/dev-util/duma/files/digest-duma-2.5.8
new file mode 100644
index 000000000000..17c2ba3cad3e
--- /dev/null
+++ b/dev-util/duma/files/digest-duma-2.5.8
@@ -0,0 +1,3 @@
+MD5 23d5868996f76a79bd148e76ff10eb23 duma_2_5_8.tar.gz 219961
+RMD160 37a1cefa853b15ea5ec9da92a8deeca500ca34b9 duma_2_5_8.tar.gz 219961
+SHA256 43a96d92384c22c191fbc6f935d0ed4ae378a561776dc7fcdf64763728c65770 duma_2_5_8.tar.gz 219961
diff --git a/dev-util/duma/files/duma-2.5.8-soname.patch b/dev-util/duma/files/duma-2.5.8-soname.patch
new file mode 100644
index 000000000000..29af55dc73a6
--- /dev/null
+++ b/dev-util/duma/files/duma-2.5.8-soname.patch
@@ -0,0 +1,13 @@
+--- Makefile.orig 2007-10-09 16:34:53.000000000 -0700
++++ Makefile 2007-10-09 16:54:28.000000000 -0700
+@@ -326,8 +326,8 @@
+ else
+
+ $(DUMASO): duma_config.h $(SO_OBJECTS)
+- $(CXX) -g -shared -Wl,-soname,$(DUMASO) -o $(DUMASO) $(SO_OBJECTS) -lpthread -lc
+- $(CXX) -g -shared -o $(DUMASO) $(SO_OBJECTS) -lpthread -lc
++ $(CXX) -g -shared -Wl,-soname -Wl,$(DUMASO) -o $(DUMASO) $(SO_OBJECTS) -lpthread -lc
++# $(CXX) -g -shared -o $(DUMASO) $(SO_OBJECTS) -lpthread -lc
+
+ endif
+