summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2003-10-05 21:30:15 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2003-10-05 21:30:15 +0000
commitee0a3ebe81a5984016053d10ddb1420924e72fd5 (patch)
tree79384b9f5304ced770e36fbe2fe8d130a6dd5d2f /dev-util/eclipse-sdk
parentFixes #19317. (diff)
downloadgentoo-2-ee0a3ebe81a5984016053d10ddb1420924e72fd5.tar.gz
gentoo-2-ee0a3ebe81a5984016053d10ddb1420924e72fd5.tar.bz2
gentoo-2-ee0a3ebe81a5984016053d10ddb1420924e72fd5.zip
Fixes #19317.
Diffstat (limited to 'dev-util/eclipse-sdk')
-rw-r--r--dev-util/eclipse-sdk/ChangeLog10
-rw-r--r--dev-util/eclipse-sdk/Manifest6
-rw-r--r--dev-util/eclipse-sdk/eclipse-sdk-2.1.1.ebuild219
-rw-r--r--dev-util/eclipse-sdk/files/digest-eclipse-sdk-2.1.11
-rw-r--r--dev-util/eclipse-sdk/files/eclipse50
-rw-r--r--dev-util/eclipse-sdk/files/eclipse.desktop7
-rw-r--r--dev-util/eclipse-sdk/metadata.xml21
7 files changed, 307 insertions, 7 deletions
diff --git a/dev-util/eclipse-sdk/ChangeLog b/dev-util/eclipse-sdk/ChangeLog
index d7581dd35cbd..83737aa49705 100644
--- a/dev-util/eclipse-sdk/ChangeLog
+++ b/dev-util/eclipse-sdk/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for dev-util/eclipse-sdk
# Copyright 2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.2 2003/06/30 19:27:41 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.3 2003/10/05 21:30:09 karltk Exp $
+*eclipse-sdk-2.1.1 (05 Oct 2003)
+
+ 05 Oct 2003; Karl Trygve Kalleberg <karltk@gentoo.org>
+ eclipse-sdk-2.1.1.ebuild, files/eclipse:
+ Thanks to the wonderful work of Jesse <yurkjes@iit.edu> and Tom Prado
+ <tprado@charter.net>, we finally have from-source ebuild for the SDK.
+ Fixes #19317.
+
*eclipse-sdk-2.1 (30 Jun 2003)
30 Jun 2003; Karl Trygve Kalleberg <karltk@gentoo.org>
diff --git a/dev-util/eclipse-sdk/Manifest b/dev-util/eclipse-sdk/Manifest
index 1d47adf9ed2b..36e27416b387 100644
--- a/dev-util/eclipse-sdk/Manifest
+++ b/dev-util/eclipse-sdk/Manifest
@@ -1,7 +1,7 @@
-MD5 f464c50745c4a816d6570fe26184d67f ChangeLog 593
+MD5 a782eed1447d08a0c8df7d702c60c36f ChangeLog 890
MD5 1d0493e018ee744da0fd103bd767909a eclipse-sdk-2.1.ebuild 82879
-MD5 28ab9a40f333f380d4affb70bfbf01aa eclipse-sdk-2.1.1.ebuild 7448
-MD5 4ff41318b6b8f841af091142db5fc73c eclipse-sdk-2.1.1.ebuild~ 7483
+MD5 6bd2e7d17900088eb3eebe779ac85875 eclipse-sdk-2.1.1.ebuild 7419
+MD5 9cc8d5162e981d7b7fc1ef9fa1ac0e65 metadata.xml 919
MD5 5bea1174eca3d2e368ad728e5086b24a files/digest-eclipse-sdk-2.1 86
MD5 a01c2dd64e43d4ee9dd96dbf0b4578c7 files/eclipse.desktop 213
MD5 9b30c0b9d4af6ed66a09e216efadefe6 files/eclipse 1067
diff --git a/dev-util/eclipse-sdk/eclipse-sdk-2.1.1.ebuild b/dev-util/eclipse-sdk/eclipse-sdk-2.1.1.ebuild
new file mode 100644
index 000000000000..4093ced39b44
--- /dev/null
+++ b/dev-util/eclipse-sdk/eclipse-sdk-2.1.1.ebuild
@@ -0,0 +1,219 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Eclipse Tools Platform"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI=" http://download2.eclipse.org/downloads/drops/R-2.1.1-200306271545/eclipse-sourceBuild-srcIncluded-2.1.1.zip"
+IUSE="gtk motif gnome kde"
+
+SLOT="0"
+LICENSE="CPL-1.0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="${RDEPEND}
+ >=dev-java/ant-1.5.3
+ >=sys-apps/sh-utils-2.0.15
+ >=sys-apps/findutils-4.1.7
+ >=app-shells/tcsh-6.12"
+
+# removed since the bin lives in /opt and this in /usr
+# !dev-util/eclipse-platform-bin
+# !dev-util/eclipse-jdt-bin
+# !dev-util/eclipse-cdt-bin"
+
+RDEPEND=">=virtual/jdk-1.3
+ kde? ( kde-base/kde virtual/motif ) :
+ ( gnome? ( =gnome-base/gnome-vfs-2* ) :
+ ( motif? ( virtual/motif ) :
+ ( >=x11-libs/gtk+-2.2.1-r1 ) ) )
+ motif? ( virtual/motif )
+ gnome? ( =gnome-base/gnome-vfs-2* )
+ gtk? ( >=x11-libs/gtk+-2.2.1-r1 )"
+
+S=${WORKDIR}/eclipse
+
+src_compile() {
+
+ # This ebuild is doing some slightly funky things since the
+ # source tarball also contains all the binaries for eclipse. On
+ # top of this, there are a ton of files that need to be merged
+ # so instead of specifying all these files, we're instead
+ # removing all the extra fluff from the source tree and then
+ # merging it all over when we're done.
+
+ # This ebuild will compile eclipse for gtk2, motif, and kde
+ # toolkits depending on the use flags set. If all are set, the
+ # default version linked to is the GTK2 version. When building
+ # for KDE though, the motif version must be built with support
+ # for KDE. Apparently the motif build also supports KDE when
+ # this is done - I could be wrong though.
+
+ gtk_launcher_src_dir="${WORKDIR}/plugins/platform-launcher/library/gtk"
+ motif_launch_src_dir="${WORKDIR}/plugins/platform-launcher/library/motif"
+ gtk_swt_src_dir=${WORKDIR}/plugins/org.eclipse.swt/Eclipse\ SWT\ PI/gtk/library
+ motif_swt_src_dir=${WORKDIR}/plugins/org.eclipse.swt/Eclipse\ SWT\ PI/motif/library
+
+ case $ARCH in
+ sparc)
+ gtk_swt_dest_dir="${WORKDIR}/plugins/org.eclipse.swt.gtk/os/solaris/sparc"
+ motif_swt_dest_dir="${WORKDIR}/plugins/org.eclipse.swt.motif/os/solaris/sparc"
+ ;;
+ x86)
+ gtk_swt_dest_dir="${WORKDIR}/plugins/org.eclipse.swt.gtk/os/linux/x86"
+ motif_swt_dest_dir="${WORKDIR}/plugins/org.eclipse.swt.motif/os/linux/x86"
+ ;;
+ ppc)
+ gtk_swt_dest_dir="${WORKDIR}/plugins/org.eclipse.swt.gtk/os/linux/ppc"
+ motif_swt_dest_dir="${WORKDIR}/plugins/org.eclipse.swt.motif/os/linux/ppc"
+ ;;
+ esac
+
+ use gtk && gtk=y
+ use motif && motif=y
+ use gnome && gnome=y gtk=y
+ use kde && kde=y motif=y
+
+ # force gtk to be the default if motif isn't selected
+ if ! [ ${motif} = "y" ] ; then
+ gtk=y
+ fi
+
+ cd ${WORKDIR}
+
+ # First build all java code
+
+ # this export is pulled from the build shellscript supplied by
+ # eclipse. It fixes an outOfMemory exception during the ant build
+ # process.
+ export ANT_OPTS=-Xmx256m
+
+ override_motif_target=
+ if [ "${gtk}" = "y" ] ; then
+ ant -buildfile build.xml -Dos=linux -Dws=gtk
+ #only do a compile/install for motif... Don't do a buildDoc. This will save time...
+ override_motif_target=compile install
+ fi
+ if [ "${motif}" = "y" ] ; then
+ ant -buildfile ${override_motif_target} build.xml -Dos=linux -Dws=motif
+ fi
+
+ # remove all .so files shipped with the tarball
+ find ${WORKDIR} -name '*.so' -exec rm -f {} \;
+
+ # remove the eclipse binary copied from the ant build above.
+ rm -f ${WORKDIR}/eclipse
+
+
+ # I'm replacing these pkg-config lines since --libs for them
+ # returns -pthread instead of -lpthread and remove the -Wl, since
+ # ld doesn't know what to do with it.
+
+ GNOME_LIB=`pkg-config --libs gnome-vfs-2.0 | sed -e "s:-pthread:-lpthread:" -e "s:-Wl,--export:--export:"`
+ GTHREAD_LIB=`pkg-config --libs gthread-2.0 | sed -e "s:-pthread:-lpthread:"`
+
+ # Build for the gtk toolkit
+ if [ "${gtk}" = "y" ] ; then
+ # Build the eclipse gtk binary
+ cd ${WORKDIR}/plugins/platform-launcher/library/gtk
+ tcsh build.csh -arch $ARCH || die
+ mv eclipse ${WORKDIR}/eclipse-gtk
+
+ cd "${gtk_swt_src_dir}"
+ cp ${WORKDIR}/plugins/org.eclipse.swt/Eclipse\ SWT/common/library/* .
+
+ cp make_gtk.mak make_gtk.mak.orig
+ sed -e "s:/bluebird/teamswt/swt-builddir/ive:$JAVA_HOME:" \
+ -e "s:JAVA_JNI=\$(IVE_HOME)/bin/include:JAVA_JNI=\$(IVE_HOME)/include:" \
+ -e "s:\`pkg-config --libs gthread-2.0\`:${GTHREAD_LIB}:" \
+ -e "s:\`pkg-config --libs gnome-vfs-2.0\`:${GNOME_LIB}:" \
+ -e "s:-I\$(JAVA_JNI):-I\$(JAVA_JNI) -I\$(JAVA_JNI)/linux:" \
+ make_gtk.mak.orig > make_gtk.mak
+
+ make -f make_gtk.mak make_swt
+ if [ "${gnome}" = "y" ] ; then
+ make -f make_gtk.mak make_gnome
+ fi
+
+ # move the *.so files to the right path so eclipse can find them
+ mkdir "${gtk_swt_dest_dir}"
+ mv *.so "${gtk_swt_dest_dir}"
+ make -f make_linux.mak clean #do a clean since everything is going to end up getting merged
+ fi
+
+ # Build for the motif toolkit
+ if [ "${motif}" = "y" ] ; then
+ # Build the eclipse motif binary
+ cd ${WORKDIR}/plugins/platform-launcher/library/motif
+ tcsh build.csh -arch $ARCH || die
+ mv eclipse ${WORKDIR}/eclipse-motif
+
+ cd "${motif_swt_src_dir}"
+ cp ${WORKDIR}/plugins/org.eclipse.swt/Eclipse\ SWT/common/library/* .
+
+ mv make_linux.mak make_linux.mak.orig
+ sed -e "s:/bluebird/teamswt/swt-builddir/ive:$JAVA_HOME:" \
+ -e "s:JAVA_JNI=\$(IVE_HOME)/bin/include:JAVA_JNI=\$(IVE_HOME)/include:" \
+ -e "s:/bluebird/teamswt/swt-builddir/motif21:/usr/X11R6:" \
+ -e "s:\`pkg-config --libs gthread-2.0\`:${GTHREAD_LIB}:" \
+ -e "s:\`pkg-config --libs gnome-vfs-2.0\`:${GNOME_LIB}:" \
+ -e "s:/usr/lib/qt3:/usr/qt/3:" \
+ -e "s:-lkdecore:-L\`kde-config --prefix\`/lib -lkdecore:" \
+ -e "s:-I/usr/include/kde:-I\`kde-config --prefix\`/include:" \
+ -e "s:-I\$(JAVA_JNI):-I\$(JAVA_JNI) -I\$(JAVA_JNI)/linux:" \
+ make_linux.mak.orig > make_linux.mak
+
+ make -f make_linux.mak make_swt
+ if [ "${gnome}" = "y" ] ; then
+ make -f make_linux.mak make_gnome
+ fi
+ if [ "${kde}" = "y" ] ; then
+ make -f make_linux.mak make_kde
+ fi
+
+ # move the *.so files to the right path so eclipse can find them
+ mkdir "${motif_swt_dest_dir}"
+ mv *.so "${motif_swt_dest_dir}"
+ make -f make_linux.mak clean #do a clean since everything is going to end up getting merged
+ fi
+
+
+ # remove all the java files so we can install this.
+ # there is no install target in build.xml for some reason and
+ # we don't want all of these files merged.
+ # also remove all the .project, .classpath and build.* files spread out all over the place
+ find ${WORKDIR} -name '*.java' -exec rm -f {} \;
+ find ${WORKDIR} -name '.classpath' -exec rm -f {} \;
+ find ${WORKDIR} -name '.project' -exec rm -f {} \;
+ find ${WORKDIR} -name 'build.*' -exec rm -f {} \;
+
+}
+
+src_install() {
+ cd ${WORKDIR}
+
+ exeinto /usr/bin
+ doexe ${FILESDIR}/eclipse
+
+ dodir /usr/lib/eclipse
+ exeinto /usr/lib/eclipse
+
+ if [ -f eclipse-gtk ] ; then
+ doexe eclipse-gtk
+ dosym /usr/lib/eclipse/eclipse-gtk /usr/lib/eclipse/eclipse
+ fi
+ if [ -f eclipse-motif ] ; then
+ doexe eclipse-motif
+ dosym /usr/bin/eclipse /usr/bin/eclipse-motif
+ if ! [ -f eclipse-gtk ] ; then
+ dosym /usr/lib/eclipse/eclipse-motif /usr/lib/eclipse/eclipse
+ fi
+ fi
+
+ doins plugins/org.eclipse.platform/.eclipseproduct
+
+ cp -dpR features icon.xpm plugins splash.bmp startup.jar \
+ ${D}/usr/lib/eclipse/
+
+ insinto /usr/share/gnome/apps/Development
+ doins ${FILESDIR}/eclipse.desktop
+}
diff --git a/dev-util/eclipse-sdk/files/digest-eclipse-sdk-2.1.1 b/dev-util/eclipse-sdk/files/digest-eclipse-sdk-2.1.1
new file mode 100644
index 000000000000..91890d063838
--- /dev/null
+++ b/dev-util/eclipse-sdk/files/digest-eclipse-sdk-2.1.1
@@ -0,0 +1 @@
+MD5 d2abf34a1a7c520bb4ddfc839e94e85b eclipse-sourceBuild-srcIncluded-2.1.1.zip 45028415
diff --git a/dev-util/eclipse-sdk/files/eclipse b/dev-util/eclipse-sdk/files/eclipse
new file mode 100644
index 000000000000..0a1d2165f58d
--- /dev/null
+++ b/dev-util/eclipse-sdk/files/eclipse
@@ -0,0 +1,50 @@
+#!/bin/bash
+#
+# tiny eclipse wrapper script to allow per user workbenches
+# under each user's home.
+#
+# (c) March 2003 D. Seyffer <uid0@getroot.de>
+#
+
+ECLIPSE_DIR="/usr/lib/eclipse"
+if [ "`basename $0`" = "eclipse-motif" ] ; then
+ ECLIPSE="${ECLIPSE_DIR}/eclipse-motif";
+else
+ ECLIPSE="${ECLIPSE_DIR}/eclipse";
+fi
+WORKBENCH="${HOME}/.eclipse/"
+
+###################################################
+
+if [ ! -d ${ECLIPSE_DIR} ] ; then
+ echo " Eclipse directory not found.";
+ exit 1;
+else
+ echo " Eclipse found.";
+fi
+
+
+if [ ! -x ${ECLIPSE} ] ; then
+ echo " Eclipse executable not found or not executable.";
+ exit 1;
+else
+ echo " Executable found and is executable.";
+fi
+
+
+if [ ! -d ${WORKBENCH} ] ; then
+ echo " No existing workbench for current user!";
+ echo " First time startup? Will prepare and have eclipse create one...";
+ mkdir -p ${WORKBENCH}
+ if [ ! -d ${WORKBENCH} ] ; then
+ echo " Error creating workbench env!";
+ exit 1;
+ fi
+else
+ echo " Found existing workbench directory for current user.";
+fi
+
+echo " Starting Eclipse...";
+cd ${WORKBENCH}
+${ECLIPSE}
+
diff --git a/dev-util/eclipse-sdk/files/eclipse.desktop b/dev-util/eclipse-sdk/files/eclipse.desktop
index dfb887fbe720..837d6f3fdeb9 100644
--- a/dev-util/eclipse-sdk/files/eclipse.desktop
+++ b/dev-util/eclipse-sdk/files/eclipse.desktop
@@ -1,8 +1,9 @@
[Desktop Entry]
Name=Eclipse
Comment=A Java Development Environment
-Icon=/opt/eclipse/icon.xpm
-Exec=/opt/eclipse/eclipse
+Icon=/usr/lib/eclipse/icon.xpm
+Exec=/usr/bin/eclipse
Terminal=false
Type=Application
-StartupNotify=false
+Categories=GNOME;Application;Development
+StartupNotify=true
diff --git a/dev-util/eclipse-sdk/metadata.xml b/dev-util/eclipse-sdk/metadata.xml
new file mode 100644
index 000000000000..e3d63c22fdc1
--- /dev/null
+++ b/dev-util/eclipse-sdk/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>karltk@gentoo.org</email>
+ <name>Karl Trygve Kalleberg</name>
+ <description>Maintainer</description>
+</maintainer>
+<longdescription>
+The Eclipse Project is an open source project of eclipse.org, overseen by
+a Project Management Committee (PMC) and project leaders. The work is done
+in subprojects working against a CVS repository. The Eclipse Project
+Charter describes the organization of the project, roles and
+responsibilities of the participants, and top level development process
+for the project. The JDT and PDE are plug-in tools for the Eclipse
+Platform. Together, these three pieces form the Eclipse SDK download, a
+complete development environment for Eclipse-based tools, and for
+developing Eclipse itself.
+</longdescription>
+</pkgmetadata>