summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-17 19:58:49 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-17 19:58:49 +0000
commit814f1b45fbf784a5032f34ac560984dac2a02b05 (patch)
treef514b1836fff3a44cb0880e9c07af499a62144e3 /dev-util/eric
parentVersion bump. (diff)
downloadgentoo-2-814f1b45fbf784a5032f34ac560984dac2a02b05.tar.gz
gentoo-2-814f1b45fbf784a5032f34ac560984dac2a02b05.tar.bz2
gentoo-2-814f1b45fbf784a5032f34ac560984dac2a02b05.zip
Version bump.
(Portage version: 2.2_rc83_p15/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/eric')
-rw-r--r--dev-util/eric/ChangeLog8
-rw-r--r--dev-util/eric/eric-5.0.2.ebuild92
-rw-r--r--dev-util/eric/files/eric-5.0.2-remove_coverage.patch119
3 files changed, 218 insertions, 1 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index ba2f4995d17d..840db7c961ce 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/eric
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.132 2010/09/17 19:51:26 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.133 2010/09/17 19:58:49 arfrever Exp $
+
+*eric-5.0.2 (17 Sep 2010)
+
+ 17 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +eric-5.0.2.ebuild, +files/eric-5.0.2-remove_coverage.patch:
+ Version bump.
*eric-4.4.8 (17 Sep 2010)
diff --git a/dev-util/eric/eric-5.0.2.ebuild b/dev-util/eric/eric-5.0.2.ebuild
new file mode 100644
index 000000000000..a62ce2757ccc
--- /dev/null
+++ b/dev-util/eric/eric-5.0.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-5.0.2.ebuild,v 1.1 2010/09/17 19:58:49 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.*"
+
+inherit eutils python
+
+MY_PN="${PN}${PV%%.*}"
+MY_PV="${PV/_pre/-snapshot-}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="A full featured Python IDE using PyQt4 and QScintilla"
+HOMEPAGE="http://eric-ide.python-projects.org/"
+BASE_URI="mirror://sourceforge/eric-ide/${MY_PN}/stable/${PV}"
+SRC_URI="${BASE_URI}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="5"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="spell"
+
+DEPEND=">=dev-python/PyQt4-4.7[assistant,svg,webkit,X]
+ >=dev-python/qscintilla-python-2.4"
+RDEPEND="${DEPEND}
+ >=dev-python/chardet-2.0.1
+ >=dev-python/coverage-3.2
+ >=dev-python/pygments-1.1.1"
+PDEPEND="spell? ( dev-python/pyenchant )"
+
+LANGS="cs de es it ru"
+for L in ${LANGS}; do
+ SRC_URI="${SRC_URI}
+ linguas_${L}? ( ${BASE_URI}/${MY_PN}-i18n-${L/zh_CN/zh_CN.GB2312}-${MY_PV}.tar.gz )"
+ IUSE="${IUSE} linguas_${L}"
+done
+unset L
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-remove_coverage.patch"
+
+ # Avoid file collisions between different slots of Eric.
+ sed -e "s/^Icon=eric$/&${SLOT}/" eric/${MY_PN}.desktop || die "sed failed"
+ sed -e "s/\([^[:alnum:]]\)eric\.png\([^[:alnum:]]\)/\1eric5.png\2/" -i $(grep -lr eric.png .) || die "sed failed"
+ mv eric/icons/default/eric{,5}.png || die "mv failed"
+ mv eric/pixmaps/eric{,5}.png || die "mv failed"
+ rm -f eric/APIs/Python/zope-*.api
+ rm -f eric/APIs/Ruby/Ruby-*.api
+
+ # Delete internal copies of dev-python/chardet, dev-python/coverage and dev-python/pygments.
+ rm -fr eric/ThirdParty
+ rm -fr eric/DebugClients/Python{,3}/coverage
+}
+
+src_install() {
+ installation() {
+ "$(PYTHON)" install.py \
+ -z \
+ -b "${EPREFIX}/usr/bin" \
+ -i "${D}" \
+ -d "${EPREFIX}$(python_get_sitedir)" \
+ -c
+ }
+ python_execute_function installation
+
+ doicon eric/icons/default/${MY_PN}.png || die "doicon failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize -x "/eric5/DebugClients/Python/" ${MY_PN}{,config.py,plugins}
+
+ elog
+ elog "If you want to use Eric with mod_python, have a look at"
+ elog "\"${EROOT}$(python_get_sitedir -b -f)/${MY_PN}/patch_modpython.py\"."
+ elog
+ elog "The following packages will give Eric extended functionality:"
+ elog " dev-python/pylint"
+ elog " dev-python/pysvn"
+ elog
+ elog "This version has a plugin interface with plugin-autofetch from"
+ elog "the application itself. You may want to check those as well."
+ elog
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${MY_PN}{,config.py,plugins}
+}
diff --git a/dev-util/eric/files/eric-5.0.2-remove_coverage.patch b/dev-util/eric/files/eric-5.0.2-remove_coverage.patch
new file mode 100644
index 000000000000..63425454d881
--- /dev/null
+++ b/dev-util/eric/files/eric-5.0.2-remove_coverage.patch
@@ -0,0 +1,119 @@
+--- eric/DataViews/PyCoverageDialog.py
++++ eric/DataViews/PyCoverageDialog.py
+@@ -15,7 +15,7 @@
+ from .Ui_PyCoverageDialog import Ui_PyCoverageDialog
+
+ import Utilities
+-from DebugClients.Python3.coverage import coverage
++from coverage import coverage
+
+ class PyCoverageDialog(QDialog, Ui_PyCoverageDialog):
+ """
+--- eric/eric5.e4p
++++ eric/eric5.e4p
+@@ -542,12 +542,6 @@
+ <Source>Helpviewer/HelpTopicDialog.py</Source>
+ <Source>Helpviewer/HelpSearchWidget.py</Source>
+ <Source>Helpviewer/HelpDocsInstaller.py</Source>
+- <Source>DebugClients/Python/coverage/data.py</Source>
+- <Source>DebugClients/Python/coverage/cmdline.py</Source>
+- <Source>DebugClients/Python/coverage/collector.py</Source>
+- <Source>DebugClients/Python/coverage/misc.py</Source>
+- <Source>DebugClients/Python/coverage/control.py</Source>
+- <Source>DebugClients/Python/coverage/__init__.py</Source>
+ <Source>Debugger/DebuggerInterfacePython3.py</Source>
+ <Source>Preferences/ConfigurationPages/DebuggerPython3Page.py</Source>
+ <Source>DebugClients/Python3/AsyncFile.py</Source>
+@@ -568,15 +562,6 @@
+ <Source>Helpviewer/HelpWebSearchWidget.py</Source>
+ <Source>Helpviewer/HelpClearPrivateDataDialog.py</Source>
+ <Source>Helpviewer/HelpLanguagesDialog.py</Source>
+- <Source>DebugClients/Python/coverage/html.py</Source>
+- <Source>DebugClients/Python/coverage/report.py</Source>
+- <Source>DebugClients/Python/coverage/templite.py</Source>
+- <Source>DebugClients/Python/coverage/codeunit.py</Source>
+- <Source>DebugClients/Python/coverage/summary.py</Source>
+- <Source>DebugClients/Python/coverage/files.py</Source>
+- <Source>DebugClients/Python/coverage/annotate.py</Source>
+- <Source>DebugClients/Python/coverage/parser.py</Source>
+- <Source>DebugClients/Python/coverage/execfile.py</Source>
+ <Source>Helpviewer/CookieJar/__init__.py</Source>
+ <Source>Helpviewer/CookieJar/CookiesExceptionsDialog.py</Source>
+ <Source>Helpviewer/CookieJar/CookieModel.py</Source>
+@@ -631,23 +616,6 @@
+ <Source>IconEditor/IconEditorWindow.py</Source>
+ <Source>IconEditor/IconZoomDialog.py</Source>
+ <Source>IconEditor/IconEditorPalette.py</Source>
+- <Source>DebugClients/Python/coverage/backward.py</Source>
+- <Source>DebugClients/Python3/coverage/__init__.py</Source>
+- <Source>DebugClients/Python3/coverage/annotate.py</Source>
+- <Source>DebugClients/Python3/coverage/backward.py</Source>
+- <Source>DebugClients/Python3/coverage/cmdline.py</Source>
+- <Source>DebugClients/Python3/coverage/codeunit.py</Source>
+- <Source>DebugClients/Python3/coverage/collector.py</Source>
+- <Source>DebugClients/Python3/coverage/control.py</Source>
+- <Source>DebugClients/Python3/coverage/data.py</Source>
+- <Source>DebugClients/Python3/coverage/execfile.py</Source>
+- <Source>DebugClients/Python3/coverage/files.py</Source>
+- <Source>DebugClients/Python3/coverage/html.py</Source>
+- <Source>DebugClients/Python3/coverage/misc.py</Source>
+- <Source>DebugClients/Python3/coverage/parser.py</Source>
+- <Source>DebugClients/Python3/coverage/report.py</Source>
+- <Source>DebugClients/Python3/coverage/summary.py</Source>
+- <Source>DebugClients/Python3/coverage/templite.py</Source>
+ <Source>ThirdParty/Pygments/pygments/lexers/parsers.py</Source>
+ <Source>Helpviewer/Passwords/__init__.py</Source>
+ <Source>Helpviewer/Passwords/PasswordManager.py</Source>
+@@ -700,14 +668,6 @@
+ <Source>eric5-api.py</Source>
+ <Source>DebugClients/Python/eric5dbgstub.py</Source>
+ <Source>DebugClients/Python3/eric5dbgstub.py</Source>
+- <Source>DebugClients/Python3/coverage/bytecode.py</Source>
+- <Source>DebugClients/Python3/coverage/xmlreport.py</Source>
+- <Source>DebugClients/Python3/coverage/phystokens.py</Source>
+- <Source>DebugClients/Python3/coverage/results.py</Source>
+- <Source>DebugClients/Python/coverage/bytecode.py</Source>
+- <Source>DebugClients/Python/coverage/xmlreport.py</Source>
+- <Source>DebugClients/Python/coverage/phystokens.py</Source>
+- <Source>DebugClients/Python/coverage/results.py</Source>
+ <Source>E5XML/ProjectWriter.py</Source>
+ <Source>E5XML/SessionWriter.py</Source>
+ <Source>E5XML/ProjectHandler.py</Source>
+@@ -1082,15 +1042,11 @@
+ <Other>ThirdParty/Pygments/pygments/AUTHORS</Other>
+ <Other>ThirdParty/Pygments/pygments/PKG-INFO</Other>
+ <Other>Documentation/Help</Other>
+- <Other>DebugClients/Python/coverage/htmlfiles</Other>
+ <Other>IconEditor/cursors/aim-cursor.xpm</Other>
+ <Other>IconEditor/cursors/colorpicker-cursor.xpm</Other>
+ <Other>IconEditor/cursors/eraser-cursor.xpm</Other>
+ <Other>IconEditor/cursors/fill-cursor.xpm</Other>
+ <Other>IconEditor/cursors/paintbrush-cursor.xpm</Other>
+- <Other>DebugClients/Python/coverage/doc</Other>
+- <Other>DebugClients/Python3/coverage/doc</Other>
+- <Other>DebugClients/Python3/coverage/htmlfiles</Other>
+ <Other>eric5config.linux</Other>
+ <Other>eric5.e4p</Other>
+ <Other>README-eric5-doc.txt</Other>
+--- eric/PyUnit/UnittestDialog.py
++++ eric/PyUnit/UnittestDialog.py
+@@ -23,7 +23,7 @@
+ from .Ui_UnittestDialog import Ui_UnittestDialog
+ from .Ui_UnittestStacktraceDialog import Ui_UnittestStacktraceDialog
+
+-from DebugClients.Python3.coverage import coverage
++from coverage import coverage
+
+ import UI.PixmapCache
+
+--- eric/QScintilla/Editor.py
++++ eric/QScintilla/Editor.py
+@@ -27,7 +27,7 @@
+
+ from Debugger.EditBreakpointDialog import EditBreakpointDialog
+
+-from DebugClients.Python3.coverage import coverage
++from coverage import coverage
+
+ from DataViews.CodeMetricsDialog import CodeMetricsDialog
+ from DataViews.PyCoverageDialog import PyCoverageDialog