summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2005-04-23 13:00:03 +0000
committerMarius Mauch <genone@gentoo.org>2005-04-23 13:00:03 +0000
commit075b9ccd34a33ce04cf68c62d5a916c95fbc2b63 (patch)
treeaec1ccb9a15b7604c41769840e13851f60921e28 /dev-util/gambas
parentRemove RESTRICT="nomirror". (diff)
downloadgentoo-2-075b9ccd34a33ce04cf68c62d5a916c95fbc2b63.tar.gz
gentoo-2-075b9ccd34a33ce04cf68c62d5a916c95fbc2b63.tar.bz2
gentoo-2-075b9ccd34a33ce04cf68c62d5a916c95fbc2b63.zip
version bump
(Portage version: 1.586-cvs)
Diffstat (limited to 'dev-util/gambas')
-rw-r--r--dev-util/gambas/ChangeLog8
-rw-r--r--dev-util/gambas/Manifest14
-rw-r--r--dev-util/gambas/files/digest-gambas-1.0.51
-rw-r--r--dev-util/gambas/gambas-1.0.4.ebuild4
-rw-r--r--dev-util/gambas/gambas-1.0.5.ebuild82
5 files changed, 95 insertions, 14 deletions
diff --git a/dev-util/gambas/ChangeLog b/dev-util/gambas/ChangeLog
index fff2f23c3475..6e7d111cf4c2 100644
--- a/dev-util/gambas/ChangeLog
+++ b/dev-util/gambas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/gambas
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.27 2005/04/06 07:40:59 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.28 2005/04/23 13:00:03 genone Exp $
+
+*gambas-1.0.5 (23 Apr 2005)
+
+ 23 Apr 2005; Marius Mauch <genone@gentoo.org> gambas-1.0.4.ebuild,
+ +gambas-1.0.5.ebuild:
+ version bump, maybe fixes bug #88422.
06 Apr 2005; Marius Mauch <genone@gentoo.org> -gambas-0.99.ebuild,
-gambas-1.0.1.ebuild, -gambas-1.0.2.ebuild, -gambas-1.0.3.ebuild,
diff --git a/dev-util/gambas/Manifest b/dev-util/gambas/Manifest
index 1c4269dba3af..b5011809fc37 100644
--- a/dev-util/gambas/Manifest
+++ b/dev-util/gambas/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 622720c5c5e309d4457ff037f8a4175f metadata.xml 222
MD5 be32cd74e0aa20aeb17e6b0a68a63869 ChangeLog 5397
-MD5 11e34c60b9b94344cf515b1ab0158fe7 gambas-1.0.4.ebuild 2345
+MD5 aff169e440c6331866c2dcc3a6d858d1 gambas-1.0.4.ebuild 2344
+MD5 aff169e440c6331866c2dcc3a6d858d1 gambas-1.0.5.ebuild 2344
MD5 39016f3bbaf4069a963b10796d8f48f1 files/WebHome.html 692
MD5 13a65dd33d4fd1d346206b80aaf3a1ff files/Makefile.am-0.97a 1528
MD5 cb40c4d6cc8de988f3e5d60e53108472 files/Makefile.am-1.0_rc2 1508
MD5 0b4e0cd89a1d1ed6a2250a19918528f9 files/digest-gambas-1.0.4 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCU5NM6J2i8a8J4okRAq8eAKC1uMkLJ253DK+u4RfossXM3vghNgCeKvk2
-agRxInNPlE9tNt8XDziFk64=
-=KdXk
------END PGP SIGNATURE-----
+MD5 265e986859806469c43d4ad4cebbf967 files/digest-gambas-1.0.5 66
diff --git a/dev-util/gambas/files/digest-gambas-1.0.5 b/dev-util/gambas/files/digest-gambas-1.0.5
new file mode 100644
index 000000000000..7339e1460430
--- /dev/null
+++ b/dev-util/gambas/files/digest-gambas-1.0.5
@@ -0,0 +1 @@
+MD5 c80f6669203a9841ed79cba25e40a30a gambas-1.0.5.tar.bz2 4242919
diff --git a/dev-util/gambas/gambas-1.0.4.ebuild b/dev-util/gambas/gambas-1.0.4.ebuild
index 5d2a31bbbc02..6721b99ca57f 100644
--- a/dev-util/gambas/gambas-1.0.4.ebuild
+++ b/dev-util/gambas/gambas-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-1.0.4.ebuild,v 1.2 2005/04/06 07:40:59 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-1.0.4.ebuild,v 1.3 2005/04/23 13:00:03 genone Exp $
inherit eutils
@@ -47,7 +47,7 @@ src_compile() {
myconf="${myconf} `use_enable sdl`"
myconf="${myconf} `use_enable curl`"
myconf="${myconf} `use_enable zlib`"
- myconf="${myconf} `use_enable xml2 libxml`"
+ myconf="${myconf} `use_enable xml libxml`"
myconf="${myconf} `use_enable xsl xslt`"
myconf="${myconf} `use_enable zlib bzlib2`"
myconf="${myconf} `use_enable kde`"
diff --git a/dev-util/gambas/gambas-1.0.5.ebuild b/dev-util/gambas/gambas-1.0.5.ebuild
new file mode 100644
index 000000000000..477934861a92
--- /dev/null
+++ b/dev-util/gambas/gambas-1.0.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-1.0.5.ebuild,v 1.1 2005/04/23 13:00:03 genone Exp $
+
+inherit eutils
+
+DESCRIPTION="a RAD tool for BASIC"
+HOMEPAGE="http://gambas.sourceforge.net"
+SRC_URI="http://gambas.sourceforge.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="postgres mysql sdl doc curl debug sqlite xml xsl zlib kde"
+
+DEPEND=">=sys-devel/automake-1.7.5
+ >=x11-libs/qt-3.2
+ kde? ( >=kde-base/kdelibs-3.2 )
+ sdl? ( media-libs/libsdl media-libs/sdl-mixer sys-libs/gpm )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ curl? ( net-misc/curl )
+ sqlite? ( dev-db/sqlite )
+ xml? ( dev-libs/libxml2 )
+ xsl? ( dev-libs/libxslt )
+ zlib? ( sys-libs/zlib app-arch/bzip2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:-Os::' configure
+ # replace braindead Makefile (it's getting better, but
+ # still has the stupid symlink stuff)
+ rm Makefile*
+ cp "${FILESDIR}/Makefile.am-1.0_rc2" ./Makefile.am
+
+ automake
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} --enable-qt --enable-net --enable-vb"
+ myconf="${myconf} `use_enable mysql`"
+ myconf="${myconf} `use_enable postgres`"
+ myconf="${myconf} `use_enable sqlite`"
+ myconf="${myconf} `use_enable sdl`"
+ myconf="${myconf} `use_enable curl`"
+ myconf="${myconf} `use_enable zlib`"
+ myconf="${myconf} `use_enable xml libxml`"
+ myconf="${myconf} `use_enable xsl xslt`"
+ myconf="${myconf} `use_enable zlib bzlib2`"
+ myconf="${myconf} `use_enable kde`"
+
+ if use debug ; then
+ myconf="${myconf} --disable-optimization --enable-debug --enable-profiling"
+ else
+ myconf="${myconf} --enable-optimization --disable-debug --disable-profiling"
+ fi
+
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ export PATH="${D}/usr/bin:${PATH}"
+ make DESTDIR="$D" install || die
+
+ dodoc README INSTALL NEWS AUTHORS ChangeLog TODO
+
+ # only install the API docs and examples with USE=doc
+ if use doc; then
+ mv ${D}/usr/share/${PN}/help ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/${PN}/examples ${D}/usr/share/doc/${PF}/examples
+ else
+ dohtml ${FILESDIR}/WebHome.html
+ fi
+ rm -rf ${D}/usr/share/${PN}/help ${D}/usr/share/${PN}/examples
+ dosym ../doc/${PF}/html /usr/share/${PN}/help
+ dosym ../doc/${PF}/examples /usr/share/${PN}/examples
+}