summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2012-08-01 12:34:21 +0000
committerNathan Phillip Brink <binki@gentoo.org>2012-08-01 12:34:21 +0000
commit6ead1fb9d6d617c27ba21fbfb1a454bad7a8a5a9 (patch)
tree75058150c69218836899ed88a8634899bfb67f4c /dev-util/geany-plugins
parentFix libmetalink DEPEND, bug #429334 (diff)
downloadgentoo-2-6ead1fb9d6d617c27ba21fbfb1a454bad7a8a5a9.tar.gz
gentoo-2-6ead1fb9d6d617c27ba21fbfb1a454bad7a8a5a9.tar.bz2
gentoo-2-6ead1fb9d6d617c27ba21fbfb1a454bad7a8a5a9.zip
Bump to geany-plugins-1.22 for bug #429056.
(Portage version: 2.2.0_alpha116-r1/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/geany-plugins')
-rw-r--r--dev-util/geany-plugins/ChangeLog9
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.22.ebuild79
-rw-r--r--dev-util/geany-plugins/metadata.xml3
3 files changed, 88 insertions, 3 deletions
diff --git a/dev-util/geany-plugins/ChangeLog b/dev-util/geany-plugins/ChangeLog
index 43ae49332902..16639175e772 100644
--- a/dev-util/geany-plugins/ChangeLog
+++ b/dev-util/geany-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/geany-plugins
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/geany-plugins/ChangeLog,v 1.16 2012/06/20 08:38:25 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/geany-plugins/ChangeLog,v 1.17 2012/08/01 12:34:21 binki Exp $
+
+*geany-plugins-1.22 (01 Aug 2012)
+
+ 01 Aug 2012; Nathan Phillip Brink <binki@gentoo.org>
+ +geany-plugins-1.22.ebuild, metadata.xml:
+ Bump to geany-plugins-1.22 for bug #429056.
20 Jun 2012; Lars Wendler <polynomial-c@gentoo.org>
-geany-plugins-0.19.ebuild:
@@ -74,4 +80,3 @@
+geany-plugins-0.19.ebuild, +metadata.xml:
Initial commit from sunrise overlay. Big thanks to Nathan who volunteered
to take care of this package.
-
diff --git a/dev-util/geany-plugins/geany-plugins-1.22.ebuild b/dev-util/geany-plugins/geany-plugins-1.22.ebuild
new file mode 100644
index 000000000000..c8d9d904539d
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-1.22.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/geany-plugins/geany-plugins-1.22.ebuild,v 1.1 2012/08/01 12:34:21 binki Exp $
+
+EAPI=4
+
+inherit autotools-utils versionator
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="http://plugins.geany.org/geany-plugins"
+SRC_URI="http://plugins.geany.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debugger devhelp enchant gpg gtkspell lua multiterm nls soup webkit"
+
+LINGUAS="be ca da de es fr gl ja pt pt_BR ru tr zh_CN"
+
+RDEPEND=">=dev-util/geany-$(get_version_component_range 1-2)
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ debugger? ( x11-libs/vte:0 )
+ devhelp? (
+ dev-util/devhelp
+ gnome-base/gconf:2
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libwnck:1
+ )
+ enchant? ( app-text/enchant )
+ gpg? ( app-crypt/gpgme )
+ gtkspell? ( app-text/gtkspell:2 )
+ lua? ( dev-lang/lua )
+ multiterm? (
+ x11-libs/gtk+:2
+ x11-libs/vte:0
+ )
+ soup? ( net-libs/libsoup )
+ webkit? (
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf:2
+ )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+src_configure() {
+ # GeanyGenDoc requires ctpl which isn't yet in portage
+ local myeconfargs=(
+ --docdir=/usr/share/doc/${PF}
+ --disable-cppcheck
+ --disable-extra-c-warnings
+ --disable-geanygendoc
+ --enable-geanygdb
+ --enable-geanymacro
+ --enable-geanynumberedbookmarks
+ --enable-gproject
+ --enable-pretty-printer
+ --enable-tableconvert
+ --enable-treebrowser
+ --enable-xmlsnippets
+ $(use_enable debugger)
+ $(use_enable devhelp)
+ $(use_enable enchant spellcheck)
+ $(use_enable gpg geanypg)
+ $(use_enable gtkspell)
+ $(use_enable multiterm)
+ $(use_enable lua geanylua)
+ $(use_enable nls)
+ # Having updatechecker... when you're using a package manager?
+ $(use_enable soup updatechecker)
+ $(use_enable soup geniuspaste)
+ $(use_enable webkit webhelper)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-util/geany-plugins/metadata.xml b/dev-util/geany-plugins/metadata.xml
index a7a016185749..4f3fe7d6560d 100644
--- a/dev-util/geany-plugins/metadata.xml
+++ b/dev-util/geany-plugins/metadata.xml
@@ -11,7 +11,8 @@
<flag name='enchant'>Enable spell checking using enchant</flag>
<flag name='gpg'>Enable geanypg plugin which integrates GPG using <pkg>app-crypt/gpgme</pkg></flag>
<flag name='gtkspell'>Use gtkspell for dictionary support</flag>
- <flag name='soup'>Enable updatechecker plugin which requires net-libs/libsoup</flag>
+ <flag name='multiterm'>Enable the multiterm plugin</flag>
+ <flag name='soup'>Enable updatechecker and geniuspaste plugins which require <pkg>net-libs/libsoup</pkg></flag>
<flag name='webkit'>Enable webhelper plugin which requires net-libs/webkit-gtk</flag>
</use>
</pkgmetadata>