summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2012-09-26 05:33:52 +0000
committerNathan Phillip Brink <binki@gentoo.org>2012-09-26 05:33:52 +0000
commit89572f7a3c04d3c7e10475399557e6665a52bf57 (patch)
tree8d9ac3d1078de77cf320c6e3732553893e85d4f9 /dev-util/geany-plugins
parentChange as-is to HPND in LICENSE. (diff)
downloadgentoo-2-89572f7a3c04d3c7e10475399557e6665a52bf57.tar.gz
gentoo-2-89572f7a3c04d3c7e10475399557e6665a52bf57.tar.bz2
gentoo-2-89572f7a3c04d3c7e10475399557e6665a52bf57.zip
Restore and fix the multiterm useflag for bug #430926.
(Portage version: 2.2.0_alpha132-r1/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/geany-plugins')
-rw-r--r--dev-util/geany-plugins/ChangeLog8
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.22-r1.ebuild85
2 files changed, 92 insertions, 1 deletions
diff --git a/dev-util/geany-plugins/ChangeLog b/dev-util/geany-plugins/ChangeLog
index 44ec495fd38b..d2c81b3aa83b 100644
--- a/dev-util/geany-plugins/ChangeLog
+++ b/dev-util/geany-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/geany-plugins
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/geany-plugins/ChangeLog,v 1.20 2012/09/26 04:57:13 binki Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/geany-plugins/ChangeLog,v 1.21 2012/09/26 05:33:52 binki Exp $
+
+*geany-plugins-1.22-r1 (26 Sep 2012)
+
+ 26 Sep 2012; Nathan Phillip Brink <binki@gentoo.org>
+ +geany-plugins-1.22-r1.ebuild:
+ Restore and fix the multiterm useflag for bug #430926.
26 Sep 2012; Nathan Phillip Brink <binki@gentoo.org>
geany-plugins-1.22.ebuild:
diff --git a/dev-util/geany-plugins/geany-plugins-1.22-r1.ebuild b/dev-util/geany-plugins/geany-plugins-1.22-r1.ebuild
new file mode 100644
index 000000000000..468d000afebf
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-1.22-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/geany-plugins/geany-plugins-1.22-r1.ebuild,v 1.1 2012/09/26 05:33:52 binki Exp $
+
+EAPI=4
+
+inherit autotools-utils vala versionator
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="http://plugins.geany.org/geany-plugins"
+SRC_URI="http://plugins.geany.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debugger devhelp enchant gpg gtkspell lua multiterm nls soup webkit"
+
+LINGUAS="be ca da de es fr gl ja pt pt_BR ru tr zh_CN"
+
+RDEPEND=">=dev-util/geany-$(get_version_component_range 1-2)
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ debugger? ( x11-libs/vte:0 )
+ devhelp? (
+ dev-util/devhelp
+ gnome-base/gconf:2
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libwnck:1
+ )
+ enchant? ( app-text/enchant )
+ gpg? ( app-crypt/gpgme )
+ gtkspell? ( app-text/gtkspell:2 )
+ lua? ( dev-lang/lua )
+ multiterm? (
+ $(vala_depend)
+ x11-libs/gtk+:2
+ >=x11-libs/vte-0.28:0
+ )
+ soup? ( net-libs/libsoup )
+ webkit? (
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf:2
+ )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+src_prepare() {
+ autotools-utils_src_prepare
+ use multiterm && vala_src_prepare
+}
+
+src_configure() {
+ # GeanyGenDoc requires ctpl which isn't yet in portage
+ local myeconfargs=(
+ --docdir=/usr/share/doc/${PF}
+ --disable-cppcheck
+ --disable-extra-c-warnings
+ --disable-geanygendoc
+ --enable-geanygdb
+ --enable-geanymacro
+ --enable-geanynumberedbookmarks
+ --enable-gproject
+ --enable-pretty-printer
+ --enable-tableconvert
+ --enable-treebrowser
+ --enable-xmlsnippets
+ $(use_enable debugger)
+ $(use_enable devhelp)
+ $(use_enable enchant spellcheck)
+ $(use_enable gpg geanypg)
+ $(use_enable gtkspell)
+ $(use_enable multiterm)
+ $(use_enable lua geanylua)
+ $(use_enable nls)
+ # Having updatechecker... when you're using a package manager?
+ $(use_enable soup updatechecker)
+ $(use_enable soup geniuspaste)
+ $(use_enable webkit webhelper)
+ )
+
+ autotools-utils_src_configure
+}