summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-04-06 20:20:19 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-04-06 20:20:19 +0000
commitd43a458c9251353772000a9fff343419151862b7 (patch)
treeb76918f7469df1def7cf668b066f3f8c556466f9 /dev-util/guile
parentadded patch to fix compilation on ppc, fixes bug #86533 (diff)
downloadgentoo-2-d43a458c9251353772000a9fff343419151862b7.tar.gz
gentoo-2-d43a458c9251353772000a9fff343419151862b7.tar.bz2
gentoo-2-d43a458c9251353772000a9fff343419151862b7.zip
make sure ppc compiles this with -O2 rather than -O3 which causes breakage. This should fix bug #85670 by Martin <monsorno@gmx.de>, which should somewhat solve bug #27716, but I leave that to Spanky and Alastair
(Portage version: 1.585-cvs)
Diffstat (limited to 'dev-util/guile')
-rw-r--r--dev-util/guile/ChangeLog8
-rw-r--r--dev-util/guile/guile-1.6.4-r1.ebuild6
-rw-r--r--dev-util/guile/guile-1.6.6.ebuild6
-rw-r--r--dev-util/guile/guile-1.6.7.ebuild6
4 files changed, 22 insertions, 4 deletions
diff --git a/dev-util/guile/ChangeLog b/dev-util/guile/ChangeLog
index ab418f9aabe4..fbdea7868e28 100644
--- a/dev-util/guile/ChangeLog
+++ b/dev-util/guile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/guile
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/ChangeLog,v 1.38 2005/04/06 20:09:36 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/ChangeLog,v 1.39 2005/04/06 20:20:19 seemant Exp $
+
+ 06 Apr 2005; Seemant Kulleen <seemant@gentoo.org> guile-1.6.4-r1.ebuild,
+ guile-1.6.6.ebuild, guile-1.6.7.ebuild:
+ make sure ppc compiles this with -O2 rather than -O3 which causes breakage.
+ This should fix bug #85670 by Martin <monsorno@gmx.de>, which should
+ somewhat solve bug #27716, but I leave that to Spanky and Alastair
06 Apr 2005; Seemant Kulleen <seemant@gentoo.org> -guile-1.6.4.ebuild,
-guile-1.6.4-r2.ebuild:
diff --git a/dev-util/guile/guile-1.6.4-r1.ebuild b/dev-util/guile/guile-1.6.4-r1.ebuild
index 67dd6e8ae15f..0a9f10c6dee9 100644
--- a/dev-util/guile/guile-1.6.4-r1.ebuild
+++ b/dev-util/guile/guile-1.6.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.6.4-r1.ebuild,v 1.20 2005/01/28 11:03:43 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.6.4-r1.ebuild,v 1.21 2005/04/06 20:20:19 seemant Exp $
inherit flag-o-matic eutils libtool
@@ -39,6 +39,10 @@ src_compile() {
append-flags -no-cpp-precomp -Dmacosx
fi
+ if [ "${ARCH}" = "ppc" ]; then
+ replace-flags -O3 -O2
+ fi
+
econf \
--with-threads \
--with-modules || die
diff --git a/dev-util/guile/guile-1.6.6.ebuild b/dev-util/guile/guile-1.6.6.ebuild
index 039083e537e9..31e44935a322 100644
--- a/dev-util/guile/guile-1.6.6.ebuild
+++ b/dev-util/guile/guile-1.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.6.6.ebuild,v 1.2 2005/01/28 11:03:43 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.6.6.ebuild,v 1.3 2005/04/06 20:20:19 seemant Exp $
inherit flag-o-matic eutils libtool
@@ -32,6 +32,10 @@ src_compile() {
epatch ${FILESDIR}/guile-amd64.patch
fi
+ if [ "${ARCH}" = "ppc" ]; then
+ replace-flags -O3 -O2
+ fi
+
if use ppc-macos ; then
elibtoolize
epatch ${FILESDIR}/guile-macos-posix.patch
diff --git a/dev-util/guile/guile-1.6.7.ebuild b/dev-util/guile/guile-1.6.7.ebuild
index 5f1cf5b4cbc0..1642b948d520 100644
--- a/dev-util/guile/guile-1.6.7.ebuild
+++ b/dev-util/guile/guile-1.6.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.6.7.ebuild,v 1.1 2005/01/28 11:03:43 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/guile/guile-1.6.7.ebuild,v 1.2 2005/04/06 20:20:19 seemant Exp $
inherit flag-o-matic eutils libtool
@@ -34,6 +34,10 @@ src_unpack() {
epatch ${FILESDIR}/guile-amd64.patch
fi
+ if [ "${ARCH}" = "ppc" ]; then
+ replace-flags -O3 -O2
+ fi
+
if use ppc-macos ; then
elibtoolize
epatch ${FILESDIR}/guile-macos-posix.patch