summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-11-26 18:57:50 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-11-26 18:57:50 +0000
commit6b55628880eb0c440df393056c9b92ca027951ef (patch)
tree1e93bea873fce6dcc64a97b2f31479e18aa6da80 /dev-util/idutils/idutils-4.2.ebuild
parentStable on ppc64; bug #200348 (diff)
downloadgentoo-2-6b55628880eb0c440df393056c9b92ca027951ef.tar.gz
gentoo-2-6b55628880eb0c440df393056c9b92ca027951ef.tar.bz2
gentoo-2-6b55628880eb0c440df393056c9b92ca027951ef.zip
New package. Vaguely based on ebuild submission in bug #150339 by CPUShare <cpushare@cpushare.com>.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-util/idutils/idutils-4.2.ebuild')
-rw-r--r--dev-util/idutils/idutils-4.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/idutils/idutils-4.2.ebuild b/dev-util/idutils/idutils-4.2.ebuild
new file mode 100644
index 000000000000..971501a969ba
--- /dev/null
+++ b/dev-util/idutils/idutils-4.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/idutils/idutils-4.2.ebuild,v 1.1 2007/11/26 18:57:49 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Fast, high-capacity, identifier database tool"
+HOMEPAGE="http://www.gnu.org/software/idutils/"
+DEB_PN="id-utils" # old upstream name for it
+DEB_P="${DEB_PN}_${PV}"
+DEB_PR="1"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="emacs nls"
+
+RDEPEND="emacs? ( virtual/emacs )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ epatch "${DISTDIR}"/${DEB_P}-${DEB_PR}.diff.gz
+ epatch "${S}"/debian/patches/*.dpatch
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ if use emacs; then
+ emake || die
+ else
+ emake EMACS="no" || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS README* ChangeLog AUTHORS THANKS TODO
+}
+