summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-10-28 01:36:29 +0000
committerJeroen Roovers <jer@gentoo.org>2009-10-28 01:36:29 +0000
commit086a3a9cd4b620703b59cdd0b31a78a709ea8794 (patch)
tree8aa87163f09898a2ca818a413bd95f0f2282f402 /dev-util/indent
parentVersion bump. (diff)
downloadgentoo-2-086a3a9cd4b620703b59cdd0b31a78a709ea8794.tar.gz
gentoo-2-086a3a9cd4b620703b59cdd0b31a78a709ea8794.tar.bz2
gentoo-2-086a3a9cd4b620703b59cdd0b31a78a709ea8794.zip
Version bump thanks to Rafał Mużyło (bug #263932). Become maintainer.
(Portage version: 2.2_rc46/cvs/Linux i686)
Diffstat (limited to 'dev-util/indent')
-rw-r--r--dev-util/indent/ChangeLog10
-rw-r--r--dev-util/indent/indent-2.2.10.ebuild38
-rw-r--r--dev-util/indent/metadata.xml3
3 files changed, 48 insertions, 3 deletions
diff --git a/dev-util/indent/ChangeLog b/dev-util/indent/ChangeLog
index f2dba56b0614..996fd9342753 100644
--- a/dev-util/indent/ChangeLog
+++ b/dev-util/indent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/indent
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/ChangeLog,v 1.34 2007/08/06 19:39:16 uberlord Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/ChangeLog,v 1.35 2009/10/28 01:36:29 jer Exp $
+
+*indent-2.2.10 (28 Oct 2009)
+
+ 28 Oct 2009; Jeroen Roovers <jer@gentoo.org> +indent-2.2.10.ebuild,
+ metadata.xml:
+ Version bump thanks to Rafał Mużyło (bug #263932). Become maintainer.
06 Aug 2007; Roy Marples <uberlord@gentoo.org> indent-2.2.9-r3.ebuild,
indent-2.2.9-r4.ebuild:
diff --git a/dev-util/indent/indent-2.2.10.ebuild b/dev-util/indent/indent-2.2.10.ebuild
new file mode 100644
index 000000000000..d0dca35fe51d
--- /dev/null
+++ b/dev-util/indent/indent-2.2.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/indent/indent-2.2.10.ebuild,v 1.1 2009/10/28 01:36:29 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Indent program source files"
+HOMEPAGE="http://www.gnu.org/software/indent/indent.html"
+SRC_URI="mirror://gnu/indent/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+src_prepare() {
+ # Update timestamp so it isn't regenerated #76610
+ touch -r man/Makefile.am man/texinfo2man.c
+}
+
+src_configure() {
+ # LINGUAS is used in aclocal.m4 #94837
+ unset LINGUAS
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ htmldir="/usr/share/doc/${PF}/html" \
+ install || die "make install failed"
+ dodoc AUTHORS NEWS README*
+}
diff --git a/dev-util/indent/metadata.xml b/dev-util/indent/metadata.xml
index 4b1ae5a8dee7..fea2d6a8f0dd 100644
--- a/dev-util/indent/metadata.xml
+++ b/dev-util/indent/metadata.xml
@@ -3,7 +3,8 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
</maintainer>
<longdescription lang="en">
Indent is the GNU indenting program. It is used to beautify C program source