summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-01-26 01:48:07 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-01-26 01:48:07 +0000
commit981625c22806e1f3eb7cd46098bb04353c0158a5 (patch)
tree933e15f271b4c6d118e73c17912a99672aba85d8 /dev-util/intel2gas/intel2gas-1.3.3-r2.ebuild
parentwhitespace (diff)
downloadgentoo-2-981625c22806e1f3eb7cd46098bb04353c0158a5.tar.gz
gentoo-2-981625c22806e1f3eb7cd46098bb04353c0158a5.tar.bz2
gentoo-2-981625c22806e1f3eb7cd46098bb04353c0158a5.zip
QA fixes as per bug #255837 thanks kevin.pyle
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-gentoo-r4 x86_64)
Diffstat (limited to 'dev-util/intel2gas/intel2gas-1.3.3-r2.ebuild')
-rw-r--r--dev-util/intel2gas/intel2gas-1.3.3-r2.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/dev-util/intel2gas/intel2gas-1.3.3-r2.ebuild b/dev-util/intel2gas/intel2gas-1.3.3-r2.ebuild
index 6eb7b111f7ed..abfe56ae608a 100644
--- a/dev-util/intel2gas/intel2gas-1.3.3-r2.ebuild
+++ b/dev-util/intel2gas/intel2gas-1.3.3-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/intel2gas/intel2gas-1.3.3-r2.ebuild,v 1.1 2005/09/29 21:51:51 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/intel2gas/intel2gas-1.3.3-r2.ebuild,v 1.2 2009/01/26 01:48:06 dragonheart Exp $
-inherit eutils
+inherit eutils autotools toolchain-funcs
DESCRIPTION="Converts assembler source from Intel (NASM), to AT&T (gas)"
HOMEPAGE="http://www.niksula.cs.hut.fi/~mtiihone/intel2gas/"
@@ -11,18 +11,25 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/libc
- sys-devel/gcc"
-RDEPEND="virtual/libc"
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}-segfault.patch
+ epatch "${FILESDIR}"/${P}-segfault.patch
+ epatch "${FILESDIR}"/${PN}-nostrip.patch
+ epatch "${FILESDIR}"/${P}-cxx.patch
+ epatch "${FILESDIR}"/${P}-constchar.patch
+ eautomake
+}
+
+src_compile() {
+ tc-export CXX
+ econf
+ emake
}
src_install() {
emake \
- prefix=${D}/usr \
+ prefix="${D}"/usr \
install || die
fperms ugo+r /usr/share/intel2gas/i2g/main.syntax
dodoc README DATAFILES BUGS