summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-18 15:46:18 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-18 15:46:18 +0000
commit4267f6a68e518f698b1b525074e1ebabb3435ab7 (patch)
tree6c6834fc894f83e148a111b5fcc26734eecea323 /dev-util/kbuild
parentBump to 0.5.3 (diff)
downloadgentoo-2-4267f6a68e518f698b1b525074e1ebabb3435ab7.tar.gz
gentoo-2-4267f6a68e518f698b1b525074e1ebabb3435ab7.tar.bz2
gentoo-2-4267f6a68e518f698b1b525074e1ebabb3435ab7.zip
Small fix for the missing svn revision, fixes #265537 and allows virtualbox-2.2 to install. Thanks to Alessio Cassibba.
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/kbuild')
-rw-r--r--dev-util/kbuild/ChangeLog8
-rw-r--r--dev-util/kbuild/kbuild-0.1.5-r1.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-util/kbuild/ChangeLog b/dev-util/kbuild/ChangeLog
index 070111307f97..aee12765fbb4 100644
--- a/dev-util/kbuild/ChangeLog
+++ b/dev-util/kbuild/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/kbuild
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kbuild/ChangeLog,v 1.7 2009/03/29 09:47:27 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kbuild/ChangeLog,v 1.8 2009/04/18 15:46:18 patrick Exp $
+
+*kbuild-0.1.5-r1 (18 Apr 2009)
+
+ 18 Apr 2009; Patrick Lauer <patrick@gentoo.org> +kbuild-0.1.5-r1.ebuild:
+ Small fix for the missing svn revision, fixes #265537 and allows
+ virtualbox-2.2 to install. Thanks to Alessio Cassibba.
*kbuild-9999 (29 Mar 2009)
diff --git a/dev-util/kbuild/kbuild-0.1.5-r1.ebuild b/dev-util/kbuild/kbuild-0.1.5-r1.ebuild
new file mode 100644
index 000000000000..bed22d3fbdbd
--- /dev/null
+++ b/dev-util/kbuild/kbuild-0.1.5-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kbuild/kbuild-0.1.5-r1.ebuild,v 1.1 2009/04/18 15:46:18 patrick Exp $
+
+EAPI=2
+
+WANT_AUTOMAKE=1.9
+
+inherit eutils autotools
+
+MY_P=kBuild-${PV}-src-20090221
+DESCRIPTION="A makefile framework for writing simple makefiles for complex tasks"
+HOMEPAGE="http://svn.netlabs.org/kbuild/wiki"
+SRC_URI="http://gentoo.zerodev.it/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/cvs
+ sys-devel/gettext"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P/-src-20090221}
+
+src_prepare() {
+ rm -rf "${S}/kBuild/bin"
+
+ cd "${S}/src/kmk"
+ eautoreconf
+ cd "${S}/src/sed"
+ eautoreconf
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-unknown-configure-opt.patch"
+}
+
+src_compile() {
+ kBuild/env.sh --full \
+ make -f bootstrap.gmk AUTORECONF=true \
+ || die "bootstrap failed"
+}
+
+src_install() {
+ kBuild/env.sh kmk \
+ NIX_INSTALL_DIR=/usr \
+ PATH_INS="${D}" \
+ install || die "install failed"
+}