summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-02-04 14:57:06 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-02-04 14:57:06 +0000
commit27cfa8934fa06101696de134887c93f547b11476 (patch)
treee234b7f392770ba531b51e936acb3fe7c5657bcb /dev-util/kdevplatform
parentVersion bump (diff)
downloadgentoo-2-27cfa8934fa06101696de134887c93f547b11476.tar.gz
gentoo-2-27cfa8934fa06101696de134887c93f547b11476.tar.bz2
gentoo-2-27cfa8934fa06101696de134887c93f547b11476.zip
Version bump
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/kdevplatform')
-rw-r--r--dev-util/kdevplatform/ChangeLog8
-rw-r--r--dev-util/kdevplatform/kdevplatform-1.2.0.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-util/kdevplatform/ChangeLog b/dev-util/kdevplatform/ChangeLog
index b8474a5964c2..946be69060d4 100644
--- a/dev-util/kdevplatform/ChangeLog
+++ b/dev-util/kdevplatform/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/kdevplatform
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/ChangeLog,v 1.48 2011/01/30 12:53:01 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/ChangeLog,v 1.49 2011/02/04 14:57:06 tampakrap Exp $
+
+*kdevplatform-1.2.0 (04 Feb 2011)
+
+ 04 Feb 2011; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kdevplatform-1.2.0.ebuild:
+ Version bump
30 Jan 2011; Theo Chatzimichos <tampakrap@gentoo.org>
kdevplatform-1.0.2.ebuild, kdevplatform-1.1.2.ebuild:
diff --git a/dev-util/kdevplatform/kdevplatform-1.2.0.ebuild b/dev-util/kdevplatform/kdevplatform-1.2.0.ebuild
new file mode 100644
index 000000000000..039cf180b9fd
--- /dev/null
+++ b/dev-util/kdevplatform/kdevplatform-1.2.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-1.2.0.ebuild,v 1.1 2011/02/04 14:57:06 tampakrap Exp $
+
+EAPI=3
+
+# Bug 276208
+RESTRICT="test"
+
+KDE_LINGUAS="ca ca@valencia da de en_GB es et fi gl it nds nl pt pt_BR sl sv th uk zh_CN zh_TW"
+
+KMNAME="kdevelop"
+inherit kde4-base
+
+DESCRIPTION="KDE development support libraries and apps"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+# Moved to playground for now
+# bazaar kompare mercurial
+LICENSE="GPL-2 LGPL-2"
+IUSE="cvs debug git reviewboard subversion"
+
+# Moved to playground for now
+# bazaar? ( dev-vcs/bzr )
+# kompare? ( >=kde-base/kompare-${KDE_MINIMAL} )
+# mercurial? ( dev-vcs/mercurial )
+# block - some plugins moved to kdevplatform from kdevelop
+DEPEND="
+ dev-libs/boost
+ reviewboard? ( dev-libs/qjson )
+ subversion? ( >=dev-vcs/subversion-1.3 )
+"
+RDEPEND="${DEPEND}
+ !<dev-util/kdevelop-${KDEVELOP_VERSION}
+ !dev-util/kdevelop-git
+ $(add_kdebase_dep konsole)
+ cvs? ( dev-vcs/cvs )
+ git? ( dev-vcs/git )
+"
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ # FindKDevPlatform.cmake is installed by kdelibs
+ sed -i \
+ -e '/cmakeFiles/s/^/#DONOTINSTALL/' \
+ cmake/modules/CMakeLists.txt || die
+}
+
+# Moved to playground for now
+# $(cmake-utils_use_build bazaar)
+# $(cmake-utils_use_with kompare)
+# $(cmake-utils_use_build mercurial)
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build cvs)
+ $(cmake-utils_use_build git)
+ $(cmake-utils_use_with reviewboard QJSON)
+ $(cmake-utils_use_build subversion)
+ $(cmake-utils_use_with subversion SubversionLibrary)
+ )
+
+ kde4-base_src_configure
+}