summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-10-05 03:04:58 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-10-05 03:04:58 +0000
commit15423e27a47ff28a2a44bbacda105e98fbc418e3 (patch)
tree61d4e8baaf35a9c09a518dfa4760827e7b1495e9 /dev-util/larch/larch-1.0_pre0.ebuild
parentNew package (diff)
downloadgentoo-2-15423e27a47ff28a2a44bbacda105e98fbc418e3.tar.gz
gentoo-2-15423e27a47ff28a2a44bbacda105e98fbc418e3.tar.bz2
gentoo-2-15423e27a47ff28a2a44bbacda105e98fbc418e3.zip
New package
Diffstat (limited to 'dev-util/larch/larch-1.0_pre0.ebuild')
-rw-r--r--dev-util/larch/larch-1.0_pre0.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/dev-util/larch/larch-1.0_pre0.ebuild b/dev-util/larch/larch-1.0_pre0.ebuild
new file mode 100644
index 000000000000..971aa3758466
--- /dev/null
+++ b/dev-util/larch/larch-1.0_pre0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/larch/larch-1.0_pre0.ebuild,v 1.1 2003/10/05 03:04:55 rphillips Exp $
+
+MY_P="${P//_/}"
+DESCRIPTION="revision control system ideal for widely distributed development (see \"tla\" also)"
+SRC_URI="http://regexps.srparish.net/src/larch/${MY_P}.tar.gz"
+HOMEPAGE="http://regexps.srparish.net/www/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~ppc ~mips ~hppa ~sparc ~arm"
+
+S="${WORKDIR}/${MY_P}/src/=build"
+
+DEPEND="sys-apps/diffutils
+ sys-apps/coreutils
+ sys-apps/findutils
+ sys-apps/gawk
+ sys-apps/tar
+ sys-apps/util-linux
+ sys-apps/debianutils
+ sys-devel/make
+ sys-devel/patch
+ app-shells/ash"
+## hmm. "larch --help-commands" fails with dash -- so we use "ash"
+# app-shells/dash
+## => report bug to dash-people? Posix 1003.1-2001 filename-expansion with
+## wildcards fail: "*/foo"
+
+src_unpack() {
+ local t
+
+ unpack "${A}"
+ mkdir -p "${MY_P}/src/=build"
+
+ # patch arch to install its scripts in /usr/share/arch
+ # instead of /usr/libexec/arch (there is only shareables scripts).
+ t="${MY_P}/src/build-tools/Makefiles/rules.mk"
+
+ cp ${t} ${t}.orig
+ sed 's:/libexec:/share:g' ${t}.orig > ${t} || die "Patch failed for $t"
+
+ t="${MY_P}/src/build-tools/Makefiles/install-shell-subcommands.mk"
+ cp ${t} ${t}.orig
+ sed 's:/libexec:/share:g' ${t}.orig > ${t} || die "Patch failed for $t"
+}
+
+src_compile() {
+ ../configure \
+ --prefix="/usr" \
+ --with-posix-shell="/bin/ash" \
+ --with-sendmail="/usr/sbin/sendmail" || die "configure failed"
+
+ # parallel make may cause problems with this package
+ make || die "make failed"
+ make test || die "tests failed!"
+}
+
+src_install () {
+ local name
+
+ make install prefix="${D}/usr" \
+ || die "make install failed"
+
+ for name in ${D}/usr/share/arch/arch/*; do
+ name="`readlink ${name} | sed 's:^.*/usr/share/arch/::'`"
+ if [ "${name}" ]; then
+ ln -sf "../${name}" "${D}/usr/share/arch/arch/${name#*/}"
+ assert "Fixing symlink for ${name} failed"
+ fi
+ done
+
+ # get some docs
+ cd ${WORKDIR}/${MY_P}/src
+ dodoc COPYING
+ if [ $(use doc) ]; then
+ dohtml -r docs-larch
+ dodoc docs-larch/ps/arch.ps
+ fi
+}
+
+pkg_postinst() {
+ einfo "also have a look at the C-implementation of larch: \"tla\"."
+}