summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-08-02 09:05:35 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-08-02 09:05:35 +0000
commit168889d1c1018248fbc8e65bf1b3801ddd8a8ad1 (patch)
treee82f45889bcf52036e3679082b0d2b2359f935cf /dev-util/mdds
parentVersion bump supporting KDE 4.9 by Michael Palimaka <kensington@gentoo.org>. (diff)
downloadgentoo-2-168889d1c1018248fbc8e65bf1b3801ddd8a8ad1.tar.gz
gentoo-2-168889d1c1018248fbc8e65bf1b3801ddd8a8ad1.tar.bz2
gentoo-2-168889d1c1018248fbc8e65bf1b3801ddd8a8ad1.zip
Another revision bump for bug#429348.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/mdds')
-rw-r--r--dev-util/mdds/ChangeLog10
-rw-r--r--dev-util/mdds/files/0.6.0-multi-vector-build.patch24
-rw-r--r--dev-util/mdds/files/0.6.0-right-overload-of-vector.patch52
-rw-r--r--dev-util/mdds/mdds-0.6.0-r2.ebuild (renamed from dev-util/mdds/mdds-0.6.0-r1.ebuild)5
4 files changed, 88 insertions, 3 deletions
diff --git a/dev-util/mdds/ChangeLog b/dev-util/mdds/ChangeLog
index c9757a0adcdb..5af36304b27a 100644
--- a/dev-util/mdds/ChangeLog
+++ b/dev-util/mdds/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/mdds
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mdds/ChangeLog,v 1.15 2012/08/01 09:16:35 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mdds/ChangeLog,v 1.16 2012/08/02 09:05:34 scarabeus Exp $
+
+*mdds-0.6.0-r2 (02 Aug 2012)
+
+ 02 Aug 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/0.6.0-multi-vector-build.patch,
+ +files/0.6.0-right-overload-of-vector.patch, +mdds-0.6.0-r2.ebuild,
+ -mdds-0.6.0-r1.ebuild:
+ Another revision bump for bug#429348.
*mdds-0.6.0-r1 (01 Aug 2012)
diff --git a/dev-util/mdds/files/0.6.0-multi-vector-build.patch b/dev-util/mdds/files/0.6.0-multi-vector-build.patch
new file mode 100644
index 000000000000..fd2d58290514
--- /dev/null
+++ b/dev-util/mdds/files/0.6.0-multi-vector-build.patch
@@ -0,0 +1,24 @@
+From 770ff91820f8ed95f7ecc40b72b78ae57ee5d277 Mon Sep 17 00:00:00 2001
+From: Kohei Yoshida <kohei.yoshida@gmail.com>
+Date: Thu, 19 Jul 2012 15:05:47 -0400
+Subject: [PATCH] Fixes build breakage on Debian.
+
+---
+ include/mdds/multi_type_vector_types.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/mdds/multi_type_vector_types.hpp b/include/mdds/multi_type_vector_types.hpp
+index f27ac88..ac2b0ef 100644
+--- a/include/mdds/multi_type_vector_types.hpp
++++ b/include/mdds/multi_type_vector_types.hpp
+@@ -355,6 +355,7 @@ struct managed_element_block : public copyable_element_block<managed_element_blo
+ typedef managed_element_block<_TypeId,_Data> self_type;
+
+ using base_type::get;
++ using base_type::set_value;
+ using base_type::m_array;
+
+ managed_element_block() : base_type() {}
+--
+1.7.11.2
+
diff --git a/dev-util/mdds/files/0.6.0-right-overload-of-vector.patch b/dev-util/mdds/files/0.6.0-right-overload-of-vector.patch
new file mode 100644
index 000000000000..03cf1c3231f0
--- /dev/null
+++ b/dev-util/mdds/files/0.6.0-right-overload-of-vector.patch
@@ -0,0 +1,52 @@
+From 900cbea3ec067833b4284584f6dfa5502dc36de8 Mon Sep 17 00:00:00 2001
+From: David Tardon <dtardon@redhat.com>
+Date: Fri, 20 Jul 2012 10:30:38 +0200
+Subject: [PATCH] help compiler select the right overload of vector::insert
+
+---
+ include/mdds/multi_type_vector_def.inl | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/include/mdds/multi_type_vector_def.inl b/include/mdds/multi_type_vector_def.inl
+index 252a260..fb72070 100644
+--- a/include/mdds/multi_type_vector_def.inl
++++ b/include/mdds/multi_type_vector_def.inl
+@@ -1148,7 +1148,7 @@ void multi_type_vector<_CellBlockFunc>::insert_empty_impl(size_type row, size_ty
+
+ // Insert two new block below the current; one for the empty block being
+ // inserted, and one for the lower part of the current non-empty block.
+- m_blocks.insert(m_blocks.begin()+block_index+1, 2, NULL);
++ m_blocks.insert(m_blocks.begin()+block_index+1, 2u, NULL);
+
+ m_blocks[block_index+1] = new block(length);
+ m_blocks[block_index+2] = new block(size_blk_next);
+@@ -1302,7 +1302,7 @@ void multi_type_vector<_CellBlockFunc>::insert_cells_to_middle(
+ // Insert two new blocks.
+ size_type n1 = row - start_row;
+ size_type n2 = blk->m_size - n1;
+- m_blocks.insert(m_blocks.begin()+block_index+1, 2, NULL);
++ m_blocks.insert(m_blocks.begin()+block_index+1, 2u, NULL);
+ blk->m_size = n1;
+
+ m_blocks[block_index+1] = new block(length);
+@@ -1467,7 +1467,7 @@ void multi_type_vector<_CellBlockFunc>::set_cells_to_single_block(
+ assert(start_row_in_block < start_row && end_row < end_row_in_block);
+
+ // Insert two new blocks below the current one.
+- m_blocks.insert(m_blocks.begin()+block_index+1, 2, NULL);
++ m_blocks.insert(m_blocks.begin()+block_index+1, 2u, NULL);
+
+ // first new block is for the data array being inserted.
+ size_type new_size = end_row - start_row + 1;
+@@ -1985,7 +1985,7 @@ void multi_type_vector<_CellBlockFunc>::set_empty_in_single_block(
+
+ // First, insert two new blocks at position past the current block.
+ size_type lower_block_size = end_row_in_block - end_row;
+- m_blocks.insert(m_blocks.begin()+block_index+1, 2, NULL);
++ m_blocks.insert(m_blocks.begin()+block_index+1, 2u, NULL);
+ m_blocks[block_index+1] = new block(empty_block_size); // empty block.
+ m_blocks[block_index+2] = new block(lower_block_size);
+
+--
+1.7.11.2
+
diff --git a/dev-util/mdds/mdds-0.6.0-r1.ebuild b/dev-util/mdds/mdds-0.6.0-r2.ebuild
index fe03b417da8b..767b8ff8be71 100644
--- a/dev-util/mdds/mdds-0.6.0-r1.ebuild
+++ b/dev-util/mdds/mdds-0.6.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mdds/mdds-0.6.0-r1.ebuild,v 1.1 2012/08/01 09:16:35 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mdds/mdds-0.6.0-r2.ebuild,v 1.1 2012/08/02 09:05:34 scarabeus Exp $
EAPI=4
@@ -23,7 +23,8 @@ S=${WORKDIR}/${P/-/_}
PATCHES=(
"${FILESDIR}/${PV}-fix-boost-1.50-linking.patch"
"${FILESDIR}/${PV}-fix-missing-includes.patch"
-
+ "${FILESDIR}/${PV}-multi-vector-build.patch"
+ "${FILESDIR}/${PV}-right-overload-of-vector.patch"
)
src_configure() {