summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-09-01 22:09:39 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-09-01 22:09:39 +0000
commit82eb16bff141eb0c72939a074298896c7e50cd36 (patch)
treeef92ead8b004ecff1f72c2d5236093db8c535661 /dev-util/meld
parentVersion bump (diff)
downloadgentoo-2-82eb16bff141eb0c72939a074298896c7e50cd36.tar.gz
gentoo-2-82eb16bff141eb0c72939a074298896c7e50cd36.tar.bz2
gentoo-2-82eb16bff141eb0c72939a074298896c7e50cd36.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-util/meld')
-rw-r--r--dev-util/meld/ChangeLog7
-rw-r--r--dev-util/meld/meld-1.7.5.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-util/meld/ChangeLog b/dev-util/meld/ChangeLog
index 07b59534c016..d0b7966804f8 100644
--- a/dev-util/meld/ChangeLog
+++ b/dev-util/meld/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/meld
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.168 2013/07/28 19:46:50 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.169 2013/09/01 22:09:39 eva Exp $
+
+*meld-1.7.5 (01 Sep 2013)
+
+ 01 Sep 2013; Gilles Dartiguelongue <eva@gentoo.org> +meld-1.7.5.ebuild:
+ Version bump.
*meld-1.7.4 (28 Jul 2013)
diff --git a/dev-util/meld/meld-1.7.5.ebuild b/dev-util/meld/meld-1.7.5.ebuild
new file mode 100644
index 000000000000..b3d9e7c767eb
--- /dev/null
+++ b/dev-util/meld/meld-1.7.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/meld-1.7.5.ebuild,v 1.1 2013/09/01 22:09:39 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit eutils python-single-r1 gnome2
+
+DESCRIPTION="A graphical diff and merge tool"
+HOMEPAGE="http://meldmerge.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+highlight gnome"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# FIXME: switch gconf-python to python-r1
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.14:2[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.8:2[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ highlight? ( >=dev-python/pygtksourceview-2.10[${PYTHON_USEDEP}] )
+ gnome? ( >=dev-python/gconf-python-2.22:2 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ app-text/scrollkeeper
+"
+
+src_prepare() {
+ # fix the prefix so its not in */local/*
+ sed -e "s:/usr/local:${EPREFIX}/usr:" \
+ -e "s:\$(prefix)/lib:\$(prefix)/$(get_libdir):" \
+ -i INSTALL || die "sed 1 failed"
+
+ # don't install anything to /usr/share/doc/meld
+ sed -e "s:\$(docdir)/meld:\$(docdir)/${PF}:" \
+ -i INSTALL || die "sed 2 failed"
+
+ # don't run scrollkeeper (with the wrong path),
+ # leave that to gnome2.eclass #145833
+ sed -e '/scrollkeeper-update/s/\t/&#/' \
+ -i help/*/Makefile || die "sed 4 failed"
+
+ strip-linguas -i "${S}/po"
+ local mylinguas=""
+ for x in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${x}.po"
+ done
+
+ if [ -n "${mylinguas}" ]; then
+ sed -e "s/PO:=.*/PO:=${mylinguas}/" \
+ -i po/Makefile || die "sed 6 failed"
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ :
+}
+
+src_install() {
+ gnome2_src_install
+ python_fix_shebang "${ED}"/usr/bin
+ doman meld.1
+}