summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-22 18:17:21 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-22 18:17:21 +0000
commitd58edb6eb173d1ea65bac8e1eeb73274d8a7e764 (patch)
treeb869bd80c0729a4ad03f7f08a208897b358f08e7 /dev-util/meld
parentRaise dep on dev-libs/qjson, fixes bug #466804. (diff)
downloadgentoo-2-d58edb6eb173d1ea65bac8e1eeb73274d8a7e764.tar.gz
gentoo-2-d58edb6eb173d1ea65bac8e1eeb73274d8a7e764.tar.bz2
gentoo-2-d58edb6eb173d1ea65bac8e1eeb73274d8a7e764.zip
Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-util/meld')
-rw-r--r--dev-util/meld/ChangeLog7
-rw-r--r--dev-util/meld/meld-1.7.2.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/dev-util/meld/ChangeLog b/dev-util/meld/ChangeLog
index a1bde6210e61..e6421aaa7818 100644
--- a/dev-util/meld/ChangeLog
+++ b/dev-util/meld/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/meld
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.165 2013/04/01 18:24:28 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.166 2013/04/22 18:17:21 pacho Exp $
+
+*meld-1.7.2 (22 Apr 2013)
+
+ 22 Apr 2013; Pacho Ramos <pacho@gentoo.org> +meld-1.7.2.ebuild:
+ Version bump
01 Apr 2013; Agostino Sarubbo <ago@gentoo.org> meld-1.7.0.ebuild:
Stable for sparc, wrt bug #458984
diff --git a/dev-util/meld/meld-1.7.2.ebuild b/dev-util/meld/meld-1.7.2.ebuild
new file mode 100644
index 000000000000..1b44bc4fe13f
--- /dev/null
+++ b/dev-util/meld/meld-1.7.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/meld-1.7.2.ebuild,v 1.1 2013/04/22 18:17:21 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit eutils python-single-r1 gnome2 multilib
+
+DESCRIPTION="A graphical diff and merge tool"
+HOMEPAGE="http://meldmerge.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+highlight gnome"
+
+# FIXME: switch pygtksourceview and gconf-python to python-r1
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.14:2[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.8:2[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ highlight? ( >=dev-python/pygtksourceview-2.10[${PYTHON_USEDEP}] )
+ gnome? ( >=dev-python/gconf-python-2.22:2 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ app-text/scrollkeeper
+"
+
+src_prepare() {
+ # fix the prefix so its not in */local/*
+ sed -e "s:/usr/local:${EPREFIX}/usr:" \
+ -e "s:\$(prefix)/lib:\$(prefix)/$(get_libdir):" \
+ -i INSTALL || die "sed 1 failed"
+
+ # don't install anything to /usr/share/doc/meld
+ sed -e "s:\$(docdir)/meld:\$(docdir)/${PF}:" \
+ -i INSTALL || die "sed 2 failed"
+
+ # don't run scrollkeeper (with the wrong path),
+ # leave that to gnome2.eclass #145833
+ sed -e '/scrollkeeper-update/s/\t/&#/' \
+ -i help/*/Makefile || die "sed 4 failed"
+
+ # don't run update-*-database, leave that to eclass
+ sed -e '/update-.*-database/d' \
+ -i Makefile || die "sed 5 failed"
+
+ strip-linguas -i "${S}/po"
+ local mylinguas=""
+ for x in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${x}.po"
+ done
+
+ if [ -n "${mylinguas}" ]; then
+ sed -e "s/PO:=.*/PO:=${mylinguas}/" \
+ -i po/Makefile || die "sed 6 failed"
+ fi
+
+ # Fix .desktop entry, upstream bug #698600
+ sed -e 's/\(MimeType.*\)/\1;/' \
+ -i data/meld.desktop.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ :
+}
+
+src_install() {
+ DOCS="NEWS"
+ gnome2_src_install
+ python_fix_shebang "${ED}"/usr/bin
+ doman meld.1
+}