summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-09-02 14:05:05 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-09-02 14:05:05 +0000
commitd30982cb0bbe021d95f98d73467976d0ad53ee13 (patch)
tree5d350729232d99471cc13e93137503a4887734d9 /dev-util/mono-tools/files
parentStable on amd64, bug #283062 (diff)
downloadgentoo-2-d30982cb0bbe021d95f98d73467976d0ad53ee13.tar.gz
gentoo-2-d30982cb0bbe021d95f98d73467976d0ad53ee13.tar.bz2
gentoo-2-d30982cb0bbe021d95f98d73467976d0ad53ee13.zip
Fix html-renderer-fixes patch to make Mono.Webbrowser engine optional. Xulrunner use-flag now pulls in gluezilla for Mono.Webbrowser. Drop gecko-sharp usage, since it's broken. Update 9999 ebuilds with same fixes.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/mono-tools/files')
-rw-r--r--dev-util/mono-tools/files/mono-tools-2.4-html-renderer-fixes.patch117
1 files changed, 117 insertions, 0 deletions
diff --git a/dev-util/mono-tools/files/mono-tools-2.4-html-renderer-fixes.patch b/dev-util/mono-tools/files/mono-tools-2.4-html-renderer-fixes.patch
new file mode 100644
index 000000000000..cb420dccc687
--- /dev/null
+++ b/dev-util/mono-tools/files/mono-tools-2.4-html-renderer-fixes.patch
@@ -0,0 +1,117 @@
+diff -NrU5 mono-tools-2.4.2.orig/configure.in mono-tools-2.4.2/configure.in
+--- mono-tools-2.4.2.orig/configure.in 2009-09-02 13:49:47.000000000 +0200
++++ mono-tools-2.4.2/configure.in 2009-09-02 14:14:04.000000000 +0200
+@@ -43,54 +43,84 @@
+
+ PKG_CHECK_MODULES(GTK_SHARP, gtk-sharp-2.0 glade-sharp-2.0 gnome-sharp-2.0 gconf-sharp-2.0)
+ #PKG_CHECK_MODULES(GTK_SHARP, gtk-sharp glade-sharp gconf-sharp)
+ AC_SUBST(GTK_SHARP_LIBS)
+
+-PKG_CHECK_MODULES(GTKHTML_SHARP, gtkhtml-sharp-3.14, enable_gtkhtml=yes, enable_gtkhtml=no)
+-if test "x$enable_gtkhtml" = "xyes"; then
+-CSHARP_FLAGS="-d:GTKHTML_SHARP_3_14"
+-else
+-PKG_CHECK_MODULES(GTKHTML_SHARP, gtkhtml-sharp-2.0, enable_gtkhtml=yes, enable_gtkhtml=no)
+-CSHARP_FLAGS=
++AC_ARG_ENABLE(gtkhtml,
++ AC_HELP_STRING([--enable-gtkhtml], [Use GTKHTML Browser]),,
++ enable_gtkhtml=yes)
++
++if test "x$enable_gtkhtml" = "xyes" ; then
++ PKG_CHECK_MODULES([GTKHTML_SHARP],
++ [gtkhtml-sharp-3.14],
++ [CSHARP_FLAGS="-d:GTKHTML_SHARP_3_14"],
++ [
++ PKG_CHECK_MODULES([GTKHTML_SHARP],
++ [gtkhtml-sharp-2.0],
++ [CSHARP_FLAGS=""],
++ [])
++ ]
++ )
++ AC_SUBST(GTKHTML_SHARP_LIBS)
++ AC_SUBST(CSHARP_FLAGS)
+ fi
+-AC_SUBST(GTKHTML_SHARP_LIBS)
+-AC_SUBST(CSHARP_FLAGS)
++
+ AM_CONDITIONAL(ENABLE_GTKHTML, test "x$enable_gtkhtml" = "xyes")
+
+-PKG_CHECK_MODULES(GECKO_SHARP, gecko-sharp-2.0, enable_gecko=yes, enable_gecko=no)
+-AC_SUBST(GECKO_SHARP_LIBS)
++AC_ARG_ENABLE(gecko,
++ AC_HELP_STRING([--enable-gecko], [Use Gecko / Xulrunner-1.8 browser libs]),,
++ enable_gecko=yes)
++
++if test "x$enable_gecko" = "xyes" ; then
++ PKG_CHECK_MODULES(GECKO_SHARP, gecko-sharp-2.0)
++
++ AC_SUBST(GECKO_SHARP_LIBS)
++
++ # get the mozilla home directory
++ MOZILLA_HOME="`$PKG_CONFIG --variable=libdir mozilla-gtkmozembed`"
++ AC_SUBST(MOZILLA_HOME)
++fi
++
+ AM_CONDITIONAL(ENABLE_GECKO, test "x$enable_gecko" = "xyes")
+
+-if test "x$enable_gecko" = "xyes"; then
+- # get the mozilla home directory
+- MOZILLA_HOME="`$PKG_CONFIG --variable=libdir mozilla-gtkmozembed`"
+- AC_SUBST(MOZILLA_HOME)
++AC_ARG_ENABLE(webkit,
++ AC_HELP_STRING([--enable-webkit], [Use Webkit browser]),,
++ enable_webkit=yes)
++
++if test "x$enable_webkit" = "xyes" ; then
++ PKG_CHECK_MODULES(WEBKIT_SHARP, webkit-sharp-1.0)
++ AC_SUBST(WEBKIT_SHARP_LIBS)
+ fi
+
+-PKG_CHECK_MODULES(WEBKIT_SHARP, webkit-sharp-1.0, enable_webkit=yes, enable_webkit=no)
+-AC_SUBST(WEBKIT_SHARP_LIBS)
+ AM_CONDITIONAL(ENABLE_WEBKIT, test "x$enable_webkit" = "xyes")
+
+ # PKG_CHECK_MODULES(MONOWEBBROWSER, mono-webbrowser, enable_monowebbrowser=yes, enable_monowebbrowser=no)
+ # AC_SUBST(MONOWEBBROWSER_LIBS)
+
+-AC_MSG_CHECKING([for Mono.WebBrowser])
+-if test "x$GACUTIL" = "xno"
+-then
+- AC_MSG_RESULT([no])
+- if test "x$enable_monowebbrowser" = "x" ; then enable_monowebbrowser=no ; fi
+-else
+- if $GACUTIL -l Mono.WebBrowser | grep -q "Mono.WebBrowser"
++AC_ARG_ENABLE(monowebbrowser,
++ AC_HELP_STRING([--enable-monowebbrowser], [Use Mono.Webbrowser]),,
++ enable_monowebbrowser=yes)
++
++if test "x$enable_monowebbrowser" = "xyes" ; then
++ AC_MSG_CHECKING([for Mono.WebBrowser])
++ if test "x$GACUTIL" = "xno"
+ then
+- AC_MSG_RESULT([yes])
+- enable_monowebbrowser=yes
++ AC_MSG_RESULT([no])
++ if test "x$enable_monowebbrowser" = "x" ; then enable_monowebbrowser=no ; fi
+ else
+- AC_MSG_RESULT([no])
+- enable_monowebbrowser=no
+- fi
++ if $GACUTIL -l Mono.WebBrowser | grep -q "Mono.WebBrowser"
++ then
++ AC_MSG_RESULT([yes])
++ enable_monowebbrowser=yes
++ MONOWEBBROWSER_LIBS=-r:Mono.WebBrowser
++ else
++ AC_MSG_RESULT([no])
++ enable_monowebbrowser=no
++ fi
++ fi
+ fi
+-MONOWEBBROWSER_LIBS=-r:Mono.WebBrowser
++
+ AM_CONDITIONAL(ENABLE_MONOWEBBROWSER, test "x$enable_monowebbrowser" = "xyes")
+
+ if test "x$enable_gtkhtml$enable_gecko$enable_monowebbrowser$enable_webkit" = "xnononono" ; then
+ AC_MSG_ERROR([no HTML display found. You need either gtkhtml, gecko, WebKit or Mono.WebBrowser])
+ fi