summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2004-06-03 12:44:32 +0000
committerPeter Johanson <latexer@gentoo.org>2004-06-03 12:44:32 +0000
commit704362457c470adfe97a4906fe0aed15166758fc (patch)
tree2a28244bd25b46f4a95e1c0010645cdf2e120bf0 /dev-util/monodoc/monodoc-0.16.ebuild
parentversion bump, add spell use flag, mark stable because of security issues,bug ... (diff)
downloadgentoo-2-704362457c470adfe97a4906fe0aed15166758fc.tar.gz
gentoo-2-704362457c470adfe97a4906fe0aed15166758fc.tar.bz2
gentoo-2-704362457c470adfe97a4906fe0aed15166758fc.zip
Move check for previous versions of monodoc into pkg_setup, see bug #52818.
Diffstat (limited to 'dev-util/monodoc/monodoc-0.16.ebuild')
-rw-r--r--dev-util/monodoc/monodoc-0.16.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/dev-util/monodoc/monodoc-0.16.ebuild b/dev-util/monodoc/monodoc-0.16.ebuild
index 4b5d376b672d..b634ad7f0e68 100644
--- a/dev-util/monodoc/monodoc-0.16.ebuild
+++ b/dev-util/monodoc/monodoc-0.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monodoc/monodoc-0.16.ebuild,v 1.2 2004/06/03 02:01:55 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monodoc/monodoc-0.16.ebuild,v 1.3 2004/06/03 12:44:32 latexer Exp $
inherit mono
@@ -14,13 +14,23 @@ IUSE=""
DEPEND=">=dev-dotnet/mono-0.95
>=x11-libs/gtk-sharp-0.93"
+pkg_setup() {
+ # This is needed as monodoc emerges just hang if previous versions are around
+ if has_version "<dev-util/monodoc-${PV}"
+ then
+ echo
+ eerror "Currently, monodoc fails if attempting to upgrade from a"
+ eerror "previous installation. Please unmerge monodoc, and then"
+ eerror "re-emerge it. See bug #52818 for details."
+ die "Previous monodoc installation detected."
+ fi
+}
+
src_compile() {
econf || die
MAKEOPTS="-j1"
make || {
echo
- eerror "If you already have monodoc installed and this upgrade failed,"
- eerror "unmerge and then re-emerge monodoc."
ewarn "If for some reason this fails, try adding 'gtkhtml' to your USE variables, re-emerge gtk-sharp, then emerge monodoc"
die "make failed"
}