summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-23 07:58:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-23 07:58:16 +0000
commitc96132c92d83a993f63fdb2d993eb35c212ab385 (patch)
tree95606d8f60337b6c207402291098707acd8a57f4 /dev-util/monotone
parentRemove FEATURES checking wrt #278745. (diff)
downloadgentoo-2-c96132c92d83a993f63fdb2d993eb35c212ab385.tar.gz
gentoo-2-c96132c92d83a993f63fdb2d993eb35c212ab385.tar.bz2
gentoo-2-c96132c92d83a993f63fdb2d993eb35c212ab385.zip
old
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/monotone')
-rw-r--r--dev-util/monotone/files/30monotone-gentoo.el5
-rwxr-xr-xdev-util/monotone/files/monotone-0.33.initd80
-rw-r--r--dev-util/monotone/files/monotone-0.35-numeric-vocab.patch10
-rw-r--r--dev-util/monotone/monotone-0.35.ebuild114
-rw-r--r--dev-util/monotone/monotone-0.39.ebuild125
-rw-r--r--dev-util/monotone/monotone-0.40.ebuild12
-rw-r--r--dev-util/monotone/monotone-0.43.ebuild129
7 files changed, 4 insertions, 471 deletions
diff --git a/dev-util/monotone/files/30monotone-gentoo.el b/dev-util/monotone/files/30monotone-gentoo.el
deleted file mode 100644
index bd5165e40861..000000000000
--- a/dev-util/monotone/files/30monotone-gentoo.el
+++ /dev/null
@@ -1,5 +0,0 @@
-;;; monotone site-lisp configuration
-
-(add-to-list 'load-path "@SITELISP@")
-(require 'monotone)
-(require 'monotone-nav)
diff --git a/dev-util/monotone/files/monotone-0.33.initd b/dev-util/monotone/files/monotone-0.33.initd
deleted file mode 100755
index 6b8d320114f6..000000000000
--- a/dev-util/monotone/files/monotone-0.33.initd
+++ /dev/null
@@ -1,80 +0,0 @@
-#!/sbin/runscript
-# Copyright 2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/files/monotone-0.33.initd,v 1.1 2007/03/13 20:58:40 dragonheart Exp $
-
-opts="import"
-
-depend() {
- need net
-}
-
-# Substitute common default values
-MTN_KEY=${MTN_KEY:-monotone@`hostname --fqdn`}
-MTN_CONFDIR=${MTN_CONFDIR:-/etc/monotone}
-MTN_COMMON="--norc --confdir=${MTN_CONFDIR} \
- --keydir=${MTN_KEYDIR:-/var/lib/monotone/keys} \
- --db=${MTN_DB:-/var/lib/monotone/default.mtn} \
- --rcfile=${MTN_CONFDIR}/hooks.lua --log=/var/log/monotone/monotone.log"
- #--dump=$ERRORLOG
-MTN_PIDFILE="/var/run/monotone/monotone.pid"
-
-dbexists() {
- # Create the database if it doesn't exist
- if [ ! -e ${MTN_DB:-/var/lib/monotone/default.mtn} ]; then
- ebegin "Creating monotone database"
- start-stop-daemon --start \
- --chuid ${MTN_USER:-monotone}:${MTN_GROUP:-monotone} \
- --exec /usr/bin/mtn -- ${MTN_COMMON} db init
- eend $?
- fi
- if [ ! -e ${MTN_KEYDIR:-/var/lib/monotone/keys}/${MTN_KEY} ]; then
- ebegin "Creating monotone server keypair"
- export MTN_PWD=${RANDOM}
- yes "${MTN_PWD}" | \
- start-stop-daemon --start \
- --chuid ${MTN_USER:-monotone}:${MTN_GROUP:-monotone} \
- --exec /usr/bin/mtn -- ${MTN_COMMON} genkey ${MTN_KEY}
-
- eend $?
- # Update the password lua hook
- cat > ${MTN_CONFDIR}/passphrase.lua <<EOF
--- This file is automaticaly generated by the init scripts.
--- If you want to add custom hooks, edit ${MTN_CONFDIR}/hooks.lua
--- If you want to change the settings, please edit /etc/conf.d/monotone
-
-function get_passphrase(identity)
- if (identity == "${MTN_KEY}") then
- return "${MTN_PWD}"
- end
- return false
-end
-EOF
- fi
-}
-
-start() {
- dbexists
-
- ebegin "Starting monotone server"
- start-stop-daemon --start --background \
- --chuid ${MTN_USER:-monotone}:${MTN_GROUP:-monotone} \
- --exec /usr/bin/mtn -- ${MTN_COMMON} --pid-file=${MTN_PIDFILE} \
- --key=${MTN_KEY} --bind=${MTN_ADDRESS:-0.0.0.0} serve
- eend $?
-}
-
-stop() {
- ebegin "Stopping monotone server"
- start-stop-daemon --stop --quiet --pidfile ${MTN_PIDFILE}
- eend $?
-}
-
-import() {
- dbexists
-
- # Read packets into the database
- einfo "Importing packets to monotone database"
- cat | /usr/bin/mtn ${MTN_COMMON} read
- eend $?
-}
diff --git a/dev-util/monotone/files/monotone-0.35-numeric-vocab.patch b/dev-util/monotone/files/monotone-0.35-numeric-vocab.patch
deleted file mode 100644
index fc91e0c66f5e..000000000000
--- a/dev-util/monotone/files/monotone-0.35-numeric-vocab.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- monotone-0.35.orig/numeric_vocab.hh 2007-06-20 14:17:12.689221923 -0300
-+++ monotone-0.35/numeric_vocab.hh 2007-06-20 14:15:41.297802806 -0300
-@@ -12,6 +12,7 @@
-
- #include <cstddef>
- #include <limits>
-+#include <climits>
-
- #include "mt-stdint.h"
- #include <boost/static_assert.hpp>
diff --git a/dev-util/monotone/monotone-0.35.ebuild b/dev-util/monotone/monotone-0.35.ebuild
deleted file mode 100644
index 0db6e7ce7cf2..000000000000
--- a/dev-util/monotone/monotone-0.35.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.35.ebuild,v 1.8 2008/05/03 01:01:11 dragonheart Exp $
-
-inherit elisp-common flag-o-matic bash-completion eutils
-
-DESCRIPTION="Monotone Distributed Version Control System"
-HOMEPAGE="http://monotone.ca"
-SRC_URI="http://monotone.ca/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="amd64 ~ia64 ppc x86"
-
-IUSE="doc emacs ipv6 nls"
-
-RDEPEND="sys-libs/zlib
- emacs? ( virtual/emacs )"
-
-DEPEND="${RDEPEND}
- >=dev-libs/boost-1.33.1
- nls? ( >=sys-devel/gettext-0.11.5 )
- doc? ( sys-apps/texinfo )"
-
-pkg_setup() {
- enewgroup monotone
- enewuser monotone -1 -1 /var/lib/monotone monotone
- if [[ "$(gcc-version)" == "3.3" ]]; then
- die 'requires >=gcc-3.4'
- fi
-}
-
-src_compile() {
- local myconf="$(use_enable nls) \
- $(use_enable ipv6)"
- #lvcargnini modifications
- epatch "${FILESDIR}"/${P}-numeric-vocab.patch
-
- # more aggressive optimizations cause trouble with the crypto library
- strip-flags
- append-flags $(test-flags -fno-stack-protector-all -fno-stack-protector)
- append-flags -fno-strict-aliasing -fno-omit-frame-pointer
-
- econf ${myconf} || die "configure failed"
- emake || die "Compilation failed"
-
- if use doc; then
- make html || die 'html compilation failed'
- fi
-
- use emacs && elisp-compile contrib/*.el
-}
-
-src_test() {
- make check || die "self test failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- mv "${D}"/usr/share/doc/"${PN}" "${D}"/usr/share/doc/"${PF}"
-
- dobashcompletion contrib/monotone.bash_completion
-
- if use doc; then
- dohtml -r html/*
- dohtml -r figures
- fi
-
- if use emacs; then
- elisp-install ${PN} contrib/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/30monotone-gentoo.el
- fi
-
- dodoc AUTHORS ChangeLog NEWS README* UPGRADE
- docinto contrib
- dodoc contrib/*
- newconfd "${FILESDIR}"/monotone.confd monotone
- newinitd "${FILESDIR}"/${PN}-0.33.initd monotone
-
- insinto /etc/monotone ;
- newins "${FILESDIR}"/hooks.lua hooks.lua
- newins "${FILESDIR}"/read-permissions read-permissions
- newins "${FILESDIR}"/write-permissions write-permissions
-
- keepdir /var/lib/monotone/keys/ /var/log/monotone /var/run/monotone
- fowners monotone:monotone /var/lib/monotone /var/lib/monotone/keys/ \
- /var/log/monotone /var/run/monotone
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- bash-completion_pkg_postinst
-
- elog
- elog "For details and instructions to upgrade from previous versions,"
- elog "please read /usr/share/doc/${PF}/UPGRADE.gz"
- elog
- elog " 1. edit /etc/conf.d/monotone"
- elog " 2. import the first keys to enable access with"
- elog " env HOME=\${homedir} mtn pubkey me@example.net | /etc/init.d/monotone import"
- elog " Thereafter, those with write permission can add other keys via"
- elog " netsync with 'monotone push --key-to-push=IDENT' and then IDENT"
- elog " can be used in the read-permission and write-permission files."
- elog " 3. adjust permisions in /etc/monotone/read-permissions"
- elog " and /etc/monotone/write-permissions"
- elog " 4. start the daemon: /etc/init.d/monotone start"
- elog " 5. make persistent: rc-update add monotone default"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/monotone/monotone-0.39.ebuild b/dev-util/monotone/monotone-0.39.ebuild
deleted file mode 100644
index 66a3982c7048..000000000000
--- a/dev-util/monotone/monotone-0.39.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.39.ebuild,v 1.3 2008/08/30 01:18:26 dragonheart Exp $
-
-inherit elisp-common flag-o-matic bash-completion eutils
-
-DESCRIPTION="Monotone Distributed Version Control System"
-HOMEPAGE="http://monotone.ca"
-SRC_URI="http://monotone.ca/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-
-IUSE="doc emacs ipv6 nls"
-
-RDEPEND="
- sys-libs/zlib
- emacs? ( virtual/emacs )
- >=dev-libs/libpcre-7.6"
-
-DEPEND="${RDEPEND}
- >=dev-libs/boost-1.33.1
- nls? ( >=sys-devel/gettext-0.11.5 )
- doc? ( sys-apps/texinfo )"
-
-pkg_setup() {
- enewgroup monotone
- enewuser monotone -1 -1 /var/lib/monotone monotone
- if [[ "$(gcc-version)" == "3.3" ]]; then
- die 'requires >=gcc-3.4'
- fi
- # https://bugs.gentoo.org/show_bug.cgi?id=202371#c2
- if ! has userpriv ${FEATURES} && has test ${FEATURES}; then
- ewarn "No test will be performed due to lack of FEATURES=userpriv"
- fi
-}
-
-src_compile() {
- # more aggressive optimizations cause trouble with the crypto library
- strip-flags
- append-flags $(test-flags -fno-stack-protector-all -fno-stack-protector)
- append-flags -fno-strict-aliasing -fno-omit-frame-pointer
-
- econf $(use_enable nls) \
- $(use_enable ipv6) \
- --with-system-pcre || die "configure failed"
- emake || die "Compilation failed"
-
- if use doc; then
- emake html || die 'html compilation failed'
- fi
-
- if use emacs; then
- cd contrib
- elisp-compile *.el || die "elisp-compile failed"
- fi
-}
-
-src_test() {
- if has userpriv ${FEATURES}; then
- emake check || die "self test failed"
- else
- ewarn 'not tested - requires FEATURES=userpriv'
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- mv "${D}"/usr/share/doc/"${PN}" "${D}"/usr/share/doc/"${PF}"
-
- dobashcompletion contrib/monotone.bash_completion
-
- if use doc; then
- dohtml -r html/*
- dohtml -r figures
- fi
-
- if use emacs; then
- elisp-install ${PN} contrib/*.{el,elc} || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el \
- || die "elisp-site-file-install failed"
- fi
-
- dodoc AUTHORS ChangeLog NEWS README* UPGRADE
- docinto contrib
- dodoc contrib/*
- newconfd "${FILESDIR}"/monotone.confd monotone
- newinitd "${FILESDIR}"/${PN}-0.36.initd monotone
-
- insinto /etc/monotone ;
- newins "${FILESDIR}"/hooks.lua hooks.lua
- newins "${FILESDIR}"/read-permissions read-permissions
- newins "${FILESDIR}"/write-permissions write-permissions
-
- keepdir /var/lib/monotone/keys/ /var/log/monotone /var/run/monotone
- fowners monotone:monotone /var/lib/monotone /var/lib/monotone/keys/ \
- /var/log/monotone /var/run/monotone
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- bash-completion_pkg_postinst
-
- elog
- elog "For details and instructions to upgrade from previous versions,"
- elog "please read /usr/share/doc/${PF}/UPGRADE.bz2"
- elog
- elog " 1. edit /etc/conf.d/monotone"
- elog " 2. import the first keys to enable access with"
- elog " env HOME=\${homedir} mtn pubkey me@example.net | /etc/init.d/monotone import"
- elog " Thereafter, those with write permission can add other keys via"
- elog " netsync with 'monotone push --key-to-push=IDENT' and then IDENT"
- elog " can be used in the read-permission and write-permission files."
- elog " 3. adjust permisions in /etc/monotone/read-permissions"
- elog " and /etc/monotone/write-permissions"
- elog " 4. start the daemon: /etc/init.d/monotone start"
- elog " 5. make persistent: rc-update add monotone default"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/monotone/monotone-0.40.ebuild b/dev-util/monotone/monotone-0.40.ebuild
index 5da9bef63bb9..d0226a241696 100644
--- a/dev-util/monotone/monotone-0.40.ebuild
+++ b/dev-util/monotone/monotone-0.40.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.40.ebuild,v 1.4 2008/11/08 12:39:10 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.40.ebuild,v 1.5 2009/07/23 07:58:16 ssuominen Exp $
inherit elisp-common flag-o-matic bash-completion eutils
@@ -30,10 +30,6 @@ pkg_setup() {
if [[ "$(gcc-version)" == "3.3" ]]; then
die 'requires >=gcc-3.4'
fi
- # https://bugs.gentoo.org/show_bug.cgi?id=202371#c2
- if ! has userpriv ${FEATURES} && has test ${FEATURES}; then
- ewarn "No test will be performed due to lack of FEATURES=userpriv"
- fi
}
src_compile() {
@@ -58,8 +54,8 @@ src_compile() {
}
src_test() {
- if has userpriv ${FEATURES}; then
- emake check || die "self test failed"
+ if [ $UID != 0 ]; then
+ emake check || die "emake check failed"
else
ewarn 'not tested - requires FEATURES=userpriv'
fi
diff --git a/dev-util/monotone/monotone-0.43.ebuild b/dev-util/monotone/monotone-0.43.ebuild
deleted file mode 100644
index b129cba36fc8..000000000000
--- a/dev-util/monotone/monotone-0.43.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.43.ebuild,v 1.2 2009/04/29 11:31:56 armin76 Exp $
-
-inherit elisp-common flag-o-matic bash-completion eutils
-
-DESCRIPTION="Monotone Distributed Version Control System"
-HOMEPAGE="http://monotone.ca"
-SRC_URI="http://monotone.ca/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-
-IUSE="doc emacs ipv6 nls"
-
-RDEPEND="
- sys-libs/zlib
- emacs? ( virtual/emacs )
- >=dev-libs/libpcre-7.6
- >=dev-libs/botan-1.8.0
- >=dev-db/sqlite-3.3.8
- >=dev-lang/lua-5.1
- net-dns/libidn"
-
-DEPEND="${RDEPEND}
- >=dev-libs/boost-1.33.1
- nls? ( >=sys-devel/gettext-0.11.5 )
- doc? ( sys-apps/texinfo )"
-
-pkg_setup() {
- enewgroup monotone
- enewuser monotone -1 -1 /var/lib/monotone monotone
- if [[ "$(gcc-version)" == "3.3" ]]; then
- die 'requires >=gcc-3.4'
- fi
- # https://bugs.gentoo.org/show_bug.cgi?id=202371#c2
- if ! has userpriv ${FEATURES} && has test ${FEATURES}; then
- ewarn "No test will be performed due to lack of FEATURES=userpriv"
- fi
-}
-
-src_compile() {
- # more aggressive optimizations cause trouble with the crypto library
- strip-flags
- append-flags $(test-flags -fno-stack-protector-all -fno-stack-protector)
- append-flags -fno-strict-aliasing -fno-omit-frame-pointer
-
- econf $(use_enable nls) \
- $(use_enable ipv6) \
- --with-system-pcre || die "configure failed"
- emake || die "Compilation failed"
-
- if use doc; then
- emake html || die 'html compilation failed'
- fi
-
- if use emacs; then
- cd contrib
- elisp-compile *.el || die "elisp-compile failed"
- fi
-}
-
-src_test() {
- if has userpriv ${FEATURES}; then
- emake check || die "self test failed"
- else
- ewarn 'not tested - requires FEATURES=userpriv'
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- mv "${D}"/usr/share/doc/"${PN}" "${D}"/usr/share/doc/"${PF}"
-
- dobashcompletion contrib/monotone.bash_completion
-
- if use doc; then
- dohtml -r html/*
- dohtml -r figures
- fi
-
- if use emacs; then
- elisp-install ${PN} contrib/*.{el,elc} || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el \
- || die "elisp-site-file-install failed"
- fi
-
- dodoc AUTHORS ChangeLog NEWS README* UPGRADE
- docinto contrib
- dodoc contrib/*
- newconfd "${FILESDIR}"/monotone.confd monotone
- newinitd "${FILESDIR}"/${PN}-0.36.initd monotone
-
- insinto /etc/monotone ;
- newins "${FILESDIR}"/hooks.lua hooks.lua
- newins "${FILESDIR}"/read-permissions read-permissions
- newins "${FILESDIR}"/write-permissions write-permissions
-
- keepdir /var/lib/monotone/keys/ /var/log/monotone /var/run/monotone
- fowners monotone:monotone /var/lib/monotone /var/lib/monotone/keys/ \
- /var/log/monotone /var/run/monotone
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- bash-completion_pkg_postinst
-
- elog
- elog "For details and instructions to upgrade from previous versions,"
- elog "please read /usr/share/doc/${PF}/UPGRADE.bz2"
- elog
- elog " 1. edit /etc/conf.d/monotone"
- elog " 2. import the first keys to enable access with"
- elog " env HOME=\${homedir} mtn pubkey me@example.net | /etc/init.d/monotone import"
- elog " Thereafter, those with write permission can add other keys via"
- elog " netsync with 'monotone push --key-to-push=IDENT' and then IDENT"
- elog " can be used in the read-permission and write-permission files."
- elog " 3. adjust permisions in /etc/monotone/read-permissions"
- elog " and /etc/monotone/write-permissions"
- elog " 4. start the daemon: /etc/init.d/monotone start"
- elog " 5. make persistent: rc-update add monotone default"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}