summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-04-02 02:11:15 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-04-02 02:11:15 +0000
commitcb7d1ddd1efd49e6e20fa57d8a483495ea08e288 (patch)
treef84500ea6687ed64f8768961a3a97b4574d04bdc /dev-util/monotone
parentUnmask swfdec-0.6 and co (diff)
downloadgentoo-2-cb7d1ddd1efd49e6e20fa57d8a483495ea08e288.tar.gz
gentoo-2-cb7d1ddd1efd49e6e20fa57d8a483495ea08e288.tar.bz2
gentoo-2-cb7d1ddd1efd49e6e20fa57d8a483495ea08e288.zip
version bump as per bug #202371 - thanks to fixes from Rainer Keller and suggestions from Xake. Old version cleanout + a few QA fixes
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util/monotone')
-rw-r--r--dev-util/monotone/ChangeLog12
-rwxr-xr-xdev-util/monotone/files/monotone.initd80
-rw-r--r--dev-util/monotone/monotone-0.29.ebuild112
-rw-r--r--dev-util/monotone/monotone-0.32.ebuild112
-rw-r--r--dev-util/monotone/monotone-0.33.ebuild112
-rw-r--r--dev-util/monotone/monotone-0.35.ebuild6
-rw-r--r--dev-util/monotone/monotone-0.36-r1.ebuild6
-rw-r--r--dev-util/monotone/monotone-0.39.ebuild (renamed from dev-util/monotone/monotone-0.36.ebuild)31
8 files changed, 38 insertions, 433 deletions
diff --git a/dev-util/monotone/ChangeLog b/dev-util/monotone/ChangeLog
index c2b27a5a5398..95a793d2dc5f 100644
--- a/dev-util/monotone/ChangeLog
+++ b/dev-util/monotone/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/monotone
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.50 2007/10/26 20:30:28 ulm Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.51 2008/04/02 02:11:15 dragonheart Exp $
+
+*monotone-0.39 (02 Apr 2008)
+
+ 02 Apr 2008; Daniel Black <dragonheart@gentoo.org> -files/monotone.initd,
+ -monotone-0.29.ebuild, -monotone-0.32.ebuild, -monotone-0.33.ebuild,
+ -monotone-0.36.ebuild, +monotone-0.39.ebuild:
+ version bump as per bug #202371 - thanks to fixes from Rainer Keller and
+ suggestions from Xake. Old version cleanout
*monotone-0.36-r1 (26 Oct 2007)
diff --git a/dev-util/monotone/files/monotone.initd b/dev-util/monotone/files/monotone.initd
deleted file mode 100755
index f31ad1c74f01..000000000000
--- a/dev-util/monotone/files/monotone.initd
+++ /dev/null
@@ -1,80 +0,0 @@
-#!/sbin/runscript
-# Copyright 2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/files/monotone.initd,v 1.1 2006/09/04 13:33:52 dragonheart Exp $
-
-opts="import"
-
-depend() {
- need net
-}
-
-# Substitute common default values
-MTN_KEY=${MTN_KEY:-monotone@`hostname --fqdn`}
-MTN_CONFDIR=${MTN_CONFDIR:-/etc/monotone}
-MTN_COMMON="--norc --confdir=${MTN_CONFDIR} \
- --keydir=${MTN_KEYDIR:-/var/lib/monotone/keys} \
- --db=${MTN_DB:-/var/lib/monotone/default.mtn} \
- --rcfile=${MTN_CONFDIR}/hooks.lua --log=/var/log/monotone/monotone.log"
- #--dump=$ERRORLOG
-MTN_PIDFILE="/var/run/monotone/monotone.pid"
-
-dbexists() {
- # Create the database if it doesn't exist
- if [ ! -e ${MTN_DB:-/var/lib/monotone/default.mtn} ]; then
- ebegin "Creating monotone database"
- start-stop-daemon --start \
- --chuid ${MTN_USER:-monotone}:${MTN_GROUP:-monotone} \
- --exec /usr/bin/mtn -- ${MTN_COMMON} db init
- eend $?
- fi
- if [ ! -e ${MTN_KEYDIR:-/var/lib/monotone/keys}/${MTN_KEY} ]; then
- ebegin "Creating monotone server keypair"
- export MTN_PWD=${RANDOM}
- yes "${MTN_PWD}" | \
- start-stop-daemon --start \
- --chuid ${MTN_USER:-monotone}:${MTN_GROUP:-monotone} \
- --exec /usr/bin/mtn -- ${MTN_COMMON} genkey ${MTN_KEY}
-
- eend $?
- # Update the password lua hook
- cat > ${MTN_CONFDIR}/passphrase.lua <<EOF
--- This file is automaticaly generated by the init scripts.
--- If you want to add custom hooks, edit ${MTN_CONFDIR}/hooks.lua
--- If you want to change the settings, please edit /etc/conf.d/monotone
-
-function get_passphrase(identity)
- if (identity == "${MTN_KEY}") then
- return "${MTN_PWD}"
- end
- return false
-end
-EOF
- fi
-}
-
-start() {
- dbexists
-
- ebegin "Starting monotone server"
- start-stop-daemon --start --background \
- --chuid ${MTN_USER:-monotone}:${MTN_GROUP:-monotone} \
- --exec /usr/bin/mtn -- ${MTN_COMMON} --pid-file=${MTN_PIDFILE} \
- --key=${MTN_KEY} --bind=${MTN_ADDRESS:-0.0.0.0} serve "*"
- eend $?
-}
-
-stop() {
- ebegin "Stopping monotone server"
- start-stop-daemon --stop --quiet --pidfile ${MTN_PIDFILE}
- eend $?
-}
-
-import() {
- dbexists
-
- # Read packets into the database
- einfo "Importing packets to monotone database"
- cat | /usr/bin/mtn ${MTN_COMMON} read
- eend $?
-}
diff --git a/dev-util/monotone/monotone-0.29.ebuild b/dev-util/monotone/monotone-0.29.ebuild
deleted file mode 100644
index 6e963526fca1..000000000000
--- a/dev-util/monotone/monotone-0.29.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.29.ebuild,v 1.12 2007/07/12 01:05:42 mr_bones_ Exp $
-
-inherit elisp-common flag-o-matic bash-completion eutils
-
-DESCRIPTION="Monotone Distributed Version Control System"
-HOMEPAGE="http://www.monotone.ca"
-SRC_URI="http://www.monotone.ca/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="amd64 ~ia64 ppc x86"
-
-IUSE="doc emacs ipv6 nls"
-
-RDEPEND="=dev-libs/boost-1.33*
- sys-libs/zlib
- emacs? ( virtual/emacs )"
-
-DEPEND="${RDEPEND}
- nls? ( >=sys-devel/gettext-0.11.5 )
- doc? ( sys-apps/texinfo )"
-
-pkg_setup() {
- enewgroup monotone
- enewuser monotone -1 -1 /var/lib/monotone monotone
- if [[ "$(gcc-version)" == "3.3" ]]; then
- die 'requires >=gcc-3.4'
- fi
-}
-
-src_compile() {
- local myconf="$(use_enable nls) \
- $(use_enable ipv6)"
-
- # more aggressive optimizations cause trouble with the crypto library
- strip-flags
- append-flags $(test-flags -fno-stack-protector-all -fno-stack-protector)
- append-flags -fno-strict-aliasing -fno-omit-frame-pointer
-
- econf ${myconf} || die "configure failed"
- emake || die "Compilation failed"
-
- if use doc; then
- make html || die 'html compilation failed'
- fi
-
- use emacs && elisp-compile contrib/*.el
-}
-
-src_test() {
- make check || die "self test failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- mv "${D}"/usr/share/doc/"${PN}" "${D}"/usr/share/doc/"${PF}"
-
- dobashcompletion contrib/monotone.bash_completion
-
- if use doc; then
- dohtml -r html/*
- dohtml -r figures
- fi
-
- if use emacs; then
- elisp-install ${PN} contrib/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/30monotone-gentoo.el
- fi
-
- dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README* UPGRADE
- docinto contrib
- dodoc contrib/*
- newconfd "${FILESDIR}"/monotone.confd monotone
- newinitd "${FILESDIR}"/monotone.initd monotone
-
- insinto /etc/monotone ;
- newins "${FILESDIR}"/hooks.lua hooks.lua
- newins "${FILESDIR}"/read-permissions read-permissions
- newins "${FILESDIR}"/write-permissions write-permissions
-
- keepdir /var/lib/monotone/keys/ /var/log/monotone /var/run/monotone
- fowners monotone:monotone /var/lib/monotone /var/lib/monotone/keys/ \
- /var/log/monotone /var/run/monotone
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- bash-completion_pkg_postinst
-
- elog
- elog "For details and instructions to upgrade from previous versions,"
- elog "please read /usr/share/doc/${PF}/UPGRADE.gz"
- elog
- elog " 1. edit /etc/conf.d/monotone"
- elog " 2. import the first keys to enable access with"
- elog " env HOME=\${homedir} mtn pubkey me@example.net | /etc/init.d/monotone import"
- elog " Thereafter, those with write permission can add other keys via"
- elog " netsync with 'monotone push --key-to-push=IDENT' and then IDENT"
- elog " can be used in the read-permission and write-permission files."
- elog " 3. adjust permisions in /etc/monotone/read-permissions"
- elog " and /etc/monotone/write-permissions"
- elog " 4. start the daemon: /etc/init.d/monotone start"
- elog " 5. make persistent: rc-update add monotone default"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/monotone/monotone-0.32.ebuild b/dev-util/monotone/monotone-0.32.ebuild
deleted file mode 100644
index 1d8834000dc4..000000000000
--- a/dev-util/monotone/monotone-0.32.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.32.ebuild,v 1.7 2007/07/12 01:05:42 mr_bones_ Exp $
-
-inherit elisp-common flag-o-matic bash-completion eutils
-
-DESCRIPTION="Monotone Distributed Version Control System"
-HOMEPAGE="http://www.monotone.ca"
-SRC_URI="http://www.monotone.ca/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-
-IUSE="doc emacs ipv6 nls"
-
-RDEPEND=">=dev-libs/boost-1.33.1
- sys-libs/zlib
- emacs? ( virtual/emacs )"
-
-DEPEND="${RDEPEND}
- nls? ( >=sys-devel/gettext-0.11.5 )
- doc? ( sys-apps/texinfo )"
-
-pkg_setup() {
- enewgroup monotone
- enewuser monotone -1 -1 /var/lib/monotone monotone
- if [[ "$(gcc-version)" == "3.3" ]]; then
- die 'requires >=gcc-3.4'
- fi
-}
-
-src_compile() {
- local myconf="$(use_enable nls) \
- $(use_enable ipv6)"
-
- # more aggressive optimizations cause trouble with the crypto library
- strip-flags
- append-flags $(test-flags -fno-stack-protector-all -fno-stack-protector)
- append-flags -fno-strict-aliasing -fno-omit-frame-pointer
-
- econf ${myconf} || die "configure failed"
- emake || die "Compilation failed"
-
- if use doc; then
- make html || die 'html compilation failed'
- fi
-
- use emacs && elisp-compile contrib/*.el
-}
-
-src_test() {
- make check || die "self test failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- mv "${D}"/usr/share/doc/"${PN}" "${D}"/usr/share/doc/"${PF}"
-
- dobashcompletion contrib/monotone.bash_completion
-
- if use doc; then
- dohtml -r html/*
- dohtml -r figures
- fi
-
- if use emacs; then
- elisp-install ${PN} contrib/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/30monotone-gentoo.el
- fi
-
- dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README* UPGRADE
- docinto contrib
- dodoc contrib/*
- newconfd "${FILESDIR}"/monotone.confd monotone
- newinitd "${FILESDIR}"/monotone.initd monotone
-
- insinto /etc/monotone ;
- newins "${FILESDIR}"/hooks.lua hooks.lua
- newins "${FILESDIR}"/read-permissions read-permissions
- newins "${FILESDIR}"/write-permissions write-permissions
-
- keepdir /var/lib/monotone/keys/ /var/log/monotone /var/run/monotone
- fowners monotone:monotone /var/lib/monotone /var/lib/monotone/keys/ \
- /var/log/monotone /var/run/monotone
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- bash-completion_pkg_postinst
-
- elog
- elog "For details and instructions to upgrade from previous versions,"
- elog "please read /usr/share/doc/${PF}/UPGRADE.gz"
- elog
- elog " 1. edit /etc/conf.d/monotone"
- elog " 2. import the first keys to enable access with"
- elog " env HOME=\${homedir} mtn pubkey me@example.net | /etc/init.d/monotone import"
- elog " Thereafter, those with write permission can add other keys via"
- elog " netsync with 'monotone push --key-to-push=IDENT' and then IDENT"
- elog " can be used in the read-permission and write-permission files."
- elog " 3. adjust permisions in /etc/monotone/read-permissions"
- elog " and /etc/monotone/write-permissions"
- elog " 4. start the daemon: /etc/init.d/monotone start"
- elog " 5. make persistent: rc-update add monotone default"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/monotone/monotone-0.33.ebuild b/dev-util/monotone/monotone-0.33.ebuild
deleted file mode 100644
index 8fe58bbb43cf..000000000000
--- a/dev-util/monotone/monotone-0.33.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.33.ebuild,v 1.2 2007/07/12 01:05:42 mr_bones_ Exp $
-
-inherit elisp-common flag-o-matic bash-completion eutils
-
-DESCRIPTION="Monotone Distributed Version Control System"
-HOMEPAGE="http://monotone.ca"
-SRC_URI="http://monotone.ca/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="1"
-KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-
-IUSE="doc emacs ipv6 nls"
-
-RDEPEND=">=dev-libs/boost-1.33.1
- sys-libs/zlib
- emacs? ( virtual/emacs )"
-
-DEPEND="${RDEPEND}
- nls? ( >=sys-devel/gettext-0.11.5 )
- doc? ( sys-apps/texinfo )"
-
-pkg_setup() {
- enewgroup monotone
- enewuser monotone -1 -1 /var/lib/monotone monotone
- if [[ "$(gcc-version)" == "3.3" ]]; then
- die 'requires >=gcc-3.4'
- fi
-}
-
-src_compile() {
- local myconf="$(use_enable nls) \
- $(use_enable ipv6)"
-
- # more aggressive optimizations cause trouble with the crypto library
- strip-flags
- append-flags $(test-flags -fno-stack-protector-all -fno-stack-protector)
- append-flags -fno-strict-aliasing -fno-omit-frame-pointer
-
- econf ${myconf} || die "configure failed"
- emake || die "Compilation failed"
-
- if use doc; then
- make html || die 'html compilation failed'
- fi
-
- use emacs && elisp-compile contrib/*.el
-}
-
-src_test() {
- make check || die "self test failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- mv "${D}"/usr/share/doc/"${PN}" "${D}"/usr/share/doc/"${PF}"
-
- dobashcompletion contrib/monotone.bash_completion
-
- if use doc; then
- dohtml -r html/*
- dohtml -r figures
- fi
-
- if use emacs; then
- elisp-install ${PN} contrib/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/30monotone-gentoo.el
- fi
-
- dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README* UPGRADE
- docinto contrib
- dodoc contrib/*
- newconfd "${FILESDIR}"/monotone.confd monotone
- newinitd "${FILESDIR}"/${P}.initd monotone
-
- insinto /etc/monotone ;
- newins "${FILESDIR}"/hooks.lua hooks.lua
- newins "${FILESDIR}"/read-permissions read-permissions
- newins "${FILESDIR}"/write-permissions write-permissions
-
- keepdir /var/lib/monotone/keys/ /var/log/monotone /var/run/monotone
- fowners monotone:monotone /var/lib/monotone /var/lib/monotone/keys/ \
- /var/log/monotone /var/run/monotone
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- bash-completion_pkg_postinst
-
- elog
- elog "For details and instructions to upgrade from previous versions,"
- elog "please read /usr/share/doc/${PF}/UPGRADE.gz"
- elog
- elog " 1. edit /etc/conf.d/monotone"
- elog " 2. import the first keys to enable access with"
- elog " env HOME=\${homedir} mtn pubkey me@example.net | /etc/init.d/monotone import"
- elog " Thereafter, those with write permission can add other keys via"
- elog " netsync with 'monotone push --key-to-push=IDENT' and then IDENT"
- elog " can be used in the read-permission and write-permission files."
- elog " 3. adjust permisions in /etc/monotone/read-permissions"
- elog " and /etc/monotone/write-permissions"
- elog " 4. start the daemon: /etc/init.d/monotone start"
- elog " 5. make persistent: rc-update add monotone default"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/monotone/monotone-0.35.ebuild b/dev-util/monotone/monotone-0.35.ebuild
index f93e82881677..15206d9a5373 100644
--- a/dev-util/monotone/monotone-0.35.ebuild
+++ b/dev-util/monotone/monotone-0.35.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.35.ebuild,v 1.6 2007/10/24 00:50:26 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.35.ebuild,v 1.7 2008/04/02 02:11:15 dragonheart Exp $
inherit elisp-common flag-o-matic bash-completion eutils
@@ -72,7 +72,7 @@ src_install() {
elisp-site-file-install "${FILESDIR}"/30monotone-gentoo.el
fi
- dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README* UPGRADE
+ dodoc AUTHORS ChangeLog NEWS README* UPGRADE
docinto contrib
dodoc contrib/*
newconfd "${FILESDIR}"/monotone.confd monotone
diff --git a/dev-util/monotone/monotone-0.36-r1.ebuild b/dev-util/monotone/monotone-0.36-r1.ebuild
index 3e3c68663fc2..650fd046c431 100644
--- a/dev-util/monotone/monotone-0.36-r1.ebuild
+++ b/dev-util/monotone/monotone-0.36-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.36-r1.ebuild,v 1.1 2007/10/26 20:30:28 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.36-r1.ebuild,v 1.2 2008/04/02 02:11:15 dragonheart Exp $
inherit elisp-common flag-o-matic bash-completion eutils
@@ -71,7 +71,7 @@ src_install() {
|| die "elisp-site-file-install failed"
fi
- dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README* UPGRADE
+ dodoc AUTHORS ChangeLog NEWS README* UPGRADE
docinto contrib
dodoc contrib/*
newconfd "${FILESDIR}"/monotone.confd monotone
diff --git a/dev-util/monotone/monotone-0.36.ebuild b/dev-util/monotone/monotone-0.39.ebuild
index 55b6d67b473e..74ec150042ad 100644
--- a/dev-util/monotone/monotone-0.36.ebuild
+++ b/dev-util/monotone/monotone-0.39.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.36.ebuild,v 1.1 2007/10/07 12:34:02 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.39.ebuild,v 1.1 2008/04/02 02:11:15 dragonheart Exp $
inherit elisp-common flag-o-matic bash-completion eutils
@@ -14,11 +14,12 @@ KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
IUSE="doc emacs ipv6 nls"
-RDEPEND=">=dev-libs/boost-1.33.1
+RDEPEND="
sys-libs/zlib
emacs? ( virtual/emacs )"
DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.33.1
nls? ( >=sys-devel/gettext-0.11.5 )
doc? ( sys-apps/texinfo )"
@@ -28,6 +29,10 @@ pkg_setup() {
if [[ "$(gcc-version)" == "3.3" ]]; then
die 'requires >=gcc-3.4'
fi
+ # https://bugs.gentoo.org/show_bug.cgi?id=202371#c2
+ if ! has userpriv ${FEATURES} && has test ${FEATURES}; then
+ ewarn "No test will be performed due to lack of FEATURES=userpriv"
+ fi
}
src_compile() {
@@ -43,11 +48,18 @@ src_compile() {
emake html || die 'html compilation failed'
fi
- use emacs && elisp-compile contrib/*.el
+ if use emacs; then
+ cd contrib
+ elisp-comp *.el || die "elisp-comp failed"
+ fi
}
src_test() {
- emake check || die "self test failed"
+ if has userpriv ${FEATURES}; then
+ emake check || die "self test failed"
+ else
+ ewarn 'not tested - requires FEATURES=userpriv'
+ fi
}
src_install() {
@@ -63,11 +75,12 @@ src_install() {
fi
if use emacs; then
- elisp-install ${PN} contrib/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/30monotone-gentoo.el
+ elisp-install ${PN} contrib/*.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el \
+ || die "elisp-site-file-install failed"
fi
- dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README* UPGRADE
+ dodoc AUTHORS ChangeLog NEWS README* UPGRADE
docinto contrib
dodoc contrib/*
newconfd "${FILESDIR}"/monotone.confd monotone
@@ -89,7 +102,7 @@ pkg_postinst() {
elog
elog "For details and instructions to upgrade from previous versions,"
- elog "please read /usr/share/doc/${PF}/UPGRADE.gz"
+ elog "please read /usr/share/doc/${PF}/UPGRADE.bz2"
elog
elog " 1. edit /etc/conf.d/monotone"
elog " 2. import the first keys to enable access with"