summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-07 19:25:10 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-07 19:25:10 +0000
commit6d17b5e4ddcf146c30fd30c94054a9d8d90c0bb7 (patch)
treea42271205ed80ff920b7ab14f24aa8749e9648de /dev-util/mpatch
parentStable for HPPA (bug #360595). (diff)
downloadgentoo-2-6d17b5e4ddcf146c30fd30c94054a9d8d90c0bb7.tar.gz
gentoo-2-6d17b5e4ddcf146c30fd30c94054a9d8d90c0bb7.tar.bz2
gentoo-2-6d17b5e4ddcf146c30fd30c94054a9d8d90c0bb7.zip
Use Python 2 (bug #326107).
(Portage version: 2.2.0_alpha29_p10/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/mpatch')
-rw-r--r--dev-util/mpatch/ChangeLog8
-rw-r--r--dev-util/mpatch/mpatch-0.8.ebuild16
2 files changed, 18 insertions, 6 deletions
diff --git a/dev-util/mpatch/ChangeLog b/dev-util/mpatch/ChangeLog
index 6a9b9e5d068e..bb17966d331b 100644
--- a/dev-util/mpatch/ChangeLog
+++ b/dev-util/mpatch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/mpatch
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mpatch/ChangeLog,v 1.1 2007/08/18 22:19:42 robbat2 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mpatch/ChangeLog,v 1.2 2011/04/07 19:25:10 arfrever Exp $
+
+ 07 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ mpatch-0.8.ebuild:
+ Use Python 2 (bug #326107).
*mpatch-0.8 (18 Aug 2007)
diff --git a/dev-util/mpatch/mpatch-0.8.ebuild b/dev-util/mpatch/mpatch-0.8.ebuild
index ac0d9f3369db..f7df8263d546 100644
--- a/dev-util/mpatch/mpatch-0.8.ebuild
+++ b/dev-util/mpatch/mpatch-0.8.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mpatch/mpatch-0.8.ebuild,v 1.1 2007/08/18 22:19:42 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mpatch/mpatch-0.8.ebuild,v 1.2 2011/04/07 19:25:10 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
inherit distutils
@@ -13,10 +16,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~ppc"
IUSE=""
-DEPEND="dev-lang/python"
+DEPEND=""
RDEPEND=""
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_install() {
distutils_src_install
- dobin cmd/qp cmd/mp
+ dobin cmd/qp cmd/mp || die "dobin failed"
}