summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-06-21 04:35:39 +0000
committerMike Gilbert <floppym@gentoo.org>2013-06-21 04:35:39 +0000
commit28f8c6a7e87419ac299a5472e107f8e9363f0e49 (patch)
tree9199f3265f8bfbaef1d70845f964f13e6b36b098 /dev-util/ninja
parentRemove obsolete patches. (diff)
downloadgentoo-2-28f8c6a7e87419ac299a5472e107f8e9363f0e49.tar.gz
gentoo-2-28f8c6a7e87419ac299a5472e107f8e9363f0e49.tar.bz2
gentoo-2-28f8c6a7e87419ac299a5472e107f8e9363f0e49.zip
Version bump.
(Portage version: 2.2.0_alpha181/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-util/ninja')
-rw-r--r--dev-util/ninja/ChangeLog7
-rw-r--r--dev-util/ninja/ninja-1.3.4.ebuild105
2 files changed, 111 insertions, 1 deletions
diff --git a/dev-util/ninja/ChangeLog b/dev-util/ninja/ChangeLog
index 64effa81ab8c..c735736d6851 100644
--- a/dev-util/ninja/ChangeLog
+++ b/dev-util/ninja/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ninja
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ChangeLog,v 1.12 2013/05/28 03:51:35 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ChangeLog,v 1.13 2013/06/21 04:35:39 floppym Exp $
+
+*ninja-1.3.4 (21 Jun 2013)
+
+ 21 Jun 2013; Mike Gilbert <floppym@gentoo.org> +ninja-1.3.4.ebuild:
+ Version bump.
*ninja-1.3.3 (28 May 2013)
diff --git a/dev-util/ninja/ninja-1.3.4.ebuild b/dev-util/ninja/ninja-1.3.4.ebuild
new file mode 100644
index 000000000000..0328418c9f1d
--- /dev/null
+++ b/dev-util/ninja/ninja-1.3.4.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ninja-1.3.4.ebuild,v 1.1 2013/06/21 04:35:39 floppym Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit bash-completion-r1 elisp-common python-any-r1 toolchain-funcs
+
+if [ "${PV}" = "999999" ]; then
+ EGIT_REPO_URI="git://github.com/martine/ninja.git http://github.com/martine/ninja.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/martine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+fi
+
+DESCRIPTION="A small build system similar to make."
+HOMEPAGE="http://github.com/martine/ninja"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="doc emacs test vim-syntax zsh-completion"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-util/re2c
+ doc? (
+ app-text/asciidoc
+ app-doc/doxygen
+ dev-libs/libxslt
+ )
+ test? ( dev-cpp/gtest )
+"
+RDEPEND="
+ emacs? ( virtual/emacs )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+ zsh-completion? ( app-shells/zsh )
+ !<net-irc/ninja-1.5.9_pre14-r1" #436804
+
+src_compile() {
+ # If somebody wants to cross-compile, we will probably need to do 2 builds.
+ tc-export CXX
+
+ "${PYTHON}" bootstrap.py --verbose || die
+
+ if use doc; then
+ ./ninja -v doxygen manual || die
+ fi
+
+ if use emacs; then
+ elisp-compile misc/ninja-mode.el || die
+ fi
+}
+
+src_test() {
+ ./ninja -v ninja_test || die
+ ./ninja_test || die
+}
+
+src_install() {
+ dodoc README HACKING.md
+ if use doc; then
+ dohtml -r doc/doxygen/html/*
+ dohtml doc/manual.html
+ fi
+ dobin ninja
+
+ newbashcomp misc/bash-completion "${PN}"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins misc/"${PN}".vim
+
+ echo 'au BufNewFile,BufRead *.ninja set ft=ninja' > "${T}/${PN}.vim"
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${T}/${PN}.vim"
+ fi
+
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ newins misc/zsh-completion _ninja
+ fi
+
+ if use emacs; then
+ cd misc || die
+ elisp-install ${PN} ninja-mode.el* || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}